aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/py-pyeapi
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-05 04:36:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-05 04:36:58 +0000
commitf1d46c4a3e60a42969595ee875991799fd92a059 (patch)
treeba5b9195af0f06e0b58afe3ea5f38bc54ad3bb32 /net-mgmt/py-pyeapi
parentb6231eced9ff1df7e4b7191929b7898c179e912c (diff)
downloadports-f1d46c4a3e60a42969595ee875991799fd92a059.tar.gz
ports-f1d46c4a3e60a42969595ee875991799fd92a059.zip
New port: net-mgmt/py-pyeapi: Python client for Arista eAPI
PR: 227078 Submitted by: Kai <freebsd_ports@k-worx.org>
Notes
Notes: svn path=/head/; revision=466530
Diffstat (limited to 'net-mgmt/py-pyeapi')
-rw-r--r--net-mgmt/py-pyeapi/Makefile21
-rw-r--r--net-mgmt/py-pyeapi/distinfo3
-rw-r--r--net-mgmt/py-pyeapi/pkg-descr12
3 files changed, 36 insertions, 0 deletions
diff --git a/net-mgmt/py-pyeapi/Makefile b/net-mgmt/py-pyeapi/Makefile
new file mode 100644
index 000000000000..7ff5b15e2b31
--- /dev/null
+++ b/net-mgmt/py-pyeapi/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= pyeapi
+DISTVERSION= 0.8.2
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Python client for Arista eAPI
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}netaddr>0:net/py-netaddr@${FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-pyeapi/distinfo b/net-mgmt/py-pyeapi/distinfo
new file mode 100644
index 000000000000..6acb6ce29652
--- /dev/null
+++ b/net-mgmt/py-pyeapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522340692
+SHA256 (pyeapi-0.8.2.tar.gz) = 5be222c290e9e14827ee15541f0e61e290e0223bdead6151233aa7baa5b1b3c8
+SIZE (pyeapi-0.8.2.tar.gz) = 133732
diff --git a/net-mgmt/py-pyeapi/pkg-descr b/net-mgmt/py-pyeapi/pkg-descr
new file mode 100644
index 000000000000..48cfdd63f760
--- /dev/null
+++ b/net-mgmt/py-pyeapi/pkg-descr
@@ -0,0 +1,12 @@
+The Python library for Arista's eAPI command API implementation provides a
+client API work using eAPI and communicating with EOS nodes. The Python
+library can be used to communicate with EOS either locally (on-box) or remotely
+(off-box). It uses a standard INI-style configuration file to specify one or
+more nodes and connection properties.
+
+The pyeapi library also provides an API layer for building native Python
+objects to interact with the destination nodes. The API layer is a convenient
+implementation for working with the EOS configuration and is extensible for
+developing custom implementations.
+
+WWW: https://github.com/arista-eosplus/pyeapi