aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/py-pysmi
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-20 19:19:28 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-20 19:19:28 +0000
commitc33ac1f58cfb147e625f875c799cdc28f318a7c2 (patch)
treed57a131fe3366331b6bf93f4c5b3d19bf763a9d1 /net-mgmt/py-pysmi
parent84af718070a00d77e414d994f2a49a61a48b800a (diff)
downloadports-c33ac1f58cfb147e625f875c799cdc28f318a7c2.tar.gz
ports-c33ac1f58cfb147e625f875c799cdc28f318a7c2.zip
Update to 0.3.0
- Update WWW Changes: https://github.com/etingof/pysmi/releases PR: 228380 Submitted by: John W. O'Brien <john@saltant.com> (maintainer)
Notes
Notes: svn path=/head/; revision=470482
Diffstat (limited to 'net-mgmt/py-pysmi')
-rw-r--r--net-mgmt/py-pysmi/Makefile12
-rw-r--r--net-mgmt/py-pysmi/distinfo6
-rw-r--r--net-mgmt/py-pysmi/files/patch-setup.py13
-rw-r--r--net-mgmt/py-pysmi/files/tests__init__.py20
-rw-r--r--net-mgmt/py-pysmi/pkg-descr2
5 files changed, 10 insertions, 43 deletions
diff --git a/net-mgmt/py-pysmi/Makefile b/net-mgmt/py-pysmi/Makefile
index 5136fab20084..2dfdb0b43f19 100644
--- a/net-mgmt/py-pysmi/Makefile
+++ b/net-mgmt/py-pysmi/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= pysmi
-PORTVERSION= 0.2.2
+PORTVERSION= 0.3.0
CATEGORIES= net-mgmt python
MASTER_SITES= CHEESESHOP \
SF/pysmi/pysmi/${PORTVERSION}
@@ -13,12 +13,13 @@ COMMENT= SNMP/SMI MIB parsing in Python
LICENSE= BSD2CLAUSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}snmp4>=0:net-mgmt/py-snmp4@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply@${FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ply>=0:devel/py-ply@${FLAVOR}
NO_ARCH= yes
-USES= python shebangfix
+USES= python
USE_PYTHON= autoplist concurrent distutils
-SHEBANG_FILES= scripts/mibdump.py
OPTIONS_DEFINE= DOCS EXAMPLES
@@ -27,9 +28,8 @@ PORTEXAMPLES= *
BASEDOCS= CHANGES.rst README.md THANKS.txt TODO.txt
-post-patch:
- ${CP} ${FILESDIR}/tests__init__.py ${WRKSRC}/tests/__init__.py
- ${MV} ${WRKSRC}/tests ${WRKSRC}/${PORTNAME}
+post-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test)
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/net-mgmt/py-pysmi/distinfo b/net-mgmt/py-pysmi/distinfo
index 46ef2d03a3e5..02dd14382b43 100644
--- a/net-mgmt/py-pysmi/distinfo
+++ b/net-mgmt/py-pysmi/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1514129467
-SHA256 (pysmi-0.2.2.tar.gz) = 2a315cc3e556b3428372b69da663a24d2f0df9e9ab075b022cb133855f25aef7
-SIZE (pysmi-0.2.2.tar.gz) = 90568
+TIMESTAMP = 1526841426
+SHA256 (pysmi-0.3.0.tar.gz) = 87b464df6e68dedc28959f3d16b57d5138c8959c0af5cdea9747df26e20858fc
+SIZE (pysmi-0.3.0.tar.gz) = 92850
diff --git a/net-mgmt/py-pysmi/files/patch-setup.py b/net-mgmt/py-pysmi/files/patch-setup.py
deleted file mode 100644
index d370dcf1c3ed..000000000000
--- a/net-mgmt/py-pysmi/files/patch-setup.py
+++ /dev/null
@@ -1,13 +0,0 @@
---- setup.py.orig 2017-12-24 15:32:10 UTC
-+++ setup.py
-@@ -112,7 +112,9 @@ params.update({
- 'pysmi.parser',
- 'pysmi.codegen',
- 'pysmi.borrower',
-- 'pysmi.writer'],
-+ 'pysmi.writer',
-+ 'pysmi.tests',
-+ ],
- 'scripts': [os.path.join('scripts', 'mibdump.py')]
- })
-
diff --git a/net-mgmt/py-pysmi/files/tests__init__.py b/net-mgmt/py-pysmi/files/tests__init__.py
deleted file mode 100644
index 598f43930ba6..000000000000
--- a/net-mgmt/py-pysmi/files/tests__init__.py
+++ /dev/null
@@ -1,20 +0,0 @@
-from unittest import SkipTest, TestSuite
-
-
-def load_tests(*args, **kwargs):
- import suite
- return suite.suite
-
-
-try:
- from pysnmp.smi.builder import MibBuilder
-except ImportError:
-
- # python -m unittest pysmi.tests
- def load_tests(*args, **kwars):
- print("Skipping test suite: pysnmp is not installed")
- return TestSuite()
-
- # nosetests pysmi
- def setup():
- raise SkipTest("pysnmp is not installed")
diff --git a/net-mgmt/py-pysmi/pkg-descr b/net-mgmt/py-pysmi/pkg-descr
index cf87382da5b9..1c2c9bf4dbc2 100644
--- a/net-mgmt/py-pysmi/pkg-descr
+++ b/net-mgmt/py-pysmi/pkg-descr
@@ -1,3 +1,3 @@
Pure-Python implementation of SNMP/SMI MIB parsing and conversion library
-WWW: http://pysmi.sourceforge.net/
+WWW: http://snmplabs.com/pysmi/