aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/rotorouter/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-02-01 02:19:04 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-02-01 02:19:04 +0000
commit0a2ec00aa646f0ab8f5d4cbbfb70d8661488f304 (patch)
treeff194c2427549c496948e0a745d749eeddf39a94 /net-mgmt/rotorouter/Makefile
parent8c26415f885c1109dff4ad76ba7bde001eb4cdfb (diff)
Notes
Diffstat (limited to 'net-mgmt/rotorouter/Makefile')
-rw-r--r--net-mgmt/rotorouter/Makefile19
1 files changed, 8 insertions, 11 deletions
diff --git a/net-mgmt/rotorouter/Makefile b/net-mgmt/rotorouter/Makefile
index b4622113ae02..0ad787003252 100644
--- a/net-mgmt/rotorouter/Makefile
+++ b/net-mgmt/rotorouter/Makefile
@@ -19,28 +19,25 @@ COMMENT= Traceroute attempt logger and result spoofer
NO_WRKSUBDIR= yes
-SED_SCRIPT+= -e 's,%%PREFIX%%,${PREFIX},g' \
- -e 's,%%RC_SUBR%%,${RC_SUBR},g'
+SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
+USE_RC_SUBR= rotorouter
-USE_RC_SUBR= yes
+.include <bsd.port.pre.mk>
do-extract:
- ${MKDIR} ${WRKSRC}
- ${CP} ${FILESDIR}/rotorouter.c ${WRKSRC}
+ ${MKDIR} ${WRKSRC}/src
+ ${CP} ${FILESDIR}/rotorouter.c ${WRKSRC}/src
do-build:
- ${CC} -lpcap -o ${WRKSRC}/rotorouter ${WRKSRC}/rotorouter.c
- ${SED} ${SED_SCRIPT} < ${FILESDIR}/rotorouter.sh > ${WRKSRC}/rotorouter.sh
+ ${CC} -lpcap -o ${WRKSRC}/src/rotorouter ${WRKSRC}/src/rotorouter.c
do-install:
@${INSTALL_DATA} -m 640 ${FILESDIR}/rotorouter.conf-example ${PREFIX}/etc
@${INSTALL_DATA} -m 640 ${FILESDIR}/rotorouter.conf-example ${PREFIX}/etc/rotorouter.conf
- @${INSTALL_PROGRAM} ${WRKSRC}/rotorouter ${PREFIX}/sbin/
- @${INSTALL_SCRIPT} -m 751 ${WRKSRC}/rotorouter.sh ${PREFIX}/etc/rc.d/rotorouter.sh
+ @${INSTALL_PROGRAM} ${WRKSRC}/src/rotorouter ${PREFIX}/sbin
post-install:
- @${SED} ${SED_SCRIPT} < ${PKGMESSAGE}
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>