aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/rubygem-riemann-dash
diff options
context:
space:
mode:
authorDave Cottlehuber <dch@FreeBSD.org>2019-05-24 07:18:19 +0000
committerDave Cottlehuber <dch@FreeBSD.org>2019-05-24 07:18:19 +0000
commit059320610e5c13bfe070bab1692db186db7686fd (patch)
tree0651c75a7b954e377358555aa7bd8925bbaaabd8 /net-mgmt/rubygem-riemann-dash
parentbd7906540bc6170ec89f9da48a81b45d20591ee1 (diff)
downloadports-059320610e5c13bfe070bab1692db186db7686fd.tar.gz
ports-059320610e5c13bfe070bab1692db186db7686fd.zip
net-mgmt/rubygem-riemann-*: new ports for the riemann.io suite
Riemann [net-mgmt/riemann] is a streaming event monitoring system designed for monitoring distributed systems in real time. This commit introduces the following gems: - rubygem-riemann-client - rubygem-riemann-dash - rubygem-riemann-rabbitmq - rubygem-riemann-tail - rubygem-riemann-tools Which allows connecting to riemann, to set & query events and the index, to view event status in real-time, whether as a dashboard of events, or as a classic tail in the terminal. An additional comprehensive set of integrations for popular tools such as Varnish, Haproxy, nginx, RabbitMQ, and more, are included in the riemann-tools gem. More information about Riemann in general is at https://riemann.io/ Reviewed by: romain Approved by: jrm (mentor) Differential Revision: https://reviews.freebsd.org/D17710
Notes
Notes: svn path=/head/; revision=502425
Diffstat (limited to 'net-mgmt/rubygem-riemann-dash')
-rw-r--r--net-mgmt/rubygem-riemann-dash/Makefile35
-rw-r--r--net-mgmt/rubygem-riemann-dash/distinfo3
-rw-r--r--net-mgmt/rubygem-riemann-dash/files/patch-riemann-dash.gemspec28
-rw-r--r--net-mgmt/rubygem-riemann-dash/pkg-descr6
-rw-r--r--net-mgmt/rubygem-riemann-dash/pkg-plist78
5 files changed, 150 insertions, 0 deletions
diff --git a/net-mgmt/rubygem-riemann-dash/Makefile b/net-mgmt/rubygem-riemann-dash/Makefile
new file mode 100644
index 000000000000..335965bf5d61
--- /dev/null
+++ b/net-mgmt/rubygem-riemann-dash/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= riemann-dash
+DISTVERSION= 0.2.14
+CATEGORIES= net-mgmt rubygems
+MASTER_SITES= RG
+
+MAINTAINER= dch@FreeBSD.org
+COMMENT= Configurable websocket/javascript based dashboard for net-mgmt/riemann
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-multi_json>=0:devel/rubygem-multi_json \
+ rubygem-sass>=0:textproc/rubygem-sass \
+ rubygem-erubis>=0:www/rubygem-erubis \
+ rubygem-sinatra>=0:www/rubygem-sinatra
+
+USES= gem
+
+NO_ARCH= yes
+USE_RUBY= yes
+
+post-install:
+ # move the public HTML files into DATADIR for webservers
+ # even when the package version & path changes
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${MV} ${STAGEDIR}${PREFIX}/${GEM_LIB_DIR}/lib/riemann/dash/public \
+ ${STAGEDIR}${DATADIR}/www
+# the eruby template is valid HTML so drop it into public dir
+ # and it can all be served directly via your webserver
+ ${CP} ${WRKSRC}/lib/riemann/dash/views/index.erubis \
+ ${STAGEDIR}${DATADIR}/www/index.html
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/rubygem-riemann-dash/distinfo b/net-mgmt/rubygem-riemann-dash/distinfo
new file mode 100644
index 000000000000..abd6550c7707
--- /dev/null
+++ b/net-mgmt/rubygem-riemann-dash/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1545758428
+SHA256 (rubygem/riemann-dash-0.2.14.gem) = 79338bf9e13d02aa0446d021422a59eb18b2b4c8ee5e4314a1a5efb0ec3466c0
+SIZE (rubygem/riemann-dash-0.2.14.gem) = 335360
diff --git a/net-mgmt/rubygem-riemann-dash/files/patch-riemann-dash.gemspec b/net-mgmt/rubygem-riemann-dash/files/patch-riemann-dash.gemspec
new file mode 100644
index 000000000000..87646d8a3a9a
--- /dev/null
+++ b/net-mgmt/rubygem-riemann-dash/files/patch-riemann-dash.gemspec
@@ -0,0 +1,28 @@
+--- riemann-dash.gemspec.orig 2018-12-25 17:47:00 UTC
++++ riemann-dash.gemspec
+@@ -24,23 +24,10 @@ Gem::Specification.new do |s|
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+ s.add_runtime_dependency(%q<erubis>.freeze, [">= 2.7.0"])
+- s.add_runtime_dependency(%q<sinatra>.freeze, ["~> 1.4.5"])
++ s.add_runtime_dependency(%q<sinatra>.freeze, [">= 1.4.5"])
+ s.add_runtime_dependency(%q<sass>.freeze, [">= 3.1.14"])
+- s.add_runtime_dependency(%q<webrick>.freeze, ["~> 1.3.1"])
+- s.add_runtime_dependency(%q<multi_json>.freeze, ["= 1.3.6"])
+- else
+- s.add_dependency(%q<erubis>.freeze, [">= 2.7.0"])
+- s.add_dependency(%q<sinatra>.freeze, ["~> 1.4.5"])
+- s.add_dependency(%q<sass>.freeze, [">= 3.1.14"])
+- s.add_dependency(%q<webrick>.freeze, ["~> 1.3.1"])
+- s.add_dependency(%q<multi_json>.freeze, ["= 1.3.6"])
++ s.add_runtime_dependency(%q<multi_json>.freeze, [">= 1.3.6"])
+ end
+- else
+- s.add_dependency(%q<erubis>.freeze, [">= 2.7.0"])
+- s.add_dependency(%q<sinatra>.freeze, ["~> 1.4.5"])
+- s.add_dependency(%q<sass>.freeze, [">= 3.1.14"])
+- s.add_dependency(%q<webrick>.freeze, ["~> 1.3.1"])
+- s.add_dependency(%q<multi_json>.freeze, ["= 1.3.6"])
+ end
+ end
+
diff --git a/net-mgmt/rubygem-riemann-dash/pkg-descr b/net-mgmt/rubygem-riemann-dash/pkg-descr
new file mode 100644
index 000000000000..bc6d19d61056
--- /dev/null
+++ b/net-mgmt/rubygem-riemann-dash/pkg-descr
@@ -0,0 +1,6 @@
+Wraps a pretty HTTP console around the Riemann real-time streaming event
+system, enabling dashboards from any web browser. Uses javascripts and
+websockets under the hood, and can be served from any static file HTTP
+server, or via ruby to allow users to edit and save the configuration.
+
+WWW: https://github.com/riemann/riemann-dash
diff --git a/net-mgmt/rubygem-riemann-dash/pkg-plist b/net-mgmt/rubygem-riemann-dash/pkg-plist
new file mode 100644
index 000000000000..1765d83755bd
--- /dev/null
+++ b/net-mgmt/rubygem-riemann-dash/pkg-plist
@@ -0,0 +1,78 @@
+bin/riemann-dash
+@comment relocated public web files
+@dir(root,wheel,755) %%DATADIR%%/www
+%%DATADIR%%/www/clock.js
+%%DATADIR%%/www/dash.js
+%%DATADIR%%/www/eventPane.js
+%%DATADIR%%/www/favicon.ico
+%%DATADIR%%/www/format.js
+%%DATADIR%%/www/index.html
+%%DATADIR%%/www/keys.js
+%%DATADIR%%/www/persistence.js
+%%DATADIR%%/www/profile.js
+%%DATADIR%%/www/sounds/beep.wav
+%%DATADIR%%/www/sounds/geiger.wav
+%%DATADIR%%/www/strings.js
+%%DATADIR%%/www/subs.js
+%%DATADIR%%/www/toolbar.js
+%%DATADIR%%/www/util.js
+%%DATADIR%%/www/vendor/PriorityQueue.js
+%%DATADIR%%/www/vendor/backbone.js
+%%DATADIR%%/www/vendor/flot/jquery.colorhelpers.js
+%%DATADIR%%/www/vendor/flot/jquery.colorhelpers.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.canvas.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.canvas.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.categories.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.categories.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.crosshair.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.crosshair.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.errorbars.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.errorbars.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.fillbetween.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.fillbetween.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.image.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.image.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.navigate.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.navigate.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.pie.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.pie.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.resize.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.resize.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.selection.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.selection.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.stack.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.stack.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.symbol.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.symbol.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.threshold.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.threshold.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.time.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.time.min.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.tooltip.js
+%%DATADIR%%/www/vendor/flot/jquery.flot.tooltip.min.js
+%%DATADIR%%/www/vendor/gauge.min.js
+%%DATADIR%%/www/vendor/jquery.gauge.js
+%%DATADIR%%/www/vendor/jquery/jquery-1.9.1.min.js
+%%DATADIR%%/www/vendor/jquery/jquery-1.9.1.min.map
+%%DATADIR%%/www/vendor/jquery/jquery-ui-1.10.2.custom.min.js
+%%DATADIR%%/www/vendor/jquery/jquery.quickfit.js
+%%DATADIR%%/www/vendor/jquery/jquery.simplemodal.1.4.4.min.js
+%%DATADIR%%/www/vendor/lodash.min.js
+%%DATADIR%%/www/vendor/smoothie.js
+%%DATADIR%%/www/vendor/toastr/toastr.css
+%%DATADIR%%/www/vendor/toastr/toastr.js
+%%DATADIR%%/www/view.js
+%%DATADIR%%/www/views/dial.js
+%%DATADIR%%/www/views/flot.js
+%%DATADIR%%/www/views/gauge.js
+%%DATADIR%%/www/views/geiger.js
+%%DATADIR%%/www/views/grid.js
+%%DATADIR%%/www/views/help.js
+%%DATADIR%%/www/views/iframe.js
+%%DATADIR%%/www/views/list.js
+%%DATADIR%%/www/views/log.js
+%%DATADIR%%/www/views/timeseries.js
+%%DATADIR%%/www/views/title.js
+%%DATADIR%%/www/x.png