aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/sdig
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2011-06-13 22:41:54 +0000
committerWesley Shields <wxs@FreeBSD.org>2011-06-13 22:41:54 +0000
commit21344878d485ab7992f474bdda305572c6eaa739 (patch)
treeb11909e4462b674f6f24b70b91414080d3b7a3ef /net-mgmt/sdig
parentd674aa8faad97738f47eeb35324516144ff81efc (diff)
downloadports-21344878d485ab7992f474bdda305572c6eaa739.tar.gz
ports-21344878d485ab7992f474bdda305572c6eaa739.zip
- Update to 0.45.
PR: ports/157440 Submitted by: Ryan Steinmetz <rpsfa@rit.edu> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=275509
Diffstat (limited to 'net-mgmt/sdig')
-rw-r--r--net-mgmt/sdig/Makefile16
-rw-r--r--net-mgmt/sdig/distinfo4
-rw-r--r--net-mgmt/sdig/files/patch-sdig.conf20
-rw-r--r--net-mgmt/sdig/files/patch-sdig.conf.520
-rw-r--r--net-mgmt/sdig/files/patch-src-output.c14
-rw-r--r--net-mgmt/sdig/pkg-message2
6 files changed, 71 insertions, 5 deletions
diff --git a/net-mgmt/sdig/Makefile b/net-mgmt/sdig/Makefile
index f33359bb6bc0..d365e76e6f7b 100644
--- a/net-mgmt/sdig/Makefile
+++ b/net-mgmt/sdig/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sdig
-PORTVERSION= 0.43
-PORTREVISION= 4
+PORTVERSION= 0.45
CATEGORIES= net-mgmt
MASTER_SITES= SF
@@ -21,6 +20,17 @@ GNU_CONFIGURE= yes
MAN5= sdig.conf.5
MAN8= sdig.8
-PLIST_FILES= bin/sdig etc/sdig.conf-sample etc/mactable-sample
+PLIST_FILES= bin/sdig etc/sdig.conf etc/mactable
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/sdig.conf
+ @${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' ${WRKSRC}/sdig.conf.5
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/sdig ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/sdig.conf ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/mactable ${PREFIX}/etc
+ ${INSTALL_MAN} ${WRKSRC}/sdig.8 ${PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/sdig.conf.5 ${PREFIX}/man/man5
.include <bsd.port.mk>
diff --git a/net-mgmt/sdig/distinfo b/net-mgmt/sdig/distinfo
index 844bd0bb43e6..c89e87e38259 100644
--- a/net-mgmt/sdig/distinfo
+++ b/net-mgmt/sdig/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sdig-0.43.tar.gz) = f12c265c443f8fd363db80077180aacd041aabc0a3ffdcc78c7c948a88077800
-SIZE (sdig-0.43.tar.gz) = 114754
+SHA256 (sdig-0.45.tar.gz) = 1af5a67d7ba0e804508d1492140ad48d61a8c253657666e110257e704e3bb73d
+SIZE (sdig-0.45.tar.gz) = 140398
diff --git a/net-mgmt/sdig/files/patch-sdig.conf b/net-mgmt/sdig/files/patch-sdig.conf
new file mode 100644
index 000000000000..3782e5499972
--- /dev/null
+++ b/net-mgmt/sdig/files/patch-sdig.conf
@@ -0,0 +1,20 @@
+--- sdig.conf.orig 2011-05-30 17:18:03.000000000 -0400
++++ sdig.conf 2011-05-30 17:18:25.000000000 -0400
+@@ -55,7 +55,7 @@
+ #
+ # Usual path is /usr/local/samba/bin
+
+-NMBLOOKUP /usr/local/samba/bin/nmblookup
++NMBLOOKUP %%PREFIX%%/bin/nmblookup
+
+ # ---------------------------------------------------------------------------
+ # MACTABLE <path to MAC table file>
+@@ -68,7 +68,7 @@
+ # rarely changes. If you want to use this feature, get it from the
+ # main web site: http://www.exploits.org/sdig/
+
+-MACTABLE /etc/mactable
++MACTABLE %%PREFIX%%/etc/mactable
+
+ # ---------------------------------------------------------------------------
+ # HOSTINFO <path to program>
diff --git a/net-mgmt/sdig/files/patch-sdig.conf.5 b/net-mgmt/sdig/files/patch-sdig.conf.5
new file mode 100644
index 000000000000..2073ff093fbf
--- /dev/null
+++ b/net-mgmt/sdig/files/patch-sdig.conf.5
@@ -0,0 +1,20 @@
+--- sdig.conf.5.orig 2011-05-30 17:21:10.000000000 -0400
++++ sdig.conf.5 2011-05-30 17:21:34.000000000 -0400
+@@ -109,7 +109,7 @@
+ This program is optional, and is provided to augment DNS lookups in
+ environments laden with Windows machines.
+
+- NMBLOOKUP /usr/local/samba/bin/nmblookup
++ NMBLOOKUP %%PREFIX%%/bin/nmblookup
+
+ .IP "MACTABLE \fIpath\fR"
+
+@@ -122,7 +122,7 @@
+ source distribution. You can get it on the main sdig web site -
+ http://www.exploits.org/sdig/
+
+- MACTABLE /etc/mactable
++ MACTABLE %%PREFIX%%/etc/mactable
+
+ .IP "HOSTINFO \fIpath\fR"
+
diff --git a/net-mgmt/sdig/files/patch-src-output.c b/net-mgmt/sdig/files/patch-src-output.c
new file mode 100644
index 000000000000..89cb8574c16a
--- /dev/null
+++ b/net-mgmt/sdig/files/patch-src-output.c
@@ -0,0 +1,14 @@
+--- src/output.c.orig 2011-05-30 16:52:55.000000000 -0400
++++ src/output.c 2011-05-30 16:53:21.000000000 -0400
+@@ -22,11 +22,6 @@
+ #ifdef SDIG_USE_SEMS
+
+ enum ops { UNLOCK = (int)1, LOCK = (int)(-1) };
+-union semun {
+- int val;
+- struct semid_ds *buf;
+- ushort *array;
+-};
+
+ int lock = 0;
+ // int pad = 0;
diff --git a/net-mgmt/sdig/pkg-message b/net-mgmt/sdig/pkg-message
new file mode 100644
index 000000000000..b3840b6625f0
--- /dev/null
+++ b/net-mgmt/sdig/pkg-message
@@ -0,0 +1,2 @@
+If you wish to use the NMBLOOKUP option within sdig, you must
+install net/samba-nmblookup (or net/samba).