aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/seafile-gui
diff options
context:
space:
mode:
authorNikolai Lifanov <lifanov@FreeBSD.org>2017-05-27 14:55:52 +0000
committerNikolai Lifanov <lifanov@FreeBSD.org>2017-05-27 14:55:52 +0000
commit5e83c645ea54cc6228b6ae112efa2fffcb0d1912 (patch)
tree5c35bf191700efd66f820f749050df18a72b3d4c /net-mgmt/seafile-gui
parentc5a29d7332740ddae384e83623cfe2361fbc1c8b (diff)
downloadports-5e83c645ea54cc6228b6ae112efa2fffcb0d1912.tar.gz
ports-5e83c645ea54cc6228b6ae112efa2fffcb0d1912.zip
update Seafile client bundle to 6.0.6
Ports affected: net-mgmt/seafile-client, net-mgmt/ccnet-client, net-mgmt/seafile-gui * Updated to 6.0.6 * Added Makefile.include to update version * Added target makesum-all for bundle - Sort files by numbers if numbers contained in the file name, so "1, 10, 2, 11, 3" will be sorted as "1, 2, 3, 10, 11". - Use native system window for Seafile main windown and cloud file browser window. - Fix progress overflow when uploading large file using cloud file browser - Improve the tip when removing an account in the client - Don't show download button when select folders in cloud file browser - Clean cache data of cloud file browser when logout an account or restart the client - [fix] Fix display problem for high screen Windows in win10 - [fix] Fix libssl compatibility problem in Debain Stretch - Add auto-update check PR: 219577 Submitted by: ultima1252@gmail.com (maintainer)
Notes
Notes: svn path=/head/; revision=441845
Diffstat (limited to 'net-mgmt/seafile-gui')
-rw-r--r--net-mgmt/seafile-gui/Makefile5
-rw-r--r--net-mgmt/seafile-gui/distinfo6
-rw-r--r--net-mgmt/seafile-gui/files/patch-CMakeLists.txt18
3 files changed, 15 insertions, 14 deletions
diff --git a/net-mgmt/seafile-gui/Makefile b/net-mgmt/seafile-gui/Makefile
index 20f459c976ee..6357b98ca9da 100644
--- a/net-mgmt/seafile-gui/Makefile
+++ b/net-mgmt/seafile-gui/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= seafile-gui
-PORTVERSION= 6.0.4
-PORTREVISION= 1
+PORTVERSION= ${SEAFILE_CLIENT_VER}
DISTVERSIONPREFIX= v
CATEGORIES= net-mgmt devel
@@ -40,4 +39,6 @@ OPTIONS_DEFINE= DEBUG
# Note that per PR 197984, cairo must be built with X11 and XCB options
# otherwise configure fails with "cairo needs x11 enabled" message
+.include "${.CURDIR}/../seafile-client/Makefile.include"
+
.include <bsd.port.mk>
diff --git a/net-mgmt/seafile-gui/distinfo b/net-mgmt/seafile-gui/distinfo
index cf46ac5bf1a3..8ea63d9f9b48 100644
--- a/net-mgmt/seafile-gui/distinfo
+++ b/net-mgmt/seafile-gui/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1487831002
-SHA256 (haiwen-seafile-client-v6.0.4_GH0.tar.gz) = 530c9f12176b69117f319fb3cfd5d2624825df20a44ea6760530a47bf60ba535
-SIZE (haiwen-seafile-client-v6.0.4_GH0.tar.gz) = 2173354
+TIMESTAMP = 1495806407
+SHA256 (haiwen-seafile-client-v6.0.6_GH0.tar.gz) = df3a587c5e93c4f53768b0724115889be2bead65d7910a31e637c3075690ea6b
+SIZE (haiwen-seafile-client-v6.0.6_GH0.tar.gz) = 2183317
diff --git a/net-mgmt/seafile-gui/files/patch-CMakeLists.txt b/net-mgmt/seafile-gui/files/patch-CMakeLists.txt
index c735257a5083..e6c5b8e007f3 100644
--- a/net-mgmt/seafile-gui/files/patch-CMakeLists.txt
+++ b/net-mgmt/seafile-gui/files/patch-CMakeLists.txt
@@ -1,15 +1,15 @@
---- CMakeLists.txt.orig 2016-04-29 04:32:14 UTC
+--- CMakeLists.txt.orig 2017-05-09 08:39:31 UTC
+++ CMakeLists.txt
-@@ -81,7 +81,7 @@ IF (WIN32)
+@@ -107,7 +107,7 @@ IF (WIN32)
+ SET(SPARKLE_LIBS ${CMAKE_SOURCE_DIR}/WinSparkle.lib)
ENDIF()
- SET(platform_specific_moc_headers src/ext-handler.h)
- SET(platform_specific_sources src/ext-handler.cpp)
--ELSEIF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD")
-+ELSEIF (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
+
+-ELSEIF (LINUX)
++ELSEIF (LINUX OR ${CMAKE_SYSTEM_NAME} MATCHES "BSD|DragonFly")
INCLUDE_DIRECTORIES(${QT_QTDBUS_INCLUDE_DIR})
LINK_DIRECTORIES(${QT_QTDBUS_LIBRARIES})
SET(EXTRA_LIBS ${EXTRA_LIBS} ${QT_QTDBUS_LIBRARIES})
-@@ -318,7 +318,7 @@ PKG_CHECK_MODULES(LIBCCNET REQUIRED libc
+@@ -360,7 +360,7 @@ PKG_CHECK_MODULES(LIBCCNET REQUIRED libccnet>=1.3)
PKG_CHECK_MODULES(LIBSEARPC REQUIRED libsearpc>=1.0)
@@ -18,7 +18,7 @@
PKG_CHECK_MODULES(LIBSEAFILE REQUIRED libseafile>=1.7)
-@@ -515,7 +515,7 @@ IF (WIN32)
+@@ -561,7 +561,7 @@ IF (WIN32)
src/utils/registry.cpp
src/utils/utils-win.cpp
)
@@ -27,7 +27,7 @@
LIST(APPEND utils_sources
src/utils/process-linux.cpp
)
-@@ -714,7 +714,7 @@ QT5_USE_MODULES(seafile-applet ${WEBKIT_
+@@ -761,7 +761,7 @@ QT5_USE_MODULES(seafile-applet ${WEBKIT_NAME} ${WEBKIT
ENDIF()
## QtBus