aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/send
diff options
context:
space:
mode:
authorBernard Spil <brnrd@FreeBSD.org>2016-12-10 21:03:31 +0000
committerBernard Spil <brnrd@FreeBSD.org>2016-12-10 21:03:31 +0000
commitc31e738ae22b9960fb9e5797ae7d3fddef1cead8 (patch)
tree9c5cb93b5c9e968062a65d9cb0c4eda5718303a6 /net-mgmt/send
parent17257140195f2cd3de75d11256be3fa7bad7395d (diff)
downloadports-c31e738ae22b9960fb9e5797ae7d3fddef1cead8.tar.gz
ports-c31e738ae22b9960fb9e5797ae7d3fddef1cead8.zip
net-mgmt/send: Fix LibreSSL build
- Add patch to fix building with LibreSSL - Register SSL dependency via USES= ssl Approved by: SSL blanket
Notes
Notes: svn path=/head/; revision=428324
Diffstat (limited to 'net-mgmt/send')
-rw-r--r--net-mgmt/send/Makefile2
-rw-r--r--net-mgmt/send/files/patch-include-pkixip_ext_asn.h27
2 files changed, 25 insertions, 4 deletions
diff --git a/net-mgmt/send/Makefile b/net-mgmt/send/Makefile
index b9baf719d173..7922807b65a0 100644
--- a/net-mgmt/send/Makefile
+++ b/net-mgmt/send/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libdnet.so:net/libdnet
-USES= gmake readline
+USES= gmake readline ssl
USE_RC_SUBR= sendd
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/net-mgmt/send/files/patch-include-pkixip_ext_asn.h b/net-mgmt/send/files/patch-include-pkixip_ext_asn.h
index 6ccde70c364c..92c93713306a 100644
--- a/net-mgmt/send/files/patch-include-pkixip_ext_asn.h
+++ b/net-mgmt/send/files/patch-include-pkixip_ext_asn.h
@@ -1,6 +1,6 @@
---- include/pkixip_ext_asn.h.orig 2010-08-28 17:58:02.000000000 +0900
-+++ include/pkixip_ext_asn.h 2014-08-30 01:54:23.000000000 +0900
-@@ -33,6 +33,10 @@
+--- include/pkixip_ext_asn.h.orig 2010-08-28 08:58:02 UTC
++++ include/pkixip_ext_asn.h
+@@ -33,7 +33,12 @@
#ifndef _PKIXIP_EXT_ASN_H
#define _PKIXIP_EXT_ASN_H
@@ -9,5 +9,26 @@
+#define STACK _STACK
+#endif
#include <openssl/asn1t.h>
++#include <openssl/asn1.h>
#include <openssl/err.h>
#include <openssl/x509v3.h>
+
+@@ -45,7 +50,7 @@
+ #define IANA_SAFI_BOTH 3
+ #define IANA_SAFI_MPLS 4
+
+-/*
++#ifdef LIBRESSL_VERSION_NUMBER
+ typedef struct IPAddressRange_st {
+ ASN1_BIT_STRING *min;
+ ASN1_BIT_STRING *max;
+@@ -79,7 +84,7 @@ typedef struct IPAddressFamily_st {
+ ASN1_OCTET_STRING *addressFamily;
+ IPAddressChoice *ipAddressChoice;
+ } IPAddressFamily;
+-*/
++#endif
+
+ #define IP_AOR_PREFIX 0
+ #define IP_AOR_RANGE 1
+