aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/sendip
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2003-06-04 14:34:24 +0000
committerMichael Landin <mich@FreeBSD.org>2003-06-04 14:34:24 +0000
commit7fb4d565259123fa3fd1ffe802ced860f3aa8cbf (patch)
tree9a08ceaa383ea0972b00e16ee323e1137e1f8d09 /net-mgmt/sendip
parent39a9b8453017a94321e3c541f7cdd29bef1ee0d5 (diff)
downloadports-7fb4d565259123fa3fd1ffe802ced860f3aa8cbf.tar.gz
ports-7fb4d565259123fa3fd1ffe802ced860f3aa8cbf.zip
Unbreak sendip build on -CURRENT.
PR: 52584 Submitted by: maintainer Approved by: roberto (mentor)
Notes
Notes: svn path=/head/; revision=82257
Diffstat (limited to 'net-mgmt/sendip')
-rw-r--r--net-mgmt/sendip/Makefile8
-rw-r--r--net-mgmt/sendip/files/patch-gnugetopt.c10
2 files changed, 11 insertions, 7 deletions
diff --git a/net-mgmt/sendip/Makefile b/net-mgmt/sendip/Makefile
index 76be1bce8c22..c846afd9f6b5 100644
--- a/net-mgmt/sendip/Makefile
+++ b/net-mgmt/sendip/Makefile
@@ -13,12 +13,6 @@ MASTER_SITES= http://www.earth.li/projectpurple/files/
MAINTAINER= joseph@randomnetworks.com
COMMENT= SendIP is a commandline tool to allow sending arbitrary IP packets
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
USE_GMAKE= yes
USE_REINPLACE= yes
USE_PERL5= yes
@@ -26,4 +20,4 @@ INSTALLS_SHLIB= yes
MAN1= sendip.1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/sendip/files/patch-gnugetopt.c b/net-mgmt/sendip/files/patch-gnugetopt.c
new file mode 100644
index 000000000000..65ec257ae5ad
--- /dev/null
+++ b/net-mgmt/sendip/files/patch-gnugetopt.c
@@ -0,0 +1,10 @@
+--- gnugetopt.c.orig Thu May 22 08:35:25 2003
++++ gnugetopt.c Thu May 22 08:35:37 2003
+@@ -45,6 +45,7 @@
+ #endif
+
+ #include <stdio.h>
++#include <string.h>
+
+ /* Comment out all this code if we are using the GNU C Library, and are not
+ actually compiling the library itself. This code is part of the GNU C