aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/sendip
diff options
context:
space:
mode:
authorHye-Shik Chang <perky@FreeBSD.org>2002-07-17 11:42:38 +0000
committerHye-Shik Chang <perky@FreeBSD.org>2002-07-17 11:42:38 +0000
commit977bb4a9a1011524dc672cd88d14f2ff2c807683 (patch)
treee36e63a7d0745c280e8266300751af707e336e0c /net-mgmt/sendip
parent766f87d735377bc048446354812af6e89ee3a50a (diff)
downloadports-977bb4a9a1011524dc672cd88d14f2ff2c807683.tar.gz
ports-977bb4a9a1011524dc672cd88d14f2ff2c807683.zip
Update to 2.1
PR: 40678 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=63129
Diffstat (limited to 'net-mgmt/sendip')
-rw-r--r--net-mgmt/sendip/Makefile9
-rw-r--r--net-mgmt/sendip/distinfo2
-rw-r--r--net-mgmt/sendip/files/patch-Makefile18
-rw-r--r--net-mgmt/sendip/files/patch-icmp.h18
-rw-r--r--net-mgmt/sendip/files/patch-types.h79
-rw-r--r--net-mgmt/sendip/pkg-plist9
6 files changed, 132 insertions, 3 deletions
diff --git a/net-mgmt/sendip/Makefile b/net-mgmt/sendip/Makefile
index 18ebf007f5df..2fc7cba7890c 100644
--- a/net-mgmt/sendip/Makefile
+++ b/net-mgmt/sendip/Makefile
@@ -6,14 +6,19 @@
#
PORTNAME= sendip
-PORTVERSION= 1.4
+PORTVERSION= 2.1
CATEGORIES= net
MASTER_SITES= http://www.earth.li/projectpurple/files/
MAINTAINER= joseph@randomnetworks.com
-WRKSRC= ${WRKDIR}/sendip
+USE_GMAKE= yes
+USE_REINPLACE= yes
MAN1= sendip.1
+pre-install:
+ ${REINPLACE_CMD} -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/Makefile;
+ ${REINPLACE_CMD} -e "s:/share/man/man1:/man/man1:g" ${WRKSRC}/Makefile;
+
.include <bsd.port.mk>
diff --git a/net-mgmt/sendip/distinfo b/net-mgmt/sendip/distinfo
index 746920e82be6..3ed76b5f2498 100644
--- a/net-mgmt/sendip/distinfo
+++ b/net-mgmt/sendip/distinfo
@@ -1 +1 @@
-MD5 (sendip-1.4.tar.gz) = f5b2a15d30e7d8359be25dcacdff663c
+MD5 (sendip-2.1.tar.gz) = 76b36e63f1b1139e86c7092ed7c010cc
diff --git a/net-mgmt/sendip/files/patch-Makefile b/net-mgmt/sendip/files/patch-Makefile
new file mode 100644
index 000000000000..1462c2b195db
--- /dev/null
+++ b/net-mgmt/sendip/files/patch-Makefile
@@ -0,0 +1,18 @@
+--- Makefile Sun Feb 24 12:37:47 2002
++++ Makefile Sat Mar 9 08:15:25 2002
+@@ -8,12 +8,13 @@
+ #For Solaris, you may need
+ #INSTALL=/usr/ucb/install
+
+-CFLAGS= -fPIC -pipe -Wall -Wpointer-arith -Wwrite-strings \
++CFLAGS= -fPIC -fsigned-char -pipe -Wall -Wpointer-arith -Wwrite-strings \
+ -Wstrict-prototypes -Wnested-externs -Winline -Werror -g \
+ -DSENDIP_LIBS=\"$(LIBDIR)\"
+ #-Wcast-align causes problems on solaris, but not serious ones
+ LDFLAGS= -g -rdynamic -lm
+-LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm
++#LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm
++LDFLAGS_SOLARIS= -g -lsocket -lnsl -lm -ldl
+ LDFLAGS_LINUX= -g -rdynamic -ldl -lm
+ LIBCFLAGS= -shared
+ CC= gcc
diff --git a/net-mgmt/sendip/files/patch-icmp.h b/net-mgmt/sendip/files/patch-icmp.h
new file mode 100644
index 000000000000..4e57eb87a78c
--- /dev/null
+++ b/net-mgmt/sendip/files/patch-icmp.h
@@ -0,0 +1,18 @@
+--- icmp.h Fri Nov 23 17:50:51 2001
++++ icmp.h Tue Mar 5 22:16:25 2002
+@@ -3,13 +3,8 @@
+ #ifndef _SENDIP_ICMP_H
+ #define _SENDIP_ICMP_H
+
+-/* FreeBSD needs these. It shouldn't, but it does. GRR */
+-#include <netinet/in_systm.h>
+-#include <netinet/ip.h>
+-
+-/* For message types */
+-#include <netinet/ip_icmp.h>
+-#include <netinet/icmp6.h>
++#define ICMP6_ECHO_REQUEST 128
++#define ICMP_ECHO 8
+
+ /* ICMP HEADER
+ * Copied from glibc 2.2, reproduced here without code specific stuff
diff --git a/net-mgmt/sendip/files/patch-types.h b/net-mgmt/sendip/files/patch-types.h
new file mode 100644
index 000000000000..4affacd10ebc
--- /dev/null
+++ b/net-mgmt/sendip/files/patch-types.h
@@ -0,0 +1,79 @@
+--- types.h Sat Feb 23 17:28:00 2002
++++ types.h Tue Mar 26 18:19:00 2002
+@@ -1,6 +1,8 @@
+ /* types.h - tpyes needed in sendip and not defined everywhere
+ * Author: Mike Ricketts <mike@earth.li>
+ * ChangeLog since 2.1 release:
++ * 03/02/2002 Added more defines/protos for non-IPv6 systems.
++ * 26/03/2002 FreeBSD style BYTE_ORDER fixes
+ */
+ #ifndef _SENDIP_TYPES_H
+ #define _SENDIP_TYPES_H
+@@ -25,8 +27,13 @@
+
+ /* for things that *really* don't know about ipv6, ... */
+ #ifndef AF_INET6
+-#define PF_INET6 10
+-#define AF_INET6 PF_INET6
++#define AF_INET6 10
++#define IPPROTO_ICMPV6 58
++#define IPPROTO_NONE 59
++#define IPPROTO_DSTOPTS 60
++#endif /* !AF_INET6 */
++
++#ifndef s6_addr
+ struct in6_addr {
+ union {
+ u_int8_t u6_addr8[16];
+@@ -37,6 +44,8 @@
+ #define s6_add16 in6_u.u6_addr16
+ #define s6_add32 in6_u.u6_addr32
+ };
++extern const struct in6_addr in6addr_any; /* :: */
++extern const struct in6_addr in6addr_loopback; /* ::1 */
+
+ struct sockaddr_in6 {
+ u_int16_t sin6_family;
+@@ -45,8 +54,9 @@
+ struct in6_addr sin6_addr;
+ u_int32_t sin6_scope_id;
+ };
++extern int inet_pton (int af, const char *cp, void *buf);
+
+-#endif /* !AF_INET 6 */
++#endif /* !s6_addr */
+
+ /* Convert _BIG_ENDIAN/_LITTLE_ENDIAN to __BYTE_ORDER */
+ #ifndef __LITTLE_ENDIAN
+@@ -58,15 +68,30 @@
+ #endif
+
+ #ifndef __BYTE_ORDER
++
++/* Not linux-style, maybe FreeBSD-style */
++#ifdef BYTE_ORDER
++#undef __LITTLE_ENDIAN
++#undef __BIG_ENDIAN
++#define __LITTLE_ENDIAN LITTLE_ENDIAN
++#define __BIG_ENDIAN BIG_ENDIAN
++#define __BYTE_ORDER BYTE_ORDER
++#else
++
++/* Not FreeBSD-style, try solaris style */
+ #ifdef _BIG_ENDIAN
+ #define __BYTE_ORDER __BIG_ENDIAN
+ #else /* not _BIG_ENDIAN */
+ #ifdef _LITTLE_ENDIAN
+ #define __BYTE_ORDER __LITTLE_ENDIAN
+ #else /* not _LITTLE_ENDIAN */
++
++/* Not solaris style. Give up. */
+ #error Could not guess your byte order
++
+ #endif /* not _LITTLE_ENDIAN */
+ #endif /* not _BIG_ENDIAN */
+-#endif /* _BYTE_ORDER */
++#endif /* not BYTE_ORDER */
++#endif /* not __BYTE_ORDER */
+
+ #endif /* _SENDIP_TYPES_H */
diff --git a/net-mgmt/sendip/pkg-plist b/net-mgmt/sendip/pkg-plist
index 2bae76f4d56b..6b004ea7794d 100644
--- a/net-mgmt/sendip/pkg-plist
+++ b/net-mgmt/sendip/pkg-plist
@@ -1 +1,10 @@
bin/sendip
+lib/sendip/ipv4.so
+lib/sendip/ipv6.so
+lib/sendip/icmp.so
+lib/sendip/tcp.so
+lib/sendip/udp.so
+lib/sendip/rip.so
+lib/sendip/bgp.so
+lib/sendip/ntp.so
+@dirrm lib/sendip