aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/smokeping
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-11-21 02:10:00 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-11-21 02:10:00 +0000
commit3f5e45025def71d97513201061ab27ecd63c0c6d (patch)
tree4b29c540066a504547b86b1e0fe5485480a796e1 /net-mgmt/smokeping
parentf029750e165881de0f74d5516b47463e7337cd7a (diff)
downloadports-3f5e45025def71d97513201061ab27ecd63c0c6d.tar.gz
ports-3f5e45025def71d97513201061ab27ecd63c0c6d.zip
- Add NO_ARCH
- Convert to new options helper Approved by: portmgr (blanket)
Notes
Notes: svn path=/head/; revision=402120
Diffstat (limited to 'net-mgmt/smokeping')
-rw-r--r--net-mgmt/smokeping/Makefile32
1 files changed, 7 insertions, 25 deletions
diff --git a/net-mgmt/smokeping/Makefile b/net-mgmt/smokeping/Makefile
index 992568fe3418..de0476d8dbd6 100644
--- a/net-mgmt/smokeping/Makefile
+++ b/net-mgmt/smokeping/Makefile
@@ -31,6 +31,7 @@ BUILD_DEPENDS= p5-CGI-Session>=0:${PORTSDIR}/www/p5-CGI-Session \
p5-perl-ldap>=0:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS:= ${BUILD_DEPENDS}
+NO_ARCH= yes
USES= gmake perl5
GNU_CONFIGURE= yes
CONFIGURE_ENV+= PERL=${PERL} PERL5LIB=${PREFIX}/smokeping/lib
@@ -62,31 +63,12 @@ DNS_DESC= Support for AnotherDNS probes
OPTIONS_DEFINE= ECHOPING CURL RADIUS TELNET DNS FPING
OPTIONS_DEFAULT= FPING
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MFPING}
-RUN_DEPENDS+= ${LOCALBASE}/sbin/fping:${PORTSDIR}/net/fping
-.endif
-
-.if ${PORT_OPTIONS:MECHOPING}
-RUN_DEPENDS+= ${LOCALBASE}/bin/echoping:${PORTSDIR}/net/echoping
-.endif
-
-.if ${PORT_OPTIONS:MCURL}
-RUN_DEPENDS+= ${LOCALBASE}/bin/curl:${PORTSDIR}/ftp/curl
-.endif
-
-.if ${PORT_OPTIONS:MRADIUS}
-RUN_DEPENDS+= p5-Authen-Radius>=0:${PORTSDIR}/security/p5-Authen-Radius
-.endif
-
-.if ${PORT_OPTIONS:MTELNET}
-RUN_DEPENDS+= p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet
-.endif
-
-.if ${PORT_OPTIONS:MDNS}
-RUN_DEPENDS+= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
-.endif
+FPING_RUN_DEPENDS= ${LOCALBASE}/sbin/fping:${PORTSDIR}/net/fping
+ECHOPING_RUN_DEPENDS= ${LOCALBASE}/bin/echoping:${PORTSDIR}/net/echoping
+CURL_RUN_DEPENDS= ${LOCALBASE}/bin/curl:${PORTSDIR}/ftp/curl
+RADIUS_RUN_DEPENDS= p5-Authen-Radius>=0:${PORTSDIR}/security/p5-Authen-Radius
+TELNET_RUN_DEPENDS= p5-Net-Telnet>=0:${PORTSDIR}/net/p5-Net-Telnet
+DNS_RUN_DEPENDS= p5-Net-DNS>=0:${PORTSDIR}/dns/p5-Net-DNS
.include <bsd.port.pre.mk>