aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/smokeping
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2015-06-14 09:16:57 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2015-06-14 09:16:57 +0000
commitb2449f52060f6e6f7939aa72e10b007a8958091c (patch)
treec081627650e02648b40ed71dc4795a97184b51d8 /net-mgmt/smokeping
parent52c7826e8a5cacb357d704a3dded5d567295171f (diff)
downloadports-b2449f52060f6e6f7939aa72e10b007a8958091c.tar.gz
ports-b2449f52060f6e6f7939aa72e10b007a8958091c.zip
Fix smokeping rc.d script who fails to check pid correctly
PR: 198736 Submitted by: vince@unsane.co.uk
Notes
Notes: svn path=/head/; revision=389609
Diffstat (limited to 'net-mgmt/smokeping')
-rw-r--r--net-mgmt/smokeping/Makefile2
-rw-r--r--net-mgmt/smokeping/files/smokeping.in4
2 files changed, 3 insertions, 3 deletions
diff --git a/net-mgmt/smokeping/Makefile b/net-mgmt/smokeping/Makefile
index 461f7e01c8cb..b7714bd64590 100644
--- a/net-mgmt/smokeping/Makefile
+++ b/net-mgmt/smokeping/Makefile
@@ -3,7 +3,7 @@
PORTNAME= smokeping
PORTVERSION= 2.6.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt www
MASTER_SITES= http://oss.oetiker.ch/smokeping/pub/ \
http://smokeping.cs.pu.edu.tw/pub/
diff --git a/net-mgmt/smokeping/files/smokeping.in b/net-mgmt/smokeping/files/smokeping.in
index d23c8fa64be5..d2011e7a6414 100644
--- a/net-mgmt/smokeping/files/smokeping.in
+++ b/net-mgmt/smokeping/files/smokeping.in
@@ -51,7 +51,7 @@ smokeping_startprecmd()
smokeping_status()
{
- rc_pid=$(check_pidfile $pidfile $command)
+ rc_pid=$(check_pidfile $pidfile $command $command_interpreter)
if [ -z "$rc_pid" ]; then
_run_rc_notrunning
else
@@ -71,7 +71,7 @@ smokeping_reload()
smokeping_stop()
{
- rc_pid=$(check_pidfile $pidfile $command)
+ rc_pid=$(check_pidfile $pidfile $command $command_interpreter)
if [ -z "$rc_pid" ]; then
_run_rc_notrunning
else