aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/smokeping
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2012-05-14 15:03:12 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2012-05-14 15:03:12 +0000
commitd2ef11eee61c3220db31099d1fbedef33555c96f (patch)
tree186c92e05f5b322fdbc576c83e148084fbf143eb /net-mgmt/smokeping
parent8b1df6e13475698284df7422d322e04cfebed217 (diff)
downloadports-d2ef11eee61c3220db31099d1fbedef33555c96f.tar.gz
ports-d2ef11eee61c3220db31099d1fbedef33555c96f.zip
Notes
Diffstat (limited to 'net-mgmt/smokeping')
-rw-r--r--net-mgmt/smokeping/Makefile15
-rw-r--r--net-mgmt/smokeping/files/patch-bin-smokeping17
-rw-r--r--net-mgmt/smokeping/files/patch-bin-smokeping_cgi21
-rw-r--r--net-mgmt/smokeping/files/patch-bin-tSmoke21
-rw-r--r--net-mgmt/smokeping/files/patch-htdocs-Makefile.in11
5 files changed, 81 insertions, 4 deletions
diff --git a/net-mgmt/smokeping/Makefile b/net-mgmt/smokeping/Makefile
index f4a615b3b76f..dd01752659c8 100644
--- a/net-mgmt/smokeping/Makefile
+++ b/net-mgmt/smokeping/Makefile
@@ -7,15 +7,16 @@
PORTNAME= smokeping
PORTVERSION= 2.6.7
+PORTREVISION= 1
CATEGORIES= net-mgmt www
MASTER_SITES= http://oss.oetiker.ch/smokeping/pub/ \
http://smokeping.cs.pu.edu.tw/pub/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rodrigo@bebik.net
COMMENT= Latency logging and graphing system
-RUN_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool \
- p5-CGI-Session>0:${PORTSDIR}/www/p5-CGI-Session \
+LIB_DEPENDS= rrd.6:${PORTSDIR}/databases/rrdtool
+BUILD_DEPENDS= p5-CGI-Session>0:${PORTSDIR}/www/p5-CGI-Session \
p5-Digest-HMAC>0:${PORTSDIR}/security/p5-Digest-HMAC \
p5-SNMP_Session>0:${PORTSDIR}/net-mgmt/p5-SNMP_Session \
p5-libwww>0:${PORTSDIR}/www/p5-libwww \
@@ -23,6 +24,7 @@ RUN_DEPENDS= rrdtool:${PORTSDIR}/databases/rrdtool \
p5-FCGI>0:${PORTSDIR}/www/p5-FCGI \
p5-Config-Grammar>0:${PORTSDIR}/devel/p5-Config-Grammar \
p5-Socket6>0:${PORTSDIR}/net/p5-Socket6
+RUN_DEPENDS:= ${BUILD_DEPENDS}
USE_PERL5= yes
USE_GMAKE= yes
@@ -157,13 +159,18 @@ post-extract:
post-patch:
${REINPLACE_CMD} ${SUB_LIST:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} \
- ${WRKSRC}/doc/Makefile.in
+ ${WRKSRC}/doc/Makefile.in \
+ ${WRKSRC}/bin/smokeping \
+ ${WRKSRC}/bin/smokeping_cgi \
+ ${WRKSRC}/bin/tSmoke
post-install:
.for FILE in basepage.html config smokemail tmail
[ -f ${ETCDIR}/${FILE} ] || ${CP} ${ETCDIR}/${FILE}.dist ${ETCDIR}/${FILE}
.endfor
[ -f ${PREFIX}/smokeping/htdocs/smokeping.fcgi ] || ${CP} ${PREFIX}/smokeping/htdocs/smokeping.fcgi.dist ${PREFIX}/smokeping/htdocs/smokeping.fcgi
+ ${MKDIR} ${PREFIX}/smokeping/htdocs/img
+ ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/smokeping/htdocs
.if !defined(BATCH)
${CAT} ${PKGMESSAGE}
.endif
diff --git a/net-mgmt/smokeping/files/patch-bin-smokeping b/net-mgmt/smokeping/files/patch-bin-smokeping
new file mode 100644
index 000000000000..720219b4e6e9
--- /dev/null
+++ b/net-mgmt/smokeping/files/patch-bin-smokeping
@@ -0,0 +1,17 @@
+--- bin/smokeping.orig 2012-05-14 12:45:03.010872981 +0200
++++ bin/smokeping 2012-05-14 12:54:39.881874010 +0200
+@@ -6,12 +6,11 @@
+
+ use FindBin;
+ # PERL5LIB
+-use lib "$FindBin::Bin/../thirdparty/lib/perl5";
+-use lib "$FindBin::Bin/../lib";
++use lib "%%PREFIX%%/smokeping/lib";
+
+ use Smokeping;
+
+-Smokeping::main("$FindBin::Bin/../etc/config");
++Smokeping::main("%%ETCDIR%%/config");
+
+ =head1 NAME
+
diff --git a/net-mgmt/smokeping/files/patch-bin-smokeping_cgi b/net-mgmt/smokeping/files/patch-bin-smokeping_cgi
new file mode 100644
index 000000000000..4bac5d642171
--- /dev/null
+++ b/net-mgmt/smokeping/files/patch-bin-smokeping_cgi
@@ -0,0 +1,21 @@
+--- bin/smokeping_cgi.orig 2012-05-14 12:45:11.565909114 +0200
++++ bin/smokeping_cgi 2012-05-14 12:55:19.866379488 +0200
+@@ -6,8 +6,7 @@
+
+ use FindBin;
+ # PERL5LIB
+-use lib "$FindBin::Bin/../thirdparty/lib/perl5";
+-use lib "$FindBin::Bin/../lib";
++use lib "%%PREFIX%%/smokeping/lib";
+
+ # don't bother with zombies
+ $SIG{CHLD} = 'IGNORE';
+@@ -18,7 +17,7 @@
+
+ use CGI::Fast;
+
+-my $cfg = (shift @ARGV) || "$FindBin::Bin/../etc/config";
++my $cfg = (shift @ARGV) || "%%ETCDIR%%/config";
+
+
+ while (my $q = new CGI::Fast) {
diff --git a/net-mgmt/smokeping/files/patch-bin-tSmoke b/net-mgmt/smokeping/files/patch-bin-tSmoke
new file mode 100644
index 000000000000..e444a249c14f
--- /dev/null
+++ b/net-mgmt/smokeping/files/patch-bin-tSmoke
@@ -0,0 +1,21 @@
+--- bin/tSmoke.orig 2012-05-14 14:54:55.388873689 +0200
++++ bin/tSmoke 2012-05-14 14:56:15.881875827 +0200
+@@ -53,8 +53,7 @@
+ # Point the lib variables to your implementation
+ use FindBin;
+ # PERL5LIB
+-use lib "$FindBin::Bin/../thirdparty/lib/perl5";
+-use lib "$FindBin::Bin/../lib";
++use lib "%%PREFIX%%/smokeping/lib";
+
+ use Smokeping;
+ use Net::SMTP;
+@@ -63,7 +62,7 @@
+ use RRDs;
+
+ # Point to your Smokeping config file
+-my $cfgfile = "etc/config.dist";
++my $cfgfile = "%%ETCDIR%%/config";
+
+ # global variables
+ my $cfg;
diff --git a/net-mgmt/smokeping/files/patch-htdocs-Makefile.in b/net-mgmt/smokeping/files/patch-htdocs-Makefile.in
new file mode 100644
index 000000000000..3217e48fece7
--- /dev/null
+++ b/net-mgmt/smokeping/files/patch-htdocs-Makefile.in
@@ -0,0 +1,11 @@
+--- htdocs/Makefile.in.orig 2012-05-14 13:21:26.387873095 +0200
++++ htdocs/Makefile.in 2012-05-14 13:22:37.617874000 +0200
+@@ -424,7 +424,7 @@
+ install-data-local:
+ $(MKDIR) -p $(DESTDIR)$(HTDOCSDIR)
+ $(ECHO) "#!/bin/sh" > $(DESTDIR)$(HTDOCSDIR)/smokeping.fcgi.dist
+- $(ECHO) "$(prefix)/bin/smokeping_cgi $(prefix)/etc/config" >> $(DESTDIR)$(HTDOCSDIR)/smokeping.fcgi.dist
++ $(ECHO) "$(prefix)/bin/smokeping_cgi $(sysconfdir)/config" >> $(DESTDIR)$(HTDOCSDIR)/smokeping.fcgi.dist
+ chmod +x $(DESTDIR)$(HTDOCSDIR)/smokeping.fcgi.dist
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.