aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/snmp++
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2014-01-26 18:22:35 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2014-01-26 18:22:35 +0000
commit3413304bd3ca00132c61a94968daade98dad34c7 (patch)
treeab64c17abc6773adc9cffbbf9ff54f621d482c65 /net-mgmt/snmp++
parent7e8629cf0ed7ef234e1dbe2ac219fd9ba84da59c (diff)
downloadports-3413304bd3ca00132c61a94968daade98dad34c7.tar.gz
ports-3413304bd3ca00132c61a94968daade98dad34c7.zip
Notes
Diffstat (limited to 'net-mgmt/snmp++')
-rw-r--r--net-mgmt/snmp++/Makefile8
-rw-r--r--net-mgmt/snmp++/distinfo4
-rw-r--r--net-mgmt/snmp++/files/Makefile.FreeBSD42
-rw-r--r--net-mgmt/snmp++/files/patch-src-common.mk2
-rw-r--r--net-mgmt/snmp++/pkg-descr2
-rw-r--r--net-mgmt/snmp++/pkg-plist2
6 files changed, 27 insertions, 33 deletions
diff --git a/net-mgmt/snmp++/Makefile b/net-mgmt/snmp++/Makefile
index 15970bd26c8d..8784aa29797e 100644
--- a/net-mgmt/snmp++/Makefile
+++ b/net-mgmt/snmp++/Makefile
@@ -2,12 +2,12 @@
# $FreeBSD$
PORTNAME= snmp++
-PORTVERSION= 3.2.25
+PORTVERSION= 3.3.0
CATEGORIES= net-mgmt
MASTER_SITES= http://www.agentpp.com/
DISTNAME= ${PORTNAME}v${PORTVERSION}
-MAINTAINER= nicolai@catpipe.net
+MAINTAINER= nicolai@petri.dk
COMMENT= SNMP C++ library with V3 support
MAKEFILE= Makefile.FreeBSD
@@ -21,7 +21,7 @@ post-extract:
${CP} ${FILESDIR}/Makefile.FreeBSD ${WRKSRC}
post-install:
- ${LN} -sf ${PREFIX}/lib/libsnmp++.so.2.0.0 ${STAGEDIR}${PREFIX}/lib/libsnmp++.so
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsnmp++.so.2.0.0
+ ${LN} -sf ${PREFIX}/lib/libsnmp++.so.3.3.0 ${STAGEDIR}${PREFIX}/lib/libsnmp++.so
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libsnmp++.so.3.3.0
.include <bsd.port.mk>
diff --git a/net-mgmt/snmp++/distinfo b/net-mgmt/snmp++/distinfo
index 75e67b09b5fc..def030244e36 100644
--- a/net-mgmt/snmp++/distinfo
+++ b/net-mgmt/snmp++/distinfo
@@ -1,2 +1,2 @@
-SHA256 (snmp++v3.2.25.tar.gz) = 02234720a95af975180f7c093b98cc003bb564f44c8795882593afbb417c1f2b
-SIZE (snmp++v3.2.25.tar.gz) = 265074
+SHA256 (snmp++v3.3.0.tar.gz) = 821ae493f8fb54bb85cbd779697a3fc92e130906b5de993b9970ffd47f12466a
+SIZE (snmp++v3.3.0.tar.gz) = 584162
diff --git a/net-mgmt/snmp++/files/Makefile.FreeBSD b/net-mgmt/snmp++/files/Makefile.FreeBSD
index 5e730102d232..c46e313e08d0 100644
--- a/net-mgmt/snmp++/files/Makefile.FreeBSD
+++ b/net-mgmt/snmp++/files/Makefile.FreeBSD
@@ -1,30 +1,30 @@
############################################################################
- ##
- ## Makefile.FreeBSD
+ ##
+ ## Makefile.FreeBSD
##
## SNMP++v3.2.22
## -----------------------------------------------
## Copyright (c) 2001-2006 Jochen Katz, Frank Fock
##
## This software is based on SNMP++2.6 from Hewlett Packard:
- ##
+ ##
## Copyright (c) 1996
## Hewlett-Packard Company
- ##
+ ##
## ATTENTION: USE OF THIS SOFTWARE IS SUBJECT TO THE FOLLOWING TERMS.
- ## Permission to use, copy, modify, distribute andor sell this software
- ## andor its documentation is hereby granted without fee. User agrees
- ## to display the above copyright notice and this license notice in all
- ## copies of the software and any documentation of the software. User
- ## agrees to assume all liability for the use of the software;
- ## Hewlett-Packard and Jochen Katz make no representations about the
- ## suitability of this software for any purpose. It is provided
- ## "AS-IS" without warranty of any kind, either express or implied. User
+ ## Permission to use, copy, modify, distribute andor sell this software
+ ## andor its documentation is hereby granted without fee. User agrees
+ ## to display the above copyright notice and this license notice in all
+ ## copies of the software and any documentation of the software. User
+ ## agrees to assume all liability for the use of the software;
+ ## Hewlett-Packard and Jochen Katz make no representations about the
+ ## suitability of this software for any purpose. It is provided
+ ## "AS-IS" without warranty of any kind, either express or implied. User
## hereby grants a royalty-free license to any and all derivatives based
- ## upon this software code base.
- ##
- ## Stuttgart, Germany, Tue Nov 21 22:12:16 CET 2006
- ##
+ ## upon this software code base.
+ ##
+ ## Stuttgart, Germany, Tue Nov 21 22:12:16 CET 2006
+ ##
##########################################################################*
#
@@ -32,17 +32,11 @@
#
COPTIONS = -D_XPG4_EXTENDED -D__unix -Wall -D_USE_OPENSSL# -DHEADER_DES_LOCL_H # -D_DEBUG
-TEMPOPTS = -I.
+TEMPOPTS = -I.
USEROPTS = -g
-CFLAGS = $(COPTIONS) $(CINCDIRS) $(USEROPTS)
+CFLAGS = $(COPTIONS) $(CINCDIRS) $(USEROPTS)
LDFLAGS = $(CFLAGS)
SHARED = -fPIC -shared
-#
-# Compilation rules
-#
-CC = g++
-LD = ld
-
include common.mk
diff --git a/net-mgmt/snmp++/files/patch-src-common.mk b/net-mgmt/snmp++/files/patch-src-common.mk
index 40471d4e806f..cc1ee895c7e0 100644
--- a/net-mgmt/snmp++/files/patch-src-common.mk
+++ b/net-mgmt/snmp++/files/patch-src-common.mk
@@ -7,5 +7,5 @@
-INSTPREFIX = /usr/local
+INSTPREFIX = $(PREFIX)
endif
-
+
ifndef INSTLIBPATH
diff --git a/net-mgmt/snmp++/pkg-descr b/net-mgmt/snmp++/pkg-descr
index 9ad99552e729..7a094786a72d 100644
--- a/net-mgmt/snmp++/pkg-descr
+++ b/net-mgmt/snmp++/pkg-descr
@@ -13,4 +13,4 @@ SNMP++v3.x extends the original SNMP++v2.8 by the following:
# Thread-safety
# Bug-fixes
-WWW: http://www.agentpp.com/snmp_pp3_x/snmp_pp3_x.html for further details.
+WWW: http://www.agentpp.com/snmp_pp3_x/snmp_pp3_x.html
diff --git a/net-mgmt/snmp++/pkg-plist b/net-mgmt/snmp++/pkg-plist
index f41e1b5d1997..34bf1dd3fe19 100644
--- a/net-mgmt/snmp++/pkg-plist
+++ b/net-mgmt/snmp++/pkg-plist
@@ -36,5 +36,5 @@ include/snmp_pp/v3.h
include/snmp_pp/vb.h
lib/libsnmp++.a
lib/libsnmp++.so
-lib/libsnmp++.so.2.0.0
+lib/libsnmp++.so.3.3.0
@dirrm include/snmp_pp