aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/snmptt
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2014-07-20 21:32:23 +0000
committerKurt Jaeger <pi@FreeBSD.org>2014-07-20 21:32:23 +0000
commitc052a41cd85e35e98dbe5a2196bd35c012f2c7ed (patch)
tree7110ba94485f512eace468efebf4a357108865ea /net-mgmt/snmptt
parente29cdaaee5ec1742184070106ddbe8b4bac5d1d9 (diff)
downloadports-c052a41cd85e35e98dbe5a2196bd35c012f2c7ed.tar.gz
ports-c052a41cd85e35e98dbe5a2196bd35c012f2c7ed.zip
net-mgmt/snmptt: 1.3 -> 1.4
PR: 191119 Submitted by: nistor@snickers.org (maintainer)
Notes
Notes: svn path=/head/; revision=362378
Diffstat (limited to 'net-mgmt/snmptt')
-rw-r--r--net-mgmt/snmptt/Makefile65
-rw-r--r--net-mgmt/snmptt/distinfo4
-rw-r--r--net-mgmt/snmptt/pkg-descr2
-rw-r--r--net-mgmt/snmptt/pkg-plist12
4 files changed, 36 insertions, 47 deletions
diff --git a/net-mgmt/snmptt/Makefile b/net-mgmt/snmptt/Makefile
index cf5171f32146..d1f1fe74042e 100644
--- a/net-mgmt/snmptt/Makefile
+++ b/net-mgmt/snmptt/Makefile
@@ -1,59 +1,52 @@
-# Created by: Bruce M Simpson <bms@FreeBSD.org>
# $FreeBSD$
-PORTNAME= snmptt
-PORTVERSION= 1.3
-CATEGORIES= net-mgmt
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}_${PORTVERSION}
-DISTNAME= ${PORTNAME}_${PORTVERSION}
-EXTRACT_SUFX= .tgz
+PORTNAME= snmptt
+PORTVERSION= 1.4
+CATEGORIES= net-mgmt
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}_${PORTVERSION}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+EXTRACT_SUFX= .tgz
MAINTAINER= nistor@snickers.org
COMMENT= SNMP trap handler/translator/swiss-army-knife
-RUN_DEPENDS= net-snmp>=0:${PORTSDIR}/net-mgmt/net-snmp \
- p5-Config-IniFiles>=0:${PORTSDIR}/devel/p5-Config-IniFiles
-
-WRKSRC= ${WRKDIR}/${PORTNAME}_${PORTVERSION}
+USES= perl5 shebangfix
+USE_RC_SUBR= snmptt
-USES= perl5
+RUN_DEPENDS= net-snmp>=0:${PORTSDIR}/net-mgmt/net-snmp \
+ p5-Config-IniFiles>=0:${PORTSDIR}/devel/p5-Config-IniFiles \
+ p5-Text-Balanced>=0:${PORTSDIR}/textproc/p5-Text-Balanced \
+ p5-Text-ParseWords>=0:${PORTSDIR}/textproc/p5-Text-ParseWords \
+ p5-Time-HiRes>=0:${PORTSDIR}/devel/p5-Time-HiRes
-USE_RC_SUBR= snmptt
+DOCS= faqs.html index.html layout1.css snmptt.html \
+ snmpttconvert.html snmpttconvertmib.html
SCRIPTS= snmptt snmptt-net-snmp-test snmpttconvert \
snmpttconvertmib snmptthandler
-DOCS= faqs.html index.html layout1.css snmptt.html \
- snmpttconvert.html snmpttconvertmib.html
-NO_STAGE= yes
+SHEBANG_FILES= ${SCRIPTS}
+
.include <bsd.port.pre.mk>
do-build:
-
-post-build:
- @${ECHO_CMD} ${WRKSRC}/snmptt ${WRKSRC}/snmptthandler ${WRKSRC}/snmptt.ini | ${XARGS} \
- ${REINPLACE_CMD} -e \
- "s|/etc/snmptt.ini|${PREFIX}/etc/snmptt.ini|g ; \
- s|/etc/snmp/snmptt.ini|${PREFIX}/etc/snmp/snmptt.ini|g ; \
- s|/etc/snmp/snmptt.conf|${PREFIX}/etc/snmp/snmptt.conf.generic|g"
+ @echo Skipping building ${PORTNAME}
do-install:
+ @echo Installing ${PORTNAME} ${PORTVERSION}
+
.for _SCRIPT in ${SCRIPTS}
- ${INSTALL_SCRIPT} ${WRKSRC}/${_SCRIPT} ${PREFIX}/sbin
+ @${INSTALL_SCRIPT} ${WRKSRC}/${_SCRIPT} ${STAGEDIR}${PREFIX}/sbin
.endfor
- ${MKDIR} ${PREFIX}/etc/snmp
- ${INSTALL_DATA} ${WRKSRC}/snmptt.ini ${PREFIX}/etc/snmp/snmptt.ini-dist
-.if !exists(${PREFIX}/etc/snmp/snmptt.ini)
- ${INSTALL_DATA} ${WRKSRC}/snmptt.ini ${PREFIX}/etc/snmp
-.endif
- ${INSTALL_DATA} ${WRKSRC}/examples/snmptt.conf.generic ${PREFIX}/etc/snmp/snmptt.conf.generic-dist
-.if !exists(${PREFIX}/etc/snmp/snmptt.conf)
- ${INSTALL_DATA} ${WRKSRC}/examples/snmptt.conf.generic ${PREFIX}/etc/snmp/snmptt.conf.generic
-.endif
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/snmp
+ ${INSTALL_DATA} ${WRKSRC}/snmptt.ini ${STAGEDIR}${PREFIX}/etc/snmp/snmptt.ini-dist
+ ${INSTALL_DATA} ${WRKSRC}/examples/snmptt.conf.generic ${STAGEDIR}${PREFIX}/etc/snmp/snmptt.conf.generic-dist
+
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for _DOC in ${DOCS}
- ${INSTALL_MAN} ${WRKSRC}/docs/${_DOC} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/docs/${_DOC} ${STAGEDIR}${DOCSDIR}
.endfor
.endif
diff --git a/net-mgmt/snmptt/distinfo b/net-mgmt/snmptt/distinfo
index 2e2461a9c0f2..3b8169745e0b 100644
--- a/net-mgmt/snmptt/distinfo
+++ b/net-mgmt/snmptt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (snmptt_1.3.tgz) = 2f09d489a2073f5b1f4bdc207533b7dcf99d5b57d1c9659cfaa3c2af44ce6567
-SIZE (snmptt_1.3.tgz) = 146314
+SHA256 (snmptt_1.4.tgz) = 512c33ecdf06da8b3c75082c1506e4b4091ddb714d0d9564771aa12ddc98ef99
+SIZE (snmptt_1.4.tgz) = 148504
diff --git a/net-mgmt/snmptt/pkg-descr b/net-mgmt/snmptt/pkg-descr
index 7ebd431d771e..92beed4719bc 100644
--- a/net-mgmt/snmptt/pkg-descr
+++ b/net-mgmt/snmptt/pkg-descr
@@ -1,4 +1,4 @@
SNMPTT (SNMP Trap Translator) is an SNMP trap handler written in Perl
-for use with the Net-SNMP / UCD-SNMP snmptrapd program (www.net-snmp.org).
+for use with the Net-SNMP. Easy to setup and use.
WWW: http://www.snmptt.org/
diff --git a/net-mgmt/snmptt/pkg-plist b/net-mgmt/snmptt/pkg-plist
index ac77f434cffa..5a0dbd21bc7b 100644
--- a/net-mgmt/snmptt/pkg-plist
+++ b/net-mgmt/snmptt/pkg-plist
@@ -1,19 +1,15 @@
+etc/snmp/snmptt.conf.generic-dist
+etc/snmp/snmptt.ini-dist
sbin/snmptt
sbin/snmptt-net-snmp-test
sbin/snmpttconvert
sbin/snmpttconvertmib
sbin/snmptthandler
-@unexec if cmp -s %D/etc/snmp/snmptt.ini %D/etc/snmp/snmptt.ini-dist; then rm -f %D/etc/snmp/snmptt.ini; fi
-etc/snmp/snmptt.ini-dist
-@exec [ ! -f %B/snmptt.ini ] && cp %B/%f %B/snmptt.ini
-@unexec if cmp -s %D/etc/snmp/snmptt.conf.generic %D/etc/snmp/snmptt.conf.generic-dist; then rm -f %D/etc/snmp/snmptt.conf.generic; fi
-etc/snmp/snmptt.conf.generic-dist
-@exec [ ! -f %B/snmptt.conf.generic ] && cp %B/%f %B/snmptt.conf.generic
%%PORTDOCS%%%%DOCSDIR%%/faqs.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/layout1.css
%%PORTDOCS%%%%DOCSDIR%%/snmptt.html
%%PORTDOCS%%%%DOCSDIR%%/snmpttconvert.html
%%PORTDOCS%%%%DOCSDIR%%/snmpttconvertmib.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm etc/snmp
+%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
+@dirrmtry etc/snmp