aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/spectools
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-04-29 16:43:05 +0000
committerRene Ladan <rene@FreeBSD.org>2013-04-29 16:43:05 +0000
commit4e4178dab5c2825019e9652f1ba4f102253a31df (patch)
treea101ccfbdb487a4c9c92a67d6d88ac8775e3362a /net-mgmt/spectools
parentecec69fbc311162911f66439dedf61b8176ef964 (diff)
downloadports-4e4178dab5c2825019e9652f1ba4f102253a31df.tar.gz
ports-4e4178dab5c2825019e9652f1ba4f102253a31df.zip
In preparation of removing devel/libusb (expires 2013-04-30), remove it
from these ports. Other changes: - convert Makefile header - convert to optionsNG - remove indefinite article from comment - drop support for FreeBSD < 8.0 - pet portlint (leave library ABI versions in LIB_DEPENDS) - net-mgmt/spectools: change option name from GTK to GTK2 to use default description from bsd.options.desc.mk Approved by: portmgr (bapt)
Notes
Notes: svn path=/head/; revision=316831
Diffstat (limited to 'net-mgmt/spectools')
-rw-r--r--net-mgmt/spectools/Makefile31
1 files changed, 10 insertions, 21 deletions
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
index 8c10a9ef9419..9add207a7833 100644
--- a/net-mgmt/spectools/Makefile
+++ b/net-mgmt/spectools/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: spectools
-# Date created: 09 Oct 2007
-# Whom: Henrik Brix Andersen <henrik@brixandersen.dk>
-#
+# Created by: Henrik Brix Andersen <henrik@brixandersen.dk>
# $FreeBSD$
-#
PORTNAME= spectools
PORTVERSION= 201004.r1
@@ -18,6 +14,7 @@ MAINTAINER= brix@FreeBSD.org
COMMENT= Tools for the Wi-Spy spectrum analyzers from MetaGeek LLC
LICENSE= GPLv2
+
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -25,14 +22,14 @@ USE_GMAKE= yes
PORTDOCS= README
-OPTIONS= GTK "Enable graphical client" On \
- NCURSES "Enable ncurses client" On
+OPTIONS_DEFINE= GTK2 NCURSES
+OPTIONS_DEFAULT= GTK2 NCURSES
ALL_TARGET= spectool_net spectool_raw
.include <bsd.port.options.mk>
-.if defined(WITH_GTK)
+.if ${PORT_OPTIONS:MGTK2}
ALL_TARGET+= spectool_gtk
LIB_DEPENDS+= gtk:${PORTSDIR}/x11-toolkits/gtk20
PLIST_SUB+= GTK=""
@@ -40,7 +37,7 @@ PLIST_SUB+= GTK=""
PLIST_SUB+= GTK="@comment "
.endif
-.if defined(WITH_NCURSES)
+.if ${PORT_OPTIONS:MNCURSES}
ALL_TARGET+= spectool_curses
PLIST_SUB+= NCURSES=""
.else
@@ -49,33 +46,25 @@ PLIST_SUB+= NCURSES="@comment "
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb-0.1:${PORTSDIR}/devel/libusb
-.endif
-
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-.if ${OSVERSION} > 800000
BROKEN= Does not build: duplicate definition of malloc
-.else
-BROKEN= Does not compile: fails to build wispy_hw_dbx.c
-.endif
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spectool_net ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/spectool_raw ${PREFIX}/bin
-.if defined(WITH_GTK)
+.if ${PORT_OPTIONS:MGTK2}
${INSTALL_PROGRAM} ${WRKSRC}/spectool_gtk ${PREFIX}/bin
.endif
-.if defined(WITH_NCURSES)
+.if ${PORT_OPTIONS:MNCURSES}
${INSTALL_PROGRAM} ${WRKSRC}/spectool_curses ${PREFIX}/bin
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S@^@${WRKSRC}/@} ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>