aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/spectools
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-25 14:58:22 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-08-25 14:58:22 +0000
commit8bec027e638a200b7fb28ca4039fcb248d21531c (patch)
tree947a5332fd6a14815e102db908d21c08b09e0e26 /net-mgmt/spectools
parent3a4491a4108b150c7f24f959db7ca72c9834a212 (diff)
downloadports-8bec027e638a200b7fb28ca4039fcb248d21531c.tar.gz
ports-8bec027e638a200b7fb28ca4039fcb248d21531c.zip
- Add LICENSE_FILE
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=395295
Diffstat (limited to 'net-mgmt/spectools')
-rw-r--r--net-mgmt/spectools/Makefile50
-rw-r--r--net-mgmt/spectools/pkg-plist2
2 files changed, 18 insertions, 34 deletions
diff --git a/net-mgmt/spectools/Makefile b/net-mgmt/spectools/Makefile
index 0800a94d35b2..08d702d33d70 100644
--- a/net-mgmt/spectools/Makefile
+++ b/net-mgmt/spectools/Makefile
@@ -13,56 +13,40 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Tools for the Wi-Spy spectrum analyzers from MetaGeek LLC
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/GPL
+BROKEN_ia64= does not build: duplicate definition of malloc
+BROKEN_powerpc= does not build: duplicate definition of malloc
+BROKEN_sparc64= does not build: duplicate definition of malloc
+
+USES= gmake pkgconfig
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USES= gmake pkgconfig
+ALL_TARGET= spectool_net spectool_raw
PORTDOCS= README
OPTIONS_DEFINE= GTK2 NCURSES DOCS
OPTIONS_DEFAULT= GTK2 NCURSES
+OPTIONS_SUB= yes
-ALL_TARGET= spectool_net spectool_raw
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MGTK2}
-ALL_TARGET+= spectool_gtk
-USE_GNOME= gtk20
-PLIST_SUB+= GTK=""
-.else
-PLIST_SUB+= GTK="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MNCURSES}
-ALL_TARGET+= spectool_curses
-PLIST_SUB+= NCURSES=""
-.else
-PLIST_SUB+= NCURSES="@comment "
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
-BROKEN= Does not build: duplicate definition of malloc
-.endif
+GTK2_ALL_TARGET= spectool_gtk
+GTK2_USE= GNOME=gtk20
+NCURSES_ALL_TARGET= spectool_curses
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/spectool_net ${STAGEDIR}/${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/spectool_raw ${STAGEDIR}/${PREFIX}/bin
-.if ${PORT_OPTIONS:MGTK2}
+
+do-install-GTK2-on:
${INSTALL_PROGRAM} ${WRKSRC}/spectool_gtk ${STAGEDIR}/${PREFIX}/bin
-.endif
-.if ${PORT_OPTIONS:MNCURSES}
+
+do-install-NCURSES-on:
${INSTALL_PROGRAM} ${WRKSRC}/spectool_curses ${STAGEDIR}/${PREFIX}/bin
-.endif
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
+post-install-DOCS-on:
${MKDIR} ${STAGEDIR}/${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S@^@${WRKSRC}/@} ${STAGEDIR}/${DOCSDIR}
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/spectools/pkg-plist b/net-mgmt/spectools/pkg-plist
index d65f997992b4..61f833b69c5a 100644
--- a/net-mgmt/spectools/pkg-plist
+++ b/net-mgmt/spectools/pkg-plist
@@ -1,4 +1,4 @@
-%%GTK%%bin/spectool_gtk
+%%GTK2%%bin/spectool_gtk
%%NCURSES%%bin/spectool_curses
bin/spectool_net
bin/spectool_raw