aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/yaf
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-03-06 14:40:46 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-03-06 14:40:46 +0000
commit22b87e6792670e5878c4d0aeb88b079f62f072d9 (patch)
tree45d3e889ae20913ae18db8b12e47f2d9b5808f9c /net-mgmt/yaf
parent81587b063fa5df9ca656a7f522b209fd0f6ad3c3 (diff)
downloadports-22b87e6792670e5878c4d0aeb88b079f62f072d9.tar.gz
ports-22b87e6792670e5878c4d0aeb88b079f62f072d9.zip
net-mgmt/yaf: 2.8.0 -> 2.8.1, with many new OPTIONs
- Fix compile error when configured with --disable-payload - Force buffer emit with IPFIX Options record when inactive Please report if you find OPTION combinations that cause problems. PR: 202611 Submitted by: Chris Inacio <nacho319+freebsdZilla@gmail.com> Approved by: dikshie@sfc.wide.ad.jp
Notes
Notes: svn path=/head/; revision=410460
Diffstat (limited to 'net-mgmt/yaf')
-rw-r--r--net-mgmt/yaf/Makefile47
-rw-r--r--net-mgmt/yaf/distinfo8
-rw-r--r--net-mgmt/yaf/pkg-plist18
3 files changed, 62 insertions, 11 deletions
diff --git a/net-mgmt/yaf/Makefile b/net-mgmt/yaf/Makefile
index daf2218df496..7c0d52b21bf9 100644
--- a/net-mgmt/yaf/Makefile
+++ b/net-mgmt/yaf/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= yaf
-PORTVERSION= 2.8.0
+PORTVERSION= 2.8.1
CATEGORIES= net-mgmt
MASTER_SITES= http://tools.netsa.cert.org/releases/
@@ -14,6 +14,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libfixbuf.so:${PORTSDIR}/net/libfixbuf \
libltdl.so:${PORTSDIR}/devel/libltdl \
+ libpcap.so:${PORTSDIR}/net/libpcap \
libpcre.so:${PORTSDIR}/devel/pcre
GNU_CONFIGURE= yes
@@ -21,10 +22,51 @@ INSTALL_TARGET= install-strip
USES= libtool pathfix perl5 pkgconfig
USE_GNOME= glib20
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-doxygen-doc --enable-applabel --enable-plugins
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+OPTIONS_DEFINE= PAYLOAD APPLABEL PLUGIN FPEXPORT ENTROPY MPLS NONIP P0FPRINT IFEXP CMPTIP4 LOCALTIME DNSAUTH DNSNX
+OPTIONS_DEFAULT= PAYLOAD APPLABEL PLUGIN ENTROPY
+
+PAYLOAD_DESC= YAF will enable reading past IP headers to do deep packet inspection
+APPLABEL_DESC= Create protocol application labels via traffic header inspection.
+PLUGIN_DESC= Enable YAF plugins, primary for application labeling.
+FPEXPORT_DESC= Export of OS fingerprinting information, e.g. p0f.
+ENTROPY_DESC= Generate Shannon entropy values of the data stream.
+MPLS_DESC= MPLS capture and export
+NONIP_DESC= Capture non-IP packets
+P0FPRINT_DESC= Generate p0f O/S fingerprinting.
+IFEXP_DESC= Export capture interface for DAG/Napatech/Netronome cards.
+CMPTIP4_DESC= Create compact IPv4 output (no IPv6 support).
+LOCALTIME_DESC= Allow localtime to be used for command inputs and record printing. Flow records are always in UTC.
+DNSAUTH_DESC= Modify DNS export to only export Authoritative DNS responses.
+DNSNX_DESC= Modify DNS export to only export NXDomain responses.
+
+PAYLOAD_CONFIGURE_ENABLE= payload
+APPLABEL_CONFIGURE_ENABLE= applabel
+PLUGIN_CONFIGURE_ENABLE= plugins
+FPEXPORT_CONFIGURE_ENABLE= fpexporter
+ENTROPY_CONFIGURE_ENABLE= entropy
+MPLS_CONFIGURE_ENABLE= mpls
+NONIP_CONFIGURE_ENABLE= nonip
+P0FPRINT_CONFIGURE_ENABLE= p0fprinter
+IFEXP_CONFIGURE_ENABLE= interface
+CMPTIP4_CONFIGURE_ENABLE= compact-ip4
+LOCALTIME_CONFIGURE_ENABLE= localtime
+DNSAUTH_CONFIGURE_ENABLE= exportDNSAuth
+DNSNX_CONFIGURE_ENABLE= exportDNSNXDomain
+
+APPLABEL_IMPLIES= PAYLOAD
+DNSAUTH_IMPLIES= PLUGIN APPLABEL
+DNSNX_IMPLIES= PLUGIN APPLABEL
+ENTROPY_IMPLIES= PAYLOAD
+P0FPRINT_IMPLIES= APPLABEL
+NONIP_IMPLIES= MPLS
+
+P0FPRINT_LIB_DEPENDS= libp0f.so:${PORTSDIR}/net/libp0f
+
+.include <bsd.port.options.mk>
+
.if defined(WITH_DAG)
CONFIGURE_ARGS+= --with-dag=${LOCALBASE}
.endif
@@ -33,5 +75,6 @@ post-install:
.for f in dhcp_fingerprints.conf yafApplabelRules.conf yafDPIRules.conf
${MV} ${STAGEDIR}${PREFIX}/etc/$f ${STAGEDIR}${PREFIX}/etc/$f.sample
.endfor
+ ${RM} ${STAGEDIR}${PREFIX}/etc/p0f.fp
.include <bsd.port.mk>
diff --git a/net-mgmt/yaf/distinfo b/net-mgmt/yaf/distinfo
index b2fb83274297..8adcde2c3d13 100644
--- a/net-mgmt/yaf/distinfo
+++ b/net-mgmt/yaf/distinfo
@@ -1,2 +1,10 @@
+SHA256 (yaf-2.8.1.tar.gz) = adbda0b3ef15325c20497609d422eda0bfbcc43a9cc015eb29812070cec75882
+SIZE (yaf-2.8.1.tar.gz) = 2071736
SHA256 (yaf-2.8.0.tar.gz) = b0f7f52980f2d05eaf5cca75a6299c3e9f65c972823e0bef8673dbe4324c507d
SIZE (yaf-2.8.0.tar.gz) = 2068192
+SHA256 (yaf-2.7.1.tar.gz) = b3fbaa667ea052bdb83a6e6a5bd6529daa93f8f926fa278778716f6dfadd8e5e
+SIZE (yaf-2.7.1.tar.gz) = 1584784
+SHA256 (yaf-2.5.0.tar.gz) = 79c3498a77e9be11487b22fb6c4fe886965042de3c875c6242b54c3f9e9a4c9d
+SIZE (yaf-2.5.0.tar.gz) = 1530757
+SHA256 (yaf-2.6.0.tar.gz) = 7562d0e81e398fe491b81cad0b96996d2ac21f649d28ecda7ca258480dab6bb8
+SIZE (yaf-2.6.0.tar.gz) = 1569256
diff --git a/net-mgmt/yaf/pkg-plist b/net-mgmt/yaf/pkg-plist
index 71b7eda7cd10..26c1c0c28f3e 100644
--- a/net-mgmt/yaf/pkg-plist
+++ b/net-mgmt/yaf/pkg-plist
@@ -80,10 +80,6 @@ lib/yaf/ethipplugin.a
lib/yaf/ethipplugin.so
lib/yaf/ethipplugin.so.1
lib/yaf/ethipplugin.so.1.0.1
-lib/yaf/gh0stplugin.a
-lib/yaf/gh0stplugin.so
-lib/yaf/gh0stplugin.so.1
-lib/yaf/gh0stplugin.so.1.0.1
lib/yaf/ircplugin.a
lib/yaf/ircplugin.so
lib/yaf/ircplugin.so.1
@@ -104,10 +100,6 @@ lib/yaf/mysqlplugin.a
lib/yaf/mysqlplugin.so
lib/yaf/mysqlplugin.so.1
lib/yaf/mysqlplugin.so.1.0.1
-lib/yaf/netdgmplugin.a
-lib/yaf/netdgmplugin.so
-lib/yaf/netdgmplugin.so.1
-lib/yaf/netdgmplugin.so.1.0.1
lib/yaf/nntpplugin.a
lib/yaf/nntpplugin.so
lib/yaf/nntpplugin.so.1
@@ -164,6 +156,14 @@ lib/yaf/tlsplugin.a
lib/yaf/tlsplugin.so
lib/yaf/tlsplugin.so.1
lib/yaf/tlsplugin.so.1.0.1
+lib/yaf/gh0stplugin.a
+lib/yaf/gh0stplugin.so
+lib/yaf/gh0stplugin.so.1
+lib/yaf/gh0stplugin.so.1.0.1
+lib/yaf/netdgmplugin.a
+lib/yaf/netdgmplugin.so
+lib/yaf/netdgmplugin.so.1
+lib/yaf/netdgmplugin.so.1.0.1
libdata/pkgconfig/libairframe.pc
libdata/pkgconfig/libyaf.pc
man/man1/airdaemon.1.gz
@@ -172,9 +172,9 @@ man/man1/filedaemon.1.gz
man/man1/getFlowKeyHash.1.gz
man/man1/ipfixDump.1.gz
man/man1/yaf.1.gz
-man/man1/yaf.init.1.gz
man/man1/yafMeta2Pcap.1.gz
man/man1/yafdhcp.1.gz
man/man1/yafdpi.1.gz
man/man1/yafscii.1.gz
+man/man1/yaf.init.1.gz
man/man1/yafzcbalance.1.gz