aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zabbix3-frontend/Makefile
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-09-16 19:10:49 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-09-16 19:10:49 +0000
commitb6c9753f39d556ddeb0349ec7fa215d09be79b5d (patch)
tree5a05cba3fa629d420b1a79cb0171a9a190fe0d94 /net-mgmt/zabbix3-frontend/Makefile
parent7006249e8e026aaa92d5c259e37cb5438a7978fb (diff)
downloadports-b6c9753f39d556ddeb0349ec7fa215d09be79b5d.tar.gz
ports-b6c9753f39d556ddeb0349ec7fa215d09be79b5d.zip
net-mgmt/zabbix3-{server|agent|proxy|frontend}: update to 3.0.4 and many fixes
- Fix default path to PID - Fix rc.d scripts to correct use PID file - Fix some error in the Makefile - Fix OPENSSL_USE -> USES=ssl - Fix WANT_PHP_WEB -> USES=php:web - Fix MYSQL_USE -> USES+= mysql - Fix PGSQL_USES -> USES+= pgsql - Fix SQLITE_USES -> USES+= sqlite - Change default options for -server and -frontend - Fix CONFLICTS - fixed SQL injection vulnerability in "Latest data" page; thanks to 1N3 at Early Warning Services, LLC PR: 209893 MFH: 2016Q3 Security: https://support.zabbix.com/browse/ZBX-11023 Changes: http://www.zabbix.com/rn3.0.4.php Submitted by: Pakhom Golynga <pg@pakhom.spb.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=422263
Diffstat (limited to 'net-mgmt/zabbix3-frontend/Makefile')
-rw-r--r--net-mgmt/zabbix3-frontend/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-mgmt/zabbix3-frontend/Makefile b/net-mgmt/zabbix3-frontend/Makefile
index 43e56268eb36..ecf59b8bcf9a 100644
--- a/net-mgmt/zabbix3-frontend/Makefile
+++ b/net-mgmt/zabbix3-frontend/Makefile
@@ -5,6 +5,11 @@ PORTNAME= zabbix3
CATEGORIES= net-mgmt
PKGNAMESUFFIX= -frontend
+MAINTAINER= pg@pakhom.spb.ru
+COMMENT= Enterprise-class open source distributed monitoring (${PKGNAMESUFFIX:S/^-//}) LTS
+
+LICENSE= GPLv2
+
MASTERDIR= ${.CURDIR}/../zabbix3-server
NO_BUILD= yes
@@ -14,10 +19,11 @@ PLIST= ${PKGDIR}/pkg-plist.frontend
USE_PHP= bcmath ctype gd pcre snmp sockets mbstring session dom xml \
xmlreader xmlwriter simplexml gettext ldap
-WANT_PHP_WEB= yes
+
+USES= php:web gettext
OPTIONS_DEFINE= MYSQL MYSQLI PGSQL SQLITE ORACLE
-OPTIONS_DEFAULT= MYSQL MYSQLI
+OPTIONS_DEFAULT= MYSQLI
MYSQLI_DESC= MySQLI backend
.include <bsd.port.options.mk>
@@ -40,7 +46,7 @@ USE_PHP+= sqlite3
.if ${PORT_OPTIONS:MORACLE}
ZABBIX_REQUIRE=
-CONFIGURE_ARGS+= --with-oracle
+CONFIGURE_ARGS+= --with-oracle
.endif
do-install: