aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zabbix52-frontend
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-11-03 14:40:39 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-11-03 14:40:39 +0000
commitdbfcfa6d138680c75f5efa596939b71f0907a407 (patch)
treeeac14f935b23c6ee0f0e5b8262a6a1d27a14c9d6 /net-mgmt/zabbix52-frontend
parent6632bb28386cc0c497f94f4eddc28ab936cd2883 (diff)
downloadports-dbfcfa6d138680c75f5efa596939b71f0907a407.tar.gz
ports-dbfcfa6d138680c75f5efa596939b71f0907a407.zip
New ports: net-mgmt/zabbix52-[agent|frontend|java|proxy|server]
net-mgmt/zabbix5 -> net-mgmt/zabbix52 What's new in Zabbix 5.2: https://www.zabbix.com/documentation/current/manual/introduction/whatsnew520 Changelog: https://www.zabbix.com/rn/rn5.2.0 PR: 250775 Approved by: pg@pakhom.spb.ru (maintainer)
Notes
Notes: svn path=/head/; revision=553988
Diffstat (limited to 'net-mgmt/zabbix52-frontend')
-rw-r--r--net-mgmt/zabbix52-frontend/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-mgmt/zabbix52-frontend/Makefile b/net-mgmt/zabbix52-frontend/Makefile
new file mode 100644
index 000000000000..28ff097fb14c
--- /dev/null
+++ b/net-mgmt/zabbix52-frontend/Makefile
@@ -0,0 +1,34 @@
+# Created by: Pakhom Golynga <pg@pakhom.spb.ru>
+# $FreeBSD$
+
+PORTNAME= zabbix52
+CATEGORIES= net-mgmt
+PKGNAMESUFFIX= -frontend
+
+MASTERDIR= ${.CURDIR}/../zabbix52-server
+
+NO_BUILD= yes
+NO_ARCH= yes
+PATCHDIR=
+PLIST= ${PKGDIR}/pkg-plist.frontend
+
+USE_PHP= bcmath ctype dom fileinfo filter gd gettext hash json ldap mbstring \
+ openssl pcre session simplexml snmp sockets xml xmlreader xmlwriter
+USES+= php:web
+
+OPTIONS_DEFINE= MYSQLI PGSQL ORACLE
+OPTIONS_DEFAULT= MYSQLI
+MYSQLI_DESC= MySQLI backend
+
+MYSQLI_USE= PHP=mysqli
+
+PGSQL_USE= PHP=pgsql
+
+ORACLE_CONFIGURE_WITH= oracle
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC}/ui && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include "${MASTERDIR}/Makefile"