aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/zenpack-macreport
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-10-30 16:41:50 +0000
committerChris Rees <crees@FreeBSD.org>2011-10-30 16:41:50 +0000
commit1d3e7937d4a30dbb47efc77536925c6dd8ce1f2d (patch)
treeb827a180346fa14491d65b9a4c9da633c82d0dcc /net-mgmt/zenpack-macreport
parenta7b1a89afd3528b7cb1d8835eba6779838403aeb (diff)
downloadports-1d3e7937d4a30dbb47efc77536925c6dd8ce1f2d.tar.gz
ports-1d3e7937d4a30dbb47efc77536925c6dd8ce1f2d.zip
Notes
Diffstat (limited to 'net-mgmt/zenpack-macreport')
-rw-r--r--net-mgmt/zenpack-macreport/Makefile25
-rw-r--r--net-mgmt/zenpack-macreport/distinfo2
-rw-r--r--net-mgmt/zenpack-macreport/files/pkg-deinstall.in10
-rw-r--r--net-mgmt/zenpack-macreport/files/pkg-message.in5
-rw-r--r--net-mgmt/zenpack-macreport/pkg-descr12
-rw-r--r--net-mgmt/zenpack-macreport/pkg-plist2
6 files changed, 56 insertions, 0 deletions
diff --git a/net-mgmt/zenpack-macreport/Makefile b/net-mgmt/zenpack-macreport/Makefile
new file mode 100644
index 000000000000..4c504dcbaea1
--- /dev/null
+++ b/net-mgmt/zenpack-macreport/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: MACReport
+# Date created: 13 May 2011
+# Whom: Zenoss <zenoss@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= MACReport
+PORTVERSION= 1.0.1
+CATEGORIES= net-mgmt
+MASTER_SITES= http://zenpacks.zenoss.org/trac-zenpacks/changeset/1002/tags/
+DISTFILES= mac-report-${PORTVERSION}?old_path=%2F\&format=zip
+
+MAINTAINER= zenoss@experts-exchange.com
+COMMENT= Lists MAC address and the Device and Interface associated info
+
+USE_ZIP= yes
+ZPACKGROUP= community
+WRKSRC= ${WRKDIR}/tags/mac-report-${PORTVERSION}
+
+ZPACKPREFIX= ZenPacks.sodonnell.
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/zenpack-macreport/distinfo b/net-mgmt/zenpack-macreport/distinfo
new file mode 100644
index 000000000000..d3d674c24236
--- /dev/null
+++ b/net-mgmt/zenpack-macreport/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mac-report-1.0.1?old_path=%2F&format=zip) = 085e200d48736f73ff7adaf008930d9d6f533dd6ff262963051d6210522de436
+SIZE (mac-report-1.0.1?old_path=%2F&format=zip) = 5491
diff --git a/net-mgmt/zenpack-macreport/files/pkg-deinstall.in b/net-mgmt/zenpack-macreport/files/pkg-deinstall.in
new file mode 100644
index 000000000000..a1f84ae8e2cf
--- /dev/null
+++ b/net-mgmt/zenpack-macreport/files/pkg-deinstall.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ echo "To de-activate this Zenpack, run the following command as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --remove %%ZPACKPREFIX%%%%PORTNAME%%
+
+IMPORTANT: De-activating a Zenpack will also remove all its associated data"
+
+fi
diff --git a/net-mgmt/zenpack-macreport/files/pkg-message.in b/net-mgmt/zenpack-macreport/files/pkg-message.in
new file mode 100644
index 000000000000..869bea811264
--- /dev/null
+++ b/net-mgmt/zenpack-macreport/files/pkg-message.in
@@ -0,0 +1,5 @@
+
+To activate this Zenpack, run the following commands as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --install %%ZPACKHOME%%/%%ZPACK%%
+%%ZENHOME%%/bin/zopectl restart
diff --git a/net-mgmt/zenpack-macreport/pkg-descr b/net-mgmt/zenpack-macreport/pkg-descr
new file mode 100644
index 000000000000..b830c8365c35
--- /dev/null
+++ b/net-mgmt/zenpack-macreport/pkg-descr
@@ -0,0 +1,12 @@
+This ZenPack consists of a report for listing each MAC address and the Device
+and Interface it is associated with. This report makes use of the layer 2
+catalog already present in Zenoss. It only allows sorting by MAC address and is
+not exportable. The author made this decision because the processing time was
+too great for an installation with more than a few thousand interfaces. The
+author can make another one available that is exportable and sortable by the
+other two fields (device and interface), if anyone decides they would like to
+live through the painful wait time.
+
+More details can be found at provided url.
+
+WWW: http://community.zenoss.org/docs/DOC-3512
diff --git a/net-mgmt/zenpack-macreport/pkg-plist b/net-mgmt/zenpack-macreport/pkg-plist
new file mode 100644
index 000000000000..52307ea0055e
--- /dev/null
+++ b/net-mgmt/zenpack-macreport/pkg-plist
@@ -0,0 +1,2 @@
+zenoss/ZenPack/%%ZPACK%%
+@dirrmtry zenoss/ZenPack