aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2021-03-29 14:41:29 +0000
committerDan Langille <dvl@FreeBSD.org>2021-03-29 14:41:29 +0000
commit16686cacc5192f2120615b0461d31e2d1590e3a9 (patch)
tree86cd53651ce966bcc773d71f5dc2b1dcac087e2b /net-mgmt
parent6cac2f79cb84f4a7e8f5c39f58964af5c2648232 (diff)
downloadports-16686cacc5192f2120615b0461d31e2d1590e3a9.tar.gz
ports-16686cacc5192f2120615b0461d31e2d1590e3a9.zip
Update to 21.3.0
Upstream has changed their release number, but I don't think that will affect us at all. It appears to follow year.month I have sent some newly added patches upstream (https://github.com/librenms/librenms/pull/12647) and they will be removed from here on the next release. This update jumps over 21.20, 21.1.0, & 17.0.1 for no reason. While here, include a patch from an outstanding PR PR: 252640 Submitted by: geoffroy desvernay <dgeo@centrale-marseille.fr>
Notes
Notes: svn path=/head/; revision=569472
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/librenms/Makefile8
-rw-r--r--net-mgmt/librenms/distinfo10
-rw-r--r--net-mgmt/librenms/files/patch-LibreNMS_Validations_System.php20
-rw-r--r--net-mgmt/librenms/files/patch-poller-wrapper.py12
4 files changed, 34 insertions, 16 deletions
diff --git a/net-mgmt/librenms/Makefile b/net-mgmt/librenms/Makefile
index b3ad1423157b..dd621abea522 100644
--- a/net-mgmt/librenms/Makefile
+++ b/net-mgmt/librenms/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= librenms
-PORTVERSION= 1.70.1
-PORTREVISION= 2
+PORTVERSION= 21.3.0
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= LOCAL/dvl:vendor
@@ -14,12 +13,12 @@ COMMENT= Autodiscovering PHP/MySQL/SNMP based network monitoring
LICENSE= GPLv3
-USES= shebangfix python
+USES= shebangfix python php
# RELEASE_TIMESTAMP is used for a patch inside the vendor code
# it represents the release date via: git show --pretty='%H|%ct' -s 1.42.01
# It sits here so you remember to update it with each release
-RELEASE_TIMESTAMP= 1606919946
+RELEASE_TIMESTAMP= 1616284710
# perhaps we also need python-memcache python-mysqldb
RUN_DEPENDS+= rrdtool:databases/rrdtool \
@@ -69,7 +68,6 @@ MYSQLD_USES_OFF= mysql:client
SHEBANG_FILES= scripts/auth_test.php \
scripts/check_requirements.py \
- scripts/deploy-docs.sh \
scripts/github-remove \
scripts/Migration/Standard_Conversion/convert_no_xml.sh \
scripts/Migration/Standard_Conversion/destwork_no_xml.sh \
diff --git a/net-mgmt/librenms/distinfo b/net-mgmt/librenms/distinfo
index b6d1e547a3ca..efb0015021a7 100644
--- a/net-mgmt/librenms/distinfo
+++ b/net-mgmt/librenms/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1608472644
-SHA256 (librenms-vendor-1.70.1.tar.gz) = d8f5c8e3af145f65f56bc4bbbd5881bf819f05807aba9a043524d76e2134ef71
-SIZE (librenms-vendor-1.70.1.tar.gz) = 28043632
-SHA256 (librenms-librenms-1.70.1_GH0.tar.gz) = db731e24ecf703ba566363c09103aedde08a3f6daa6ff1e6627f644bd284c1f6
-SIZE (librenms-librenms-1.70.1_GH0.tar.gz) = 47603341
+TIMESTAMP = 1616683224
+SHA256 (librenms-vendor-21.3.0.tar.gz) = e06532500ac6aba46745de24dbb263fa481345cd0884f6b667ade69a20ce39ee
+SIZE (librenms-vendor-21.3.0.tar.gz) = 28253811
+SHA256 (librenms-librenms-21.3.0_GH0.tar.gz) = cf3cc5bd4fb7ebeb68ad731fea9601a009b87ef738f7063c6a33690a47483dc0
+SIZE (librenms-librenms-21.3.0_GH0.tar.gz) = 49218982
diff --git a/net-mgmt/librenms/files/patch-LibreNMS_Validations_System.php b/net-mgmt/librenms/files/patch-LibreNMS_Validations_System.php
new file mode 100644
index 000000000000..f3c02c13593a
--- /dev/null
+++ b/net-mgmt/librenms/files/patch-LibreNMS_Validations_System.php
@@ -0,0 +1,20 @@
+--- LibreNMS/Validations/System.php.orig 2021-03-25 16:28:19 UTC
++++ LibreNMS/Validations/System.php
+@@ -39,7 +39,7 @@ class System extends BaseValidation
+ $install_dir = $validator->getBaseDir();
+
+ $lnms = `which lnms 2>/dev/null`;
+- if (empty($lnms)) {
++ if (empty($lnms) && !Config::get('installed_from_package')) {
+ $validator->warn('Global lnms shortcut not installed. lnms command must be run with full path', "sudo ln -s $install_dir/lnms /usr/bin/lnms");
+ }
+
+@@ -50,7 +50,7 @@ class System extends BaseValidation
+ }
+
+ $rotation_file = '/etc/logrotate.d/librenms';
+- if (! file_exists($rotation_file)) {
++ if (! file_exists($rotation_file) && !Config::get('installed_from_package')) {
+ $validator->warn('Log rotation not enabled, could cause disk space issues', "sudo cp $install_dir/misc/librenms.logrotate $rotation_file");
+ }
+ }
diff --git a/net-mgmt/librenms/files/patch-poller-wrapper.py b/net-mgmt/librenms/files/patch-poller-wrapper.py
index e39137451c32..6ec6dc710480 100644
--- a/net-mgmt/librenms/files/patch-poller-wrapper.py
+++ b/net-mgmt/librenms/files/patch-poller-wrapper.py
@@ -1,11 +1,11 @@
---- poller-wrapper.py.orig 2020-07-20 20:50:23 UTC
+--- poller-wrapper.py.orig 2021-01-14 02:21:36 UTC
+++ poller-wrapper.py
-@@ -27,6 +27,8 @@
-
- import LibreNMS.library as LNMS
+@@ -44,6 +44,8 @@ except ImportError as exc:
+ print('ERROR: %s' % exc)
+ sys.exit(2)
+os.environ['PATH'] += ':/usr/local/sbin:/usr/local/bin'
+
- try:
- import json
+ APP_NAME = "poller_wrapper"
+ LOG_FILE = "logs/" + APP_NAME + ".log"