aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2014-11-22 20:40:08 +0000
committerChris Rees <crees@FreeBSD.org>2014-11-22 20:40:08 +0000
commit4cb60faedd280bf4b0b07bd947bd9087e09d4357 (patch)
tree68afea909ff5f83c22ece4ec8e2ae5959483778d /net-mgmt
parent5b6c7671efda9fa65107199c83addafb2a6f9dca (diff)
downloadports-4cb60faedd280bf4b0b07bd947bd9087e09d4357.tar.gz
ports-4cb60faedd280bf4b0b07bd947bd9087e09d4357.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/collectd/Makefile2
-rw-r--r--net-mgmt/collectd5/Makefile2
-rw-r--r--net-mgmt/flow-tools/Makefile2
-rw-r--r--net-mgmt/nagios-check_postgres/Makefile2
-rw-r--r--net-mgmt/netmagis-common/Makefile8
-rw-r--r--net-mgmt/pmacct/Makefile2
-rw-r--r--net-mgmt/rackmonkey/Makefile4
7 files changed, 10 insertions, 12 deletions
diff --git a/net-mgmt/collectd/Makefile b/net-mgmt/collectd/Makefile
index 2443f5d7203d..65f95aefe537 100644
--- a/net-mgmt/collectd/Makefile
+++ b/net-mgmt/collectd/Makefile
@@ -334,7 +334,7 @@ PLIST_SUB+= PDNS="@comment "
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--enable-postgresql
PLIST_SUB+= PGSQL=""
.else
diff --git a/net-mgmt/collectd5/Makefile b/net-mgmt/collectd5/Makefile
index 74d1877c87a5..27d00c36e9fb 100644
--- a/net-mgmt/collectd5/Makefile
+++ b/net-mgmt/collectd5/Makefile
@@ -299,7 +299,7 @@ PLIST_SUB+= PERL="@comment "
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--with-postgresql=${LOCALBASE} --enable-postgresql --with-libpq
PLIST_SUB+= PGSQL=""
.else
diff --git a/net-mgmt/flow-tools/Makefile b/net-mgmt/flow-tools/Makefile
index 53039cb4b6c8..1b2de5877afa 100644
--- a/net-mgmt/flow-tools/Makefile
+++ b/net-mgmt/flow-tools/Makefile
@@ -42,7 +42,7 @@ FLOW_CAPTURE_PIDDIR= ${VARDIR}/run/flow-capture
.if ${PORT_OPTIONS:MPGSQL}
CONFIGURE_ARGS+=--with-pgsql="${PREFIX}"
-USE_PGSQL= yes
+USES+= pgsql
.endif
.if ${PORT_OPTIONS:MMYSQL}
diff --git a/net-mgmt/nagios-check_postgres/Makefile b/net-mgmt/nagios-check_postgres/Makefile
index 88db6cab161a..aaadbfa86df0 100644
--- a/net-mgmt/nagios-check_postgres/Makefile
+++ b/net-mgmt/nagios-check_postgres/Makefile
@@ -17,7 +17,7 @@ NO_ARCH= yes
USES= perl5
USE_PERL5= configure
-USE_PGSQL= yes
+USES+= pgsql
# This script is primarily used for monitoring via Nagios, but it also
# has output styles compatible with cacti or mrtg. The options
diff --git a/net-mgmt/netmagis-common/Makefile b/net-mgmt/netmagis-common/Makefile
index efb9f4f78c91..ff57a83a0200 100644
--- a/net-mgmt/netmagis-common/Makefile
+++ b/net-mgmt/netmagis-common/Makefile
@@ -17,10 +17,8 @@ COMMENT?= Netmagis common infrastructure
#LICENSE_FILE= ${WRKSRC}/LICENSE
#LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= tcl:85+
-
-USE_PGSQL= pgtcl
-WANT_PGSQL_VER= 91+
+USES= tcl:85+ pgsql:9.1+
+WANT_PGSQL= pgtcl
RUN_DEPENDS+= dtplite:${PORTSDIR}/devel/tcllib
@@ -30,7 +28,7 @@ RUN_DEPENDS+= netmagis-config:${PORTSDIR}/net-mgmt/netmagis-common
.if ${PKGNAMESUFFIX} == -database
RUN_DEPENDS+= pwgen:${PORTSDIR}/sysutils/pwgen
-USE_PGSQL+= server pltcl
+WANT_PGSQL+= server
.endif
.if ${PKGNAMESUFFIX} == -www
diff --git a/net-mgmt/pmacct/Makefile b/net-mgmt/pmacct/Makefile
index 971de46e40a7..be32390fb06e 100644
--- a/net-mgmt/pmacct/Makefile
+++ b/net-mgmt/pmacct/Makefile
@@ -45,7 +45,7 @@ PLIST_SUB+= WITH_MYSQL="@comment "
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= yes
+USES+= pgsql
CONFIGURE_ARGS+=--enable-pgsql
PLIST_SUB+= WITH_PGSQL=""
.else
diff --git a/net-mgmt/rackmonkey/Makefile b/net-mgmt/rackmonkey/Makefile
index 960b3de6dc79..950d89a9ca76 100644
--- a/net-mgmt/rackmonkey/Makefile
+++ b/net-mgmt/rackmonkey/Makefile
@@ -43,7 +43,7 @@ USE_MYSQL= yes
RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.if ${PORT_OPTIONS:MPGSQL}
-USE_PGSQL= 83
+USES+= pgsql
RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
.endif
@@ -80,7 +80,7 @@ do-install:
fi \
fi \
fi \
- elif [ "${USE_MYSQL}" -o "${USE_PGSQL}" ]; then \
+ elif [ "${USE_MYSQL}" -o "${USES:MPGSQL}" ]; then \
${INSTALL} ${WRKSRC}/conf/rackmonkey.conf-default ${STAGEDIR}${WWWDIR}/; \
fi
if [ -e "${WWWDIR}/rackmonkey.conf" ]; then \