aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-04-05 05:12:48 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-04-05 05:12:48 +0000
commit7058206875658a3f6445486402a4da5de03a5f28 (patch)
tree7390ed8daf468bec745bc18d78b217796f6d762a /net-mgmt
parent0324527439fef0ff4349cc5dd0dda471cccd185f (diff)
downloadports-7058206875658a3f6445486402a4da5de03a5f28.tar.gz
ports-7058206875658a3f6445486402a4da5de03a5f28.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/py-pyIOSXR/Makefile22
-rw-r--r--net-mgmt/py-pyIOSXR/distinfo3
-rw-r--r--net-mgmt/py-pyIOSXR/pkg-descr4
4 files changed, 30 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index 433edc020ca9..6073745d1f1e 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -314,6 +314,7 @@
SUBDIR += py-msrestazure
SUBDIR += py-ncclient
SUBDIR += py-pdagent
+ SUBDIR += py-pyIOSXR
SUBDIR += py-pyang
SUBDIR += py-pyeapi
SUBDIR += py-pynsca
diff --git a/net-mgmt/py-pyIOSXR/Makefile b/net-mgmt/py-pyIOSXR/Makefile
new file mode 100644
index 000000000000..33b62fae8711
--- /dev/null
+++ b/net-mgmt/py-pyIOSXR/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= pyIOSXR
+DISTVERSION= 0.52
+CATEGORIES= net-mgmt python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= freebsd_ports@k-worx.org
+COMMENT= Python API to interact with network devices running IOS-XR
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pip>=0:devel/py-pip@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=3.2.4:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}netmiko>=1.4.1:security/py-netmiko@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/py-pyIOSXR/distinfo b/net-mgmt/py-pyIOSXR/distinfo
new file mode 100644
index 000000000000..820070cf7675
--- /dev/null
+++ b/net-mgmt/py-pyIOSXR/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1522361007
+SHA256 (pyIOSXR-0.52.tar.gz) = 5d3478bc20a0680f1ddfba413f4a8576be640a8485f1cf4439af5803d45b0999
+SIZE (pyIOSXR-0.52.tar.gz) = 13603
diff --git a/net-mgmt/py-pyIOSXR/pkg-descr b/net-mgmt/py-pyIOSXR/pkg-descr
new file mode 100644
index 000000000000..c292cbf4c8b1
--- /dev/null
+++ b/net-mgmt/py-pyIOSXR/pkg-descr
@@ -0,0 +1,4 @@
+pyIOSXR is a Python library that facilitates communication with Cisco devices
+running IOS-XR through the XML agent.
+
+WWW: https://github.com/fooelisa/pyiosxr