aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2014-06-08 06:23:20 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2014-06-08 06:23:20 +0000
commit76a1a4c201da08ad23c9e78d7584bab3ac0e0f7d (patch)
treea5c8e4a85467d11705b939399f939c6c26c15c2c /net-mgmt
parentb6a1b5e25200f10e52cc40d0303c74c643073402 (diff)
downloadports-76a1a4c201da08ad23c9e78d7584bab3ac0e0f7d.tar.gz
ports-76a1a4c201da08ad23c9e78d7584bab3ac0e0f7d.zip
Convert to STAGE.
Notes
Notes: svn path=/head/; revision=356980
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/confregdecode/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/net-mgmt/confregdecode/Makefile b/net-mgmt/confregdecode/Makefile
index fc0edd56c4fd..55f9c017f63a 100644
--- a/net-mgmt/confregdecode/Makefile
+++ b/net-mgmt/confregdecode/Makefile
@@ -17,17 +17,20 @@ MAKE_ENV= JAVAC="${JAVAC}" JAR="${JAR}"
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
SUB_FILES= confregdecode
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
do-install:
- ${MKDIR} ${DATADIR}
- ${INSTALL_DATA} ${WRKSRC}/confregdecode.jar ${DATADIR}
- ${INSTALL_SCRIPT} ${WRKDIR}/confregdecode ${PREFIX}/bin
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/confregdecode.jar ${STAGEDIR}${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/confregdecode ${STAGEDIR}${PREFIX}/bin
post-install:
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in README.txt ConfregDecode.html
- ${INSTALL_MAN} ${WRKSRC}/${file} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
.endfor
.endif