aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2018-11-08 13:32:09 +0000
committerDan Langille <dvl@FreeBSD.org>2018-11-08 13:32:09 +0000
commit78d0c1ee287cb1abbfa947e135b32ad7c5c9a849 (patch)
tree941434acd412b81584612c0327092af0efc12b50 /net-mgmt
parentd0903b5de9765625ceb642dd7d8e63f5d6c01a07 (diff)
downloadports-78d0c1ee287cb1abbfa947e135b32ad7c5c9a849.tar.gz
ports-78d0c1ee287cb1abbfa947e135b32ad7c5c9a849.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/librenms/Makefile9
-rw-r--r--net-mgmt/librenms/distinfo10
-rw-r--r--net-mgmt/librenms/files/patch-LibreNMS_Validations_Dependencies.php12
-rw-r--r--net-mgmt/librenms/files/patch-LibreNMS_Validations_Programs.php10
-rw-r--r--net-mgmt/librenms/files/patch-LibreNMS_Validations_User.php18
-rw-r--r--net-mgmt/librenms/files/patch-html_install.php23
-rw-r--r--net-mgmt/librenms/files/patch-includes_common.php13
-rw-r--r--net-mgmt/librenms/files/patch-includes_defaults.inc.php4
-rw-r--r--net-mgmt/librenms/files/pkg-message.in17
9 files changed, 86 insertions, 30 deletions
diff --git a/net-mgmt/librenms/Makefile b/net-mgmt/librenms/Makefile
index 2d4b5600eb52..a08b887e3b48 100644
--- a/net-mgmt/librenms/Makefile
+++ b/net-mgmt/librenms/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= librenms
-PORTVERSION= 1.43
-PORTREVISION= 1
+PORTVERSION= 1.45
# RELEASE_TIMESTAMP is used for a patch inside the vendor code
# it represents the release date via: git show --pretty='%H|%ct' -s 1.42.01
# It sits here so you remember to update it with each release
-RELEASE_TIMESTAMP= 1535704658
+RELEASE_TIMESTAMP= 1539772408
PORTEPOCH= 1
CATEGORIES= net-mgmt
MASTER_SITES= LOCAL/dvl:vendor
@@ -30,7 +29,7 @@ RUN_DEPENDS+= rrdtool:databases/rrdtool \
USES= python${PY_MYSQL} shebangfix
-USE_PHP= ctype curl filter gd hash json ldap mbstring mcrypt mysqli openssl pdo posix session simplexml snmp tokenizer xml zip
+USE_PHP= ctype curl filter gd hash json ldap mbstring mysqli openssl pdo pdo_mysql posix session simplexml snmp tokenizer xml zip
USE_GITHUB= yes
GH_ACCOUNT= librenms
@@ -104,7 +103,7 @@ ROOT_FILES= .env.example addhost.php adduser.php alerts.php artisan billing-calc
poller-wrapper.py readmegen.yml renamehost.php services-wrapper.py snmp-scan.py \
snmptrap.php syslog.php validate.php
-ROOT_DIRS= LibreNMS app bootstrap config contrib database doc html includes lib licenses logs mibs misc resources routes scripts sql-schema storage tests
+ROOT_DIRS= LibreNMS app bootstrap config contrib database doc html includes licenses logs mibs misc resources routes scripts sql-schema storage tests
# these are directories which require a generic @DIR entry in pkg-plist
OTHER_DIRS= storage/app/public \
diff --git a/net-mgmt/librenms/distinfo b/net-mgmt/librenms/distinfo
index 25e37c3075be..bc4847178652 100644
--- a/net-mgmt/librenms/distinfo
+++ b/net-mgmt/librenms/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1535832769
-SHA256 (librenms-vendor-1.43.tar.gz) = e7364c085d5c636fdf8fd1dbc3d35da16b7a6ceee8934e740c8c3a8f6766d95a
-SIZE (librenms-vendor-1.43.tar.gz) = 31842846
-SHA256 (librenms-librenms-1.43_GH0.tar.gz) = 6f5fc969eae766d894715f703628534b35420ba3b77cc25988abfd522f14cb6c
-SIZE (librenms-librenms-1.43_GH0.tar.gz) = 32876746
+TIMESTAMP = 1540995479
+SHA256 (librenms-vendor-1.45.tar.gz) = 2c67feacbb448591528870d4c55448f8bcb804bdb1845902cdb2dc1b9f4846f3
+SIZE (librenms-vendor-1.45.tar.gz) = 31718828
+SHA256 (librenms-librenms-1.45_GH0.tar.gz) = b3365bf88c40c0ee098edbf2b34510e737f357c483560f04926775c4dea9954d
+SIZE (librenms-librenms-1.45_GH0.tar.gz) = 30880140
diff --git a/net-mgmt/librenms/files/patch-LibreNMS_Validations_Dependencies.php b/net-mgmt/librenms/files/patch-LibreNMS_Validations_Dependencies.php
new file mode 100644
index 000000000000..d78ab514b0ab
--- /dev/null
+++ b/net-mgmt/librenms/files/patch-LibreNMS_Validations_Dependencies.php
@@ -0,0 +1,12 @@
+--- LibreNMS/Validations/Dependencies.php.orig 2018-10-24 19:04:18 UTC
++++ LibreNMS/Validations/Dependencies.php
+@@ -38,6 +38,9 @@ class Dependencies extends BaseValidatio
+ */
+ public function validate(Validator $validator)
+ {
++ $validator->ok("Installed from package; no Composer required");
++ return;
++
+ $composer_output = trim(shell_exec($validator->getBaseDir() . '/scripts/composer_wrapper.php --version'));
+ $found = preg_match(
+ '/Composer.*(\d+\.\d+\.\d+(-RC\d*|-beta\d?|-alpha\d+)?)/',
diff --git a/net-mgmt/librenms/files/patch-LibreNMS_Validations_Programs.php b/net-mgmt/librenms/files/patch-LibreNMS_Validations_Programs.php
new file mode 100644
index 000000000000..84e801d9bc5b
--- /dev/null
+++ b/net-mgmt/librenms/files/patch-LibreNMS_Validations_Programs.php
@@ -0,0 +1,10 @@
+--- LibreNMS/Validations/Programs.php.orig 2018-10-17 10:33:28 UTC
++++ LibreNMS/Validations/Programs.php
+@@ -73,6 +73,7 @@ class Programs extends BaseValidation
+ return;
+ }
+
++ $validator->warn("fping FAILURES can be ignored if running LibreNMS in a jail without ::1. You may want to test it manually: fping ::1");
+ $validator->fail(
+ "$bin could not be executed. $bin must have CAP_NET_RAW capability (getcap) or suid. Selinux exlusions may be required.\n ($output)"
+ );
diff --git a/net-mgmt/librenms/files/patch-LibreNMS_Validations_User.php b/net-mgmt/librenms/files/patch-LibreNMS_Validations_User.php
new file mode 100644
index 000000000000..9c9546855117
--- /dev/null
+++ b/net-mgmt/librenms/files/patch-LibreNMS_Validations_User.php
@@ -0,0 +1,18 @@
+--- LibreNMS/Validations/User.php.orig 2018-10-17 10:33:28 UTC
++++ LibreNMS/Validations/User.php
+@@ -71,6 +71,7 @@ class User extends BaseValidation
+ "sudo setfacl -d -m g::rwx $rrd_dir $log_dir $dir/bootstrap/cache/ $dir/storage/\n" .
+ "sudo chmod -R ug=rwX $rrd_dir $log_dir $dir/bootstrap/cache/ $dir/storage/\n";
+
++ if (!Config::get('installed_from_package')) {
+ $find_result = rtrim(`find $dir \! -user $lnms_username -o \! -group $lnms_groupname 2> /dev/null`);
+ if (!empty($find_result)) {
+ // Ignore files created by the webserver
+@@ -124,6 +125,7 @@ class User extends BaseValidation
+ 'Some folders have incorrect file permissions, this may cause issues.'
+ )->setFix($fix)->setList('Files', explode(PHP_EOL, $incorrect)));
+ }
++ }
+ } else {
+ $validator->warn("You don't have \$config['user'] set, this most likely needs to be set to librenms");
+ }
diff --git a/net-mgmt/librenms/files/patch-html_install.php b/net-mgmt/librenms/files/patch-html_install.php
index f87bf965497c..6eaec2d41b3e 100644
--- a/net-mgmt/librenms/files/patch-html_install.php
+++ b/net-mgmt/librenms/files/patch-html_install.php
@@ -1,6 +1,6 @@
---- html/install.php.orig 2018-08-04 20:07:12 UTC
+--- html/install.php.orig 2018-10-17 10:33:28 UTC
+++ html/install.php
-@@ -357,7 +357,7 @@ $config_file = <<<"EOD"
+@@ -358,7 +358,7 @@ $config_file = <<<"EOD"
// This is the user LibreNMS will run as
//Please ensure this user is created and has the correct permissions to your install
@@ -9,7 +9,7 @@
### Locations - it is recommended to keep the default
#\$config\['install_dir'\] = "$install_dir";
-@@ -383,8 +383,8 @@ $config_file = <<<"EOD"
+@@ -384,15 +384,15 @@ $config_file = <<<"EOD"
#\$config\['nets'\]\[\] = "192.168.0.0/16";
# Update configuration
@@ -20,3 +20,20 @@
EOD;
if (!file_exists("../config.php")) {
+ $conf = fopen("../config.php", 'w');
+ if ($conf != false) {
+ if (fwrite($conf, "<?php\n") === false) {
+- echo("<div class='alert alert-danger'>We couldn't create the config.php file, please create this manually before continuing by copying the below into a config.php in the root directory of your install (typically /opt/librenms/)</div>");
++ echo("<div class='alert alert-danger'>We couldn't create the config.php file, please create this manually before continuing by copying the below into a config.php in the root directory of your install (typically /usr/local/www/librenms/)</div>");
+ echo("<pre>&lt;?php\n".stripslashes($config_file)."</pre>");
+ } else {
+ $config_file = stripslashes($config_file);
+@@ -400,7 +400,7 @@ if (!file_exists("../config.php")) {
+ echo("<div class='alert alert-success'>The config file has been created</div>");
+ }
+ } else {
+- echo("<div class='alert alert-danger'>We couldn't create the config.php file, please create this manually before continuing by copying the below into a config.php in the root directory of your install (typically /opt/librenms/)</div>");
++ echo("<div class='alert alert-danger'>We couldn't create the config.php file, please create this manually before continuing by copying the below into a config.php in the root directory of your install (typically /usr/local/www/librenms/)</div>");
+ echo("<pre>&lt;?php\n".stripslashes($config_file)."</pre>");
+ }
+ }
diff --git a/net-mgmt/librenms/files/patch-includes_common.php b/net-mgmt/librenms/files/patch-includes_common.php
index dfe8b9c90fa1..1a37a6eb5a8a 100644
--- a/net-mgmt/librenms/files/patch-includes_common.php
+++ b/net-mgmt/librenms/files/patch-includes_common.php
@@ -1,6 +1,6 @@
---- includes/common.php.orig 2018-08-04 20:07:12 UTC
+--- includes/common.php.orig 2018-10-17 10:33:28 UTC
+++ includes/common.php
-@@ -1157,6 +1157,10 @@ function version_info($remote = false)
+@@ -1158,6 +1158,10 @@ function version_info($remote = false)
$output['local_sha'] = $local_sha;
$output['local_date'] = $local_date;
$output['local_branch'] = rtrim(`git rev-parse --abbrev-ref HEAD`);
@@ -11,15 +11,12 @@
}
$output['db_schema'] = dbIsConnected() ? get_db_schema() : '?';
$output['php_ver'] = phpversion();
-@@ -1713,6 +1717,12 @@ function set_numeric($value, $default =
+@@ -1719,6 +1723,9 @@ function set_numeric($value, $default =
function check_git_exists()
{
-+ global $config;
-+
-+ if (!empty($config['installed_from_package'])) {
-+ return false;
-+ }
++ # installed from package; git not involved
++ return false;
+
exec('git > /dev/null 2>&1', $response, $exit_code);
if ($exit_code === 1) {
diff --git a/net-mgmt/librenms/files/patch-includes_defaults.inc.php b/net-mgmt/librenms/files/patch-includes_defaults.inc.php
index 03cfaf20b0da..52b77758f7f9 100644
--- a/net-mgmt/librenms/files/patch-includes_defaults.inc.php
+++ b/net-mgmt/librenms/files/patch-includes_defaults.inc.php
@@ -1,6 +1,6 @@
---- includes/defaults.inc.php.orig 2018-08-04 20:07:12 UTC
+--- includes/defaults.inc.php.orig 2018-10-17 10:33:28 UTC
+++ includes/defaults.inc.php
-@@ -47,19 +47,19 @@ $config['own_hostname'] = 'localhost';
+@@ -49,19 +49,19 @@ $config['own_hostname'] = 'localhost';
$config['fping_options']['timeout'] = 500;
$config['fping_options']['count'] = 3;
$config['fping_options']['interval'] = 500;
diff --git a/net-mgmt/librenms/files/pkg-message.in b/net-mgmt/librenms/files/pkg-message.in
index a4f944dacd35..be46a270b382 100644
--- a/net-mgmt/librenms/files/pkg-message.in
+++ b/net-mgmt/librenms/files/pkg-message.in
@@ -1,13 +1,16 @@
-=== Configuration details ===
-The following is recommended for /usr/local/etc/mysql/my.cnf
+=== UPGRADE details ===
+
+Depending on the version, you may have to run the upgrade script.
-NOTE: these are global settings. Please read this first:
+cd %%WWWDIR%%
+./build-base.php
-http://dev.mysql.com/doc/refman/5.7/en/sql-mode.html
+re: https://docs.librenms.org/#General/Updating/
+
+=== Configuration details ===
-[mysqld]
-innodb_file_per_table=1
-sql-mode=""
+NOTE: setting sql-mode="" is no longer required. You can remove
+it from /usr/local/etc/mysql/my.cnf
You can mostly follow the guide at:
http://docs.librenms.org/