aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:06:21 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-13 14:06:21 +0000
commitc5c9146b354fcf2443efe35ac79f4372c7d87354 (patch)
tree0f37f75ab8599367391697e35a5fc9811fea36f5 /net-mgmt
parentb7c396bdc68d8726701949db9571cc1acc7428e3 (diff)
downloadports-c5c9146b354fcf2443efe35ac79f4372c7d87354.tar.gz
ports-c5c9146b354fcf2443efe35ac79f4372c7d87354.zip
net-mgmt/py-ipy: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/py-ipy/Makefile10
-rw-r--r--net-mgmt/py-ipy/files/patch-setup.py11
2 files changed, 18 insertions, 3 deletions
diff --git a/net-mgmt/py-ipy/Makefile b/net-mgmt/py-ipy/Makefile
index 3468c9a88a97..9c1bf1b20198 100644
--- a/net-mgmt/py-ipy/Makefile
+++ b/net-mgmt/py-ipy/Makefile
@@ -1,9 +1,10 @@
PORTNAME= ipy
-PORTVERSION= 1.01
+PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= net-mgmt python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= IPy-${PORTVERSION}
+DISTNAME= IPy-1.01
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python module for handling IPv4 and IPv6 Addresses and Networks
@@ -12,8 +13,11 @@ WWW= https://github.com/autocracy/python-ipy
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/net-mgmt/py-ipy/files/patch-setup.py b/net-mgmt/py-ipy/files/patch-setup.py
new file mode 100644
index 000000000000..5fb84f3a86e7
--- /dev/null
+++ b/net-mgmt/py-ipy/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2020-12-01 20:32:26 UTC
++++ setup.py
+@@ -56,7 +56,7 @@ setup(
+ URL = "https://github.com/autocracy/python-ipy"
+
+ setup(
+- name="IPy",
++ name="ipy",
+ version=VERSION,
+ description="Class and tools for handling of IPv4 and IPv6 addresses and networks",
+ long_description=LONG_DESCRIPTION,