aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2014-03-03 14:21:44 +0000
committerMark Felder <feld@FreeBSD.org>2014-03-03 14:21:44 +0000
commited3ab565f9af8e121d8c7df3c493018910b077e2 (patch)
treed8c8f8f527b767c17ae0c5e03b467f913183a097 /net-mgmt
parentd38461c76f5591107c62d512cac83c2adcec9bdb (diff)
downloadports-ed3ab565f9af8e121d8c7df3c493018910b077e2.tar.gz
ports-ed3ab565f9af8e121d8c7df3c493018910b077e2.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/flowviewer/Makefile48
-rw-r--r--net-mgmt/flowviewer/distinfo4
-rw-r--r--net-mgmt/flowviewer/files/patch-FlowViewer__Configuration.pm40
-rw-r--r--net-mgmt/flowviewer/files/pkg-message.in2
-rw-r--r--net-mgmt/flowviewer/pkg-plist19
5 files changed, 56 insertions, 57 deletions
diff --git a/net-mgmt/flowviewer/Makefile b/net-mgmt/flowviewer/Makefile
index a833d7460d15..316536a97789 100644
--- a/net-mgmt/flowviewer/Makefile
+++ b/net-mgmt/flowviewer/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= flowviewer
-PORTVERSION= 4.2.2
+PORTVERSION= 4.3
CATEGORIES= net-mgmt
MASTER_SITES= SF/${PORTNAME}
DISTNAME= FlowViewer_${DISTVERSION}
@@ -23,15 +23,15 @@ NETFLOWv9_DESC= Support for IPFIX/NETFLOWv9
NETFLOWv5_RUN_DEPENDS= flow-cat:${PORTSDIR}/net-mgmt/flow-tools-ng
NETFLOWv9_RUN_DEPENDS= rwptoflow:${PORTSDIR}/security/silktools
-FLOWVIEWERDIR?= ${STAGEDIR}${PREFIX}/www/flowviewer
+FLOWVIEWERDIR?= ${PREFIX}/www/flowviewer
PLIST_SCRIPT= FV.cgi FV_Relay.cgi FlowGrapher.cgi FlowGrapher_Main.cgi \
- FlowGrapher_Relay.cgi FlowGrapher_Replay.cgi FlowGrapher_Sort.cgi \
+ FlowGrapher_Replay.cgi FlowGrapher_Sort.cgi \
FlowTracker.cgi FlowTracker_Dashboard.cgi FlowTracker_Display.cgi \
FlowTracker_DisplayPublic.cgi FlowTracker_Dumper.cgi \
FlowTracker_Group.cgi FlowTracker_Main.cgi FlowTracker_Management.cgi \
- FlowTracker_Relay.cgi FlowTracker_Replay.cgi FlowViewer.cgi \
- FlowViewer_Main.cgi FlowViewer_Relay.cgi FlowViewer_Replay.cgi \
+ FlowTracker_Replay.cgi FlowViewer.cgi dscan.suppress.dst dscan.suppress.src \
+ FlowViewer_Main.cgi FlowViewer_Replay.cgi \
FlowViewer_Save.cgi FlowViewer_SaveManage.cgi FlowViewer_Sort.cgi \
FlowViewer_UI.pm FlowViewer_Utilities.pm FlowGrapher_Colors \
FlowTracker_AltDashboard FlowTracker_Collector FlowTracker_Grapher \
@@ -40,13 +40,15 @@ PLIST_SCRIPT= FV.cgi FV_Relay.cgi FlowGrapher.cgi FlowGrapher_Main.cgi \
NamedInterfaces_Devices NamedInterfaces_Exporters
PLIST_DATA= FG_button.png FT_button.png FV_button.png FlowViewer.css
PLIST_TOOLS= flowcapture_restart resize_rrdtools flowtracker_grapher_nonlazy \
- date_to_epoch_gm performance_check edc_rwflowappend flowtracker_restart \
+ date_to_epoch_gm performance_check flowtracker_restart \
convert_pre40_filters analyze_flowtracker_debug flowtracker_grapher_recent \
flow-capture-table.conf rsync_trackings epoch_to_date_local rwflowpack_start \
- edc_rwreceiver epoch_to_date_gm rsync_htmls flowtracker_archive_restore \
- date_to_epoch_local analyze_netflow_packets rsync_flows copy_netflow_jpl
+ epoch_to_date_gm rsync_htmls flowtracker_archive_restore \
+ date_to_epoch_local analyze_netflow_packets rsync_flows
-PLIST_SUB+= FLOWVIEWERDIR="${FLOWVIEWERDIR:S,^${STAGEDIR}${PREFIX}/,,}"
+PLIST_SUB+= FLOWVIEWERDIR="${FLOWVIEWERDIR}" \
+ WWWOWN=${WWWOWN} \
+ WWWGRP=${WWWGRP}
SUB_LIST+= "FLOWVIEWERDIR=${FLOWVIEWERDIR}" \
"PKGNAME=${PKGNAME}"
SUB_FILES= pkg-message
@@ -56,37 +58,31 @@ NO_BUILD= yes
PORTDOCS= README
-NO_STAGE= yes
.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -E \
- -e "s|%%PREFIX%%|${STAGEDIR}${PREFIX}|" \
+ -e "s|%%PREFIX%%|${PREFIX}|" \
${WRKSRC}/FlowViewer_Configuration.pm
@${REINPLACE_CMD} -E \
-e "s|%%FLOWVIEWERDIR%%|${FLOWVIEWERDIR}|" \
${WRKSRC}/FlowViewer_Configuration.pm
do-install:
- ${MKDIR} ${FLOWVIEWERDIR}
- ${MKDIR} ${FLOWVIEWERDIR}/tools
- ${INSTALL_DATA} ${WRKSRC}/FlowViewer_Configuration.pm ${FLOWVIEWERDIR}/FlowViewer_Configuration.pm.dist
- ${MKDIR} ${FLOWVIEWERDIR}/tmp ${FLOWVIEWERDIR}/reports \
- ${FLOWVIEWERDIR}/graphs ${FLOWVIEWERDIR}/tracker ${FLOWVIEWERDIR}/working \
- ${FLOWVIEWERDIR}/saves ${FLOWVIEWERDIR}/names ${FLOWVIEWERDIR}/filters \
- ${FLOWVIEWERDIR}/rrdtools ${FLOWVIEWERDIR}/FlowViewer_Dashboard
- ${CHOWN} ${WWWOWN}:${WWWGRP} ${FLOWVIEWERDIR}/tmp \
- ${FLOWVIEWERDIR}/reports ${FLOWVIEWERDIR}/graphs \
- ${FLOWVIEWERDIR}/tracker ${FLOWVIEWERDIR}/working ${FLOWVIEWERDIR}/saves \
- ${FLOWVIEWERDIR}/names ${FLOWVIEWERDIR}/filters ${FLOWVIEWERDIR}/rrdtools \
- ${FLOWVIEWERDIR}/FlowViewer_Dashboard ${FLOWVIEWERDIR}/tools
+ ${MKDIR} ${STAGEDIR}${FLOWVIEWERDIR}
+ ${MKDIR} ${STAGEDIR}${FLOWVIEWERDIR}/tools
+ ${INSTALL_DATA} ${WRKSRC}/FlowViewer_Configuration.pm ${STAGEDIR}${FLOWVIEWERDIR}/FlowViewer_Configuration.pm.dist
+ ${MKDIR} ${STAGEDIR}${FLOWVIEWERDIR}/tmp ${STAGEDIR}${FLOWVIEWERDIR}/reports \
+ ${STAGEDIR}${FLOWVIEWERDIR}/graphs ${STAGEDIR}${FLOWVIEWERDIR}/tracker ${STAGEDIR}${FLOWVIEWERDIR}/working \
+ ${STAGEDIR}${FLOWVIEWERDIR}/saves ${STAGEDIR}${FLOWVIEWERDIR}/names ${STAGEDIR}${FLOWVIEWERDIR}/filters \
+ ${STAGEDIR}${FLOWVIEWERDIR}/rrdtools ${STAGEDIR}${FLOWVIEWERDIR}/FlowViewer_Dashboard
.for i in ${PLIST_SCRIPT}
- @${INSTALL_SCRIPT} ${WRKSRC}/${i} ${FLOWVIEWERDIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${i} ${STAGEDIR}${FLOWVIEWERDIR}
.endfor
.for i in ${PLIST_TOOLS}
- @${INSTALL_SCRIPT} ${WRKSRC}/tools/${i} ${FLOWVIEWERDIR}/tools
+ @${INSTALL_SCRIPT} ${WRKSRC}/tools/${i} ${STAGEDIR}${FLOWVIEWERDIR}/tools
.endfor
.for i in ${PLIST_DATA}
- @${INSTALL_DATA} ${WRKSRC}/${i} ${FLOWVIEWERDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${FLOWVIEWERDIR}/reports
.endfor
.if ${PORT_OPTIONS:MDOCS}
diff --git a/net-mgmt/flowviewer/distinfo b/net-mgmt/flowviewer/distinfo
index 973e0dedb700..16406d0ae6a6 100644
--- a/net-mgmt/flowviewer/distinfo
+++ b/net-mgmt/flowviewer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FlowViewer_4.2.2.tar) = b39f01e199c0b57f928576ae487afcf14d1899c9f7dc47e2af30303e9d1c1b9c
-SIZE (FlowViewer_4.2.2.tar) = 1013760
+SHA256 (FlowViewer_4.3.tar) = 740086dbf4b70aed625c650caddd4c010ea49d035253165b6087f2c12dc9188a
+SIZE (FlowViewer_4.3.tar) = 1024000
diff --git a/net-mgmt/flowviewer/files/patch-FlowViewer__Configuration.pm b/net-mgmt/flowviewer/files/patch-FlowViewer__Configuration.pm
index 238969de25c1..434fef37c67e 100644
--- a/net-mgmt/flowviewer/files/patch-FlowViewer__Configuration.pm
+++ b/net-mgmt/flowviewer/files/patch-FlowViewer__Configuration.pm
@@ -1,6 +1,11 @@
---- FlowViewer_Configuration.pm.orig 2013-11-20 17:01:30.000000000 +0600
-+++ FlowViewer_Configuration.pm 2013-11-20 17:14:57.000000000 +0600
-@@ -59,28 +59,28 @@
+--- FlowViewer_Configuration.pm.orig 2014-02-24 17:44:27.000000000 +0400
++++ FlowViewer_Configuration.pm 2014-02-24 17:54:45.000000000 +0400
+@@ -56,31 +56,31 @@
+
+ # Service
+
+-$FlowViewer_service = "https"; # (http, or https)
++$FlowViewer_service = "http"; # (http, or https)
# Directories and Files:
@@ -10,29 +15,28 @@
-$graphs_short = "/FlowGrapher";
-$tracker_directory = "/var/www/html/FlowTracker";
-$tracker_short = "/FlowTracker";
+-$cgi_bin_directory = "/var/www/cgi-bin/FlowViewer_4.3";
+-$cgi_bin_short = "/cgi-bin/FlowViewer_4.3";
+-$work_directory = "/var/www/cgi-bin/FlowViewer_4.3/Flow_Working";
+-$save_directory = "/var/www/html/FlowViewer_Saves";
+-$save_short = "/FlowViewer_Saves";
+-$names_directory = "/var/www/cgi-bin/FlowViewer_4.3";
+-$filter_directory = "/var/www/cgi-bin/FlowTracker_Files/FlowTracker_Filters";
+-$rrdtool_directory = "/var/www/cgi-bin/FlowTracker_Files/FlowTracker_RRDtool";
+-$dashboard_directory = "/var/www/html/FlowViewer_Dashboard";
+$reports_directory = "%%FLOWVIEWERDIR%%/reports";
+$reports_short = "/FlowViewer/reports";
+$graphs_directory = "%%FLOWVIEWERDIR%%/graphs";
+$graphs_short = "/FlowViewer/graphs";
+$tracker_directory = "%%FLOWVIEWERDIR%%/tracker";
+$tracker_short = "/FlowViewer/tracker";
- $old_tracker_directory = "/var/www/html/FlowTracker_4.2";
--$cgi_bin_directory = "/var/www/cgi-bin/FlowViewer_4.2.1";
--$cgi_bin_short = "/cgi-bin/FlowViewer_4.2.1";
--$work_directory = "/var/www/cgi-bin/FlowViewer_4.2.1/Flow_Working";
--$save_directory = "/var/www/html/FlowViewer_Saves";
--$save_short = "/FlowViewer_Saves";
--$names_directory = "/var/www/cgi-bin/FlowViewer_4.2.1";
--$filter_directory = "/var/www/cgi-bin/FlowTracker_Files/FlowTracker_Filters";
--$rrdtool_directory = "/var/www/cgi-bin/FlowTracker_Files/FlowTracker_RRDtool";
--$dashboard_directory = "/var/www/html/FlowViewer_Dashboard";
+$cgi_bin_directory = "%%FLOWVIEWERDIR%%";
+$cgi_bin_short = "/FlowViewer";
+$work_directory = "%%FLOWVIEWERDIR%%/working";
+$save_directory = "%%FLOWVIEWERDIR%%/saves";
-+$save_short = "/FlowViewer/Saves";
++$save_short = "/FlowViewer/saves";
+$names_directory = "%%FLOWVIEWERDIR%%/names";
-+$filter_directory = "%%FLOWVIEWERDIR%%/filters";
++$filter_directory = "%%FLOWVIEWERDIR%%/filters";
+$rrdtool_directory = "%%FLOWVIEWERDIR%%/rrdtools";
+$dashboard_directory = "%%FLOWVIEWERDIR%%/FlowViewer_Dashboard";
$dashboard_short = "/FlowViewer_Dashboard";
@@ -41,8 +45,8 @@
-$exporter_directory = "/data/flows/all_routers";
-$flow_bin_directory = "/usr/local/flow-tools/bin";
-$rrdtool_bin_directory = "/usr/bin";
-+$flow_data_directory = "%%PREFIX%%/var/netflow/";
-+$exporter_directory = "%%PREFIX%%/var/netflow/all_routers";
++$flow_data_directory = "/var/db/flows";
++$exporter_directory = "/var/db/flows/all_routers";
+$flow_bin_directory = "%%PREFIX%%/bin";
+$rrdtool_bin_directory = "%%PREFIX%%/bin";
@@ -52,7 +56,7 @@
# Tracking parameters
$actives_webpage = "index.html";
--$log_directory = "/var/www/cgi-bin/FlowViewer_4.2.1/logs";
+-$log_directory = "/var/www/cgi-bin/FlowViewer_4.3/logs";
+$log_directory = "%%FLOWVIEWERDIR%%/logs";
$log_collector_short= "Y";
$log_collector_med = "N";
diff --git a/net-mgmt/flowviewer/files/pkg-message.in b/net-mgmt/flowviewer/files/pkg-message.in
index 62a0df06f944..4cc89e5ff2bd 100644
--- a/net-mgmt/flowviewer/files/pkg-message.in
+++ b/net-mgmt/flowviewer/files/pkg-message.in
@@ -19,4 +19,6 @@ that you add something like the following to httpd.conf:
Deny from all
</Directory>
+Then point your browser to 'http://myserver.domain.org/FlowViewer/FV.cgi'
+
You can find additional information in the %%DOCSDIR%%/README file
diff --git a/net-mgmt/flowviewer/pkg-plist b/net-mgmt/flowviewer/pkg-plist
index 667580c232b0..53df695e4caa 100644
--- a/net-mgmt/flowviewer/pkg-plist
+++ b/net-mgmt/flowviewer/pkg-plist
@@ -1,12 +1,8 @@
-%%FLOWVIEWERDIR%%/FG_button.png
-%%FLOWVIEWERDIR%%/FT_button.png
%%FLOWVIEWERDIR%%/FV.cgi
%%FLOWVIEWERDIR%%/FV_Relay.cgi
-%%FLOWVIEWERDIR%%/FV_button.png
%%FLOWVIEWERDIR%%/FlowGrapher.cgi
%%FLOWVIEWERDIR%%/FlowGrapher_Colors
%%FLOWVIEWERDIR%%/FlowGrapher_Main.cgi
-%%FLOWVIEWERDIR%%/FlowGrapher_Relay.cgi
%%FLOWVIEWERDIR%%/FlowGrapher_Replay.cgi
%%FLOWVIEWERDIR%%/FlowGrapher_Sort.cgi
%%FLOWVIEWERDIR%%/FlowTracker.cgi
@@ -21,18 +17,15 @@
%%FLOWVIEWERDIR%%/FlowTracker_Main.cgi
%%FLOWVIEWERDIR%%/FlowTracker_Management.cgi
%%FLOWVIEWERDIR%%/FlowTracker_Recreate
-%%FLOWVIEWERDIR%%/FlowTracker_Relay.cgi
%%FLOWVIEWERDIR%%/FlowTracker_Replay.cgi
%%FLOWVIEWERDIR%%/FlowTracker_Thumbnail
%%FLOWVIEWERDIR%%/FlowViewer.cgi
-%%FLOWVIEWERDIR%%/FlowViewer.css
%%FLOWVIEWERDIR%%/FlowViewer_CleanASCache
%%FLOWVIEWERDIR%%/FlowViewer_CleanFiles
%%FLOWVIEWERDIR%%/FlowViewer_CleanHostCache
%%FLOWVIEWERDIR%%/FlowViewer_CleanSiLK
%%FLOWVIEWERDIR%%/FlowViewer_Configuration.pm.dist
%%FLOWVIEWERDIR%%/FlowViewer_Main.cgi
-%%FLOWVIEWERDIR%%/FlowViewer_Relay.cgi
%%FLOWVIEWERDIR%%/FlowViewer_Replay.cgi
%%FLOWVIEWERDIR%%/FlowViewer_Save.cgi
%%FLOWVIEWERDIR%%/FlowViewer_SaveManage.cgi
@@ -41,14 +34,13 @@
%%FLOWVIEWERDIR%%/FlowViewer_Utilities.pm
%%FLOWVIEWERDIR%%/NamedInterfaces_Devices
%%FLOWVIEWERDIR%%/NamedInterfaces_Exporters
+%%FLOWVIEWERDIR%%/dscan.suppress.dst
+%%FLOWVIEWERDIR%%/dscan.suppress.src
%%FLOWVIEWERDIR%%/tools/analyze_flowtracker_debug
%%FLOWVIEWERDIR%%/tools/analyze_netflow_packets
%%FLOWVIEWERDIR%%/tools/convert_pre40_filters
-%%FLOWVIEWERDIR%%/tools/copy_netflow_jpl
%%FLOWVIEWERDIR%%/tools/date_to_epoch_gm
%%FLOWVIEWERDIR%%/tools/date_to_epoch_local
-%%FLOWVIEWERDIR%%/tools/edc_rwflowappend
-%%FLOWVIEWERDIR%%/tools/edc_rwreceiver
%%FLOWVIEWERDIR%%/tools/epoch_to_date_gm
%%FLOWVIEWERDIR%%/tools/epoch_to_date_local
%%FLOWVIEWERDIR%%/tools/flow-capture-table.conf
@@ -63,9 +55,14 @@
%%FLOWVIEWERDIR%%/tools/rsync_htmls
%%FLOWVIEWERDIR%%/tools/rsync_trackings
%%FLOWVIEWERDIR%%/tools/rwflowpack_start
+%%FLOWVIEWERDIR%%/reports/FG_button.png
+%%FLOWVIEWERDIR%%/reports/FT_button.png
+%%FLOWVIEWERDIR%%/reports/FV_button.png
+%%FLOWVIEWERDIR%%/reports/FlowViewer.css
+@exec /usr/sbin/chown %%WWWOWN%%:%%WWWGRP%% %%FLOWVIEWERDIR%%/tmp %%FLOWVIEWERDIR%%/reports %%FLOWVIEWERDIR%%/graphs %%FLOWVIEWERDIR%%/tracker %%FLOWVIEWERDIR%%/working %%FLOWVIEWERDIR%%/saves %%FLOWVIEWERDIR%%/names %%FLOWVIEWERDIR%%/filters %%FLOWVIEWERDIR%%/rrdtools %%FLOWVIEWERDIR%%/FlowViewer_Dashboard %%FLOWVIEWERDIR%%/tools
@dirrmtry %%FLOWVIEWERDIR%%/working
@dirrmtry %%FLOWVIEWERDIR%%/tracker
-@dirrm %%FLOWVIEWERDIR%%/tools
+@dirrmtry %%FLOWVIEWERDIR%%/tools
@dirrmtry %%FLOWVIEWERDIR%%/tmp
@dirrmtry %%FLOWVIEWERDIR%%/saves
@dirrmtry %%FLOWVIEWERDIR%%/rrdtools