aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-12 11:14:09 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-12 11:14:09 +0000
commitede8a52a170fd619d163af8a2e0f87d47c67430c (patch)
tree4d3d8c4cd65124d0cc470468b1470728fee00e3b /net-mgmt
parent7df29f1c91dc82ff3cb9974619c64e1338ca931b (diff)
downloadports-ede8a52a170fd619d163af8a2e0f87d47c67430c.tar.gz
ports-ede8a52a170fd619d163af8a2e0f87d47c67430c.zip
net-mgmt/irrtoolset: Unbreak in 12.2-STABLE
And possibly in other places. Remove files/ missed in previous update and fix LICENSE permissions. PR: 254213 Submitted by: rkoberman@gmail.com (maintainer) Reported by: terry-freebsd@glaver.org
Notes
Notes: svn path=/head/; revision=568167
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/irrtoolset/Makefile2
-rw-r--r--net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.l11
-rw-r--r--net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.y31
3 files changed, 2 insertions, 42 deletions
diff --git a/net-mgmt/irrtoolset/Makefile b/net-mgmt/irrtoolset/Makefile
index ad5350ac5196..1508dc89ae85 100644
--- a/net-mgmt/irrtoolset/Makefile
+++ b/net-mgmt/irrtoolset/Makefile
@@ -10,7 +10,9 @@ COMMENT= Suite of routing policy tools to interact with the IRR
LICENSE= MIT GPLv2+ RIPE_NCC
LICENSE_COMB= multi
+LICENSE_NAME_RIPE_NCC= RIPE NCC license
LICENSE_FILE= ${WRKSRC}/COPYING
+LICENSE_PERMS_RIPE_NCC= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
USES= autoreconf bison gmake libtool
GNU_CONFIGURE= yes
diff --git a/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.l b/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.l
deleted file mode 100644
index e3409a5e00c2..000000000000
--- a/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.l
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/rpsl/rpsl.l.orig 2012-07-31 12:10:39 UTC
-+++ src/rpsl/rpsl.l
-@@ -713,7 +713,7 @@ void handle_object_error(const char *s,
- current_object->errors += buffer;
- }
-
--void rpslerror(const char *, ...) {
-+void rpslerror(void *, const char *, ...) {
- if (current_attribute) {
- current_attribute->errorLine = errorLine;
- current_attribute->errorColon = errorColon - yyleng;
diff --git a/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.y b/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.y
deleted file mode 100644
index 7fece1407165..000000000000
--- a/net-mgmt/irrtoolset/files/patch-src-rpsl-rpsl.y
+++ /dev/null
@@ -1,31 +0,0 @@
---- src/rpsl/rpsl.y.orig 2012-07-31 12:10:39 UTC
-+++ src/rpsl/rpsl.y
-@@ -75,7 +75,7 @@ extern void handle_object_error(const ch
- extern void handle_warning(const char *, ...);
- extern int yylex();
- char *token_name(int token_id);
--void rpslerror(const char *s, ...);
-+void rpslerror(void *, const char *s, ...);
- Attr *changeCurrentAttr(Attr *b);
- void handleArgumentTypeError(char *attr, const char *method, int position,
- const RPType *correctType,
-@@ -83,7 +83,6 @@ void handleArgumentTypeError(char *attr,
- const AttrMethod *searchMethod(const AttrRPAttr *rp_attr, const char *method, ItemList *args);
-
- /* argument to yyparse result of parsing should be stored here */
--#define YYPARSE_PARAM object
- #define yyschema schema
- #define enable_yy_parser_debugging enable_rpsl_parser_debugging
-
-@@ -91,8 +90,9 @@ extern Object *current_object;
-
- %}
-
--%name-prefix="rpsl"
--%output="rpsl.y.cc"
-+%name-prefix "rpsl"
-+%output "rpsl.y.cc"
-+%parse-param {void *object}
-
- %expect 1
-