aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2021-06-30 02:45:57 +0000
committerFukang Chen <loader@FreeBSD.org>2021-06-30 05:09:36 +0000
commitf76aa00290b61be36138c3c177250b5ac10f2607 (patch)
tree8abc9e91e5b1f9e6c2c77529f64cc58d857de13c /net-mgmt
parentd3a50ae15530e720a7fb660123d0e6608531f9ee (diff)
downloadports-f76aa00290b61be36138c3c177250b5ac10f2607.tar.gz
ports-f76aa00290b61be36138c3c177250b5ac10f2607.zip
Mk/bsd.options.desc.mk: Add shared version control OPTIONS & descriptions
- Add CVS description - Add DARCS description - Add GIT description - Add MERCURIAL description - Add PERFORCE description - Rename SVN to SUBVERSION devel/anjuta: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE and OPTIONS_DEFAULT - Change SUBVERSION_DESC to use the default description devel/git: - Rename OPTION P4 to PERFORCE - Rename OPTION SVN to SUBVERSION - Change PERFORCE_DESC to use the default description devel/ocaml-opam: - Rename OPTION HG to MERCURIAL - Sort OPTIONS_DEFINE and OPTIONS_DEFAULT - Change {DARCS,GIT,MERCURIAL}_DESC to use the default description devel/thunar-vcs-plugin: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE - Change GIT_DESC to use the default description devel/viewvc-devel: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE, OPTIONS_DEFAULT and OPTIONS_SINGLE net-mgmt/observium: - Rename OPTION SVN to SUBVERSION net-mgmt/rancid3: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_SINGLE_SCM - Change {CVS,GIT,SUBVERSION}_DESC to use the default description ports-mgmt/portshaker: - Rename OPTION SVN to SUBVERSION - Rename HG to MERCURIAL - Sort OPTIONS_DEFINE - Change {GIT,MERCURIAL}_DESC to use the default description security/hydra: - Rename OPTION SVN to SUBVERSION security/medusa: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE shells/scponly: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE - Typo fix in SVNSERVE_DESC www/trac-devel: - Rename OPTION SVN to SUBVERSION - Sort OPTIONS_DEFINE, OPTIONS_DEFAULT and OPTIONS_MULTI_DATABASE - Change {GIT,SUBVERSION}_DESC to use the default description Reviewed by: koobs, adamw, dvl, garga, hannes_mehnert.org, rm, dbaio, romain Approved by: koobs (ports, mentor) Differential Revision: https://reviews.freebsd.org/D17459 MFH: No (OPTION description updates)
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/observium/Makefile8
-rw-r--r--net-mgmt/rancid3/Makefile11
2 files changed, 8 insertions, 11 deletions
diff --git a/net-mgmt/observium/Makefile b/net-mgmt/observium/Makefile
index bcb7403ca8cc..56e9160ea3bc 100644
--- a/net-mgmt/observium/Makefile
+++ b/net-mgmt/observium/Makefile
@@ -3,7 +3,7 @@
PORTNAME= observium
PORTVERSION= 0.19.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt
MASTER_SITES= http://www.observium.org/
DISTNAME= ${PORTNAME}-community-latest
@@ -40,8 +40,8 @@ RUN_DEPENDS+= rrdtool:databases/rrdtool \
sudo:security/sudo
LIB_DEPENDS+= libpng.so:graphics/png
-OPTIONS_DEFINE= APACHEMOD DOCS EXAMPLES FPING IPMITOOL LIBVIRT MYSQLD NAGPLUGINS NMAP PYPOLLER SVN WMIC
-OPTIONS_DEFAULT= APACHEMOD FPING IPMITOOL LIBVIRT NAGPLUGINS NMAP PYPOLLER SVN WMIC
+OPTIONS_DEFINE= APACHEMOD DOCS EXAMPLES FPING IPMITOOL LIBVIRT MYSQLD NAGPLUGINS NMAP PYPOLLER SUBVERSION WMIC
+OPTIONS_DEFAULT= APACHEMOD FPING IPMITOOL LIBVIRT NAGPLUGINS NMAP PYPOLLER SUBVERSION WMIC
APACHEMOD_DESC= Use PHP with Apache 2.2+ module
FPING_DESC= Enable fping support ping monitoring
IPMITOOL_DESC= Enable support for monitoring hardware IPMI
@@ -55,7 +55,7 @@ LIBVIRT_RUN_DEPENDS= virsh:devel/libvirt
NAGPLUGINS_RUN_DEPENDS= ${LOCALBASE}/libexec/nagios/check_nagios:net-mgmt/nagios-plugins
NMAP_RUN_DEPENDS= nmap:security/nmap
PYPOLLER_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mysqlclient>=1.3.13:databases/py-mysqlclient@${PY_FLAVOR}
-SVN_RUN_DEPENDS= svn:devel/subversion
+SUBVERSION_RUN_DEPENDS= svn:devel/subversion
WMIC_RUN_DEPENDS= wmic:net-mgmt/wmi-client
.include <bsd.port.options.mk>
diff --git a/net-mgmt/rancid3/Makefile b/net-mgmt/rancid3/Makefile
index 322312e9e8e5..a16106005d51 100644
--- a/net-mgmt/rancid3/Makefile
+++ b/net-mgmt/rancid3/Makefile
@@ -2,7 +2,7 @@
PORTNAME= rancid
PORTVERSION= 3.13
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= net-mgmt
MASTER_SITES= ftp://ftp.shrubbery.net/pub/rancid/
PKGNAMESUFFIX= 3
@@ -37,21 +37,18 @@ NEWCONFIG_FILES= rancid.conf lg.conf
OPTIONS_SINGLE= SCM
-OPTIONS_SINGLE_SCM= CVS SVN GIT
+OPTIONS_SINGLE_SCM= CVS GIT SUBVERSION
OPTIONS_DEFINE= COMWARE
OPTIONS_DEFAULT= CVS
COMWARE_DESC= Add experimental support for Comware devices
-CVS_DESC= Use CVS as the means of version control
-SVN_DESC= Use Subversion as the means of version control
-GIT_DESC= Use Git as the means of version control
CVS_RUN_DEPENDS= cvs:devel/cvs
CVS_CONFIGURE_ON= --without-svn
-SVN_RUN_DEPENDS= svn:devel/subversion
-SVN_CONFIGURE_ON= --with-svn
+SUBVERSION_RUN_DEPENDS= svn:devel/subversion
+SUBVERSION_CONFIGURE_ON= --with-svn
GIT_RUN_DEPENDS= git:devel/git
GIT_CONFIGURE_ON= --with-git