aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-04-17 10:34:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-04-17 10:34:58 +0000
commitf9ba42ff0a81ae49ef98129cb0ed956db0946332 (patch)
tree1c7543ae61d3b55ec989309a1b21e2d33de5a8d7 /net-mgmt
parent1d29f2c4c109ce586c0ffc068ea8034f24663fcc (diff)
downloadports-f9ba42ff0a81ae49ef98129cb0ed956db0946332.tar.gz
ports-f9ba42ff0a81ae49ef98129cb0ed956db0946332.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/ccnet/Makefile21
-rw-r--r--net-mgmt/ccnet/distinfo4
-rw-r--r--net-mgmt/ccnet/files/patch-Makefile.am10
-rw-r--r--net-mgmt/ccnet/files/patch-configure.ac16
-rw-r--r--net-mgmt/ccnet/files/patch-lib_Makefile.am6
-rw-r--r--net-mgmt/ccnet/files/patch-lib_net.c6
-rw-r--r--net-mgmt/ccnet/files/patch-lib_utils.c19
-rw-r--r--net-mgmt/ccnet/files/patch-net_common_getgateway.c4
-rw-r--r--net-mgmt/ccnet/pkg-plist1
9 files changed, 45 insertions, 42 deletions
diff --git a/net-mgmt/ccnet/Makefile b/net-mgmt/ccnet/Makefile
index 3297feecd91c..eb046422d266 100644
--- a/net-mgmt/ccnet/Makefile
+++ b/net-mgmt/ccnet/Makefile
@@ -1,21 +1,20 @@
# $FreeBSD$
PORTNAME= ccnet
-PORTVERSION= 4.0.6
+PORTVERSION= 5.1.1
DISTVERSIONPREFIX= v
DISTVERSIONSUFFIX= -server
-PORTREVISION= 6
CATEGORIES= net-mgmt devel
MAINTAINER= ultima1252@gmail.com
COMMENT= Framework for writing networked applications
LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENCE.txt
BUILD_DEPENDS= valac:lang/vala
LIB_DEPENDS= libsearpc.so:devel/libsearpc \
libglib-2.0.so:devel/glib20 \
- libgobject-2.0.so:devel/glib20 \
libsqlite3.so:databases/sqlite3 \
libzdb.so:databases/libzdb \
libuuid.so:misc/e2fsprogs-libuuid \
@@ -26,25 +25,24 @@ LIB_DEPENDS= libsearpc.so:devel/libsearpc \
USE_GITHUB= yes
GH_ACCOUNT= haiwen
-USES= autoreconf libtool pkgconfig pathfix python:2
-PATHFIX_MAKEFILEIN= Makefile.am
+USES= autoreconf libtool localbase pathfix pkgconfig python:-2.7 \
+ shebangfix
USE_LDCONFIG= yes
+USE_OPENSSL= yes
+SHEBANG_FILES= tools/*.py
+PATHFIX_MAKEFILEIN= Makefile.am
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/event2
-LDFLAGS+= -L${LOCALBASE}/lib -L${LOCALBASE}/lib/event2
CONFIGURE_ENV= SSL_CFLAGS="${OPENSSLINC}" SSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--enable-server --enable-ldap
+CONFIGURE_ARGS+= --enable-server --enable-ldap
INSTALL_TARGET= install-strip
-USE_OPENSSL= yes
-
HAIWENDIR= www/haiwen
SEAFILE_SERVER= ${HAIWENDIR}/seafile-server
SEABIN= ${SEAFILE_SERVER}/seafile/bin
SEALIB= ${SEAFILE_SERVER}/seafile/lib
-SEAFILE_USERNAME?= www
+SEAFILE_USERNAME?= seafile
SEAFILE_GROUPNAME?= ${SEAFILE_USERNAME}
PLIST_SUB= SEAFILE_USERNAME=${SEAFILE_USERNAME} \
@@ -69,5 +67,6 @@ post-install:
(cd ${STAGEDIR}${PREFIX}/lib && \
${COPYTREE_SHARE} ${PYTHON_VERSION} ${STAGEDIR}${PREFIX}/${SEALIB})
@${RM} -rf ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION}
+ ${LN} -s ${PREFIX}/${SEABIN}/ccnet-server ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/net-mgmt/ccnet/distinfo b/net-mgmt/ccnet/distinfo
index 1c33db983154..a7d3f4001f76 100644
--- a/net-mgmt/ccnet/distinfo
+++ b/net-mgmt/ccnet/distinfo
@@ -1,2 +1,2 @@
-SHA256 (haiwen-ccnet-v4.0.6-server_GH0.tar.gz) = d9793715b3473a161f802224dbeac75744e70313f073f8e0b7191b9141c36812
-SIZE (haiwen-ccnet-v4.0.6-server_GH0.tar.gz) = 218550
+SHA256 (haiwen-ccnet-v5.1.1-server_GH0.tar.gz) = d237ae8b54b6ad561b88d517d03a77f5389f3269075c17d484f53b58af3a6705
+SIZE (haiwen-ccnet-v5.1.1-server_GH0.tar.gz) = 221857
diff --git a/net-mgmt/ccnet/files/patch-Makefile.am b/net-mgmt/ccnet/files/patch-Makefile.am
index a113bec4baab..60324461c81b 100644
--- a/net-mgmt/ccnet/files/patch-Makefile.am
+++ b/net-mgmt/ccnet/files/patch-Makefile.am
@@ -1,6 +1,6 @@
---- Makefile.am.orig 2015-01-27 22:28:22.000000000 -0500
-+++ Makefile.am 2015-01-27 22:33:35.000000000 -0500
-@@ -24,9 +24,13 @@
+--- Makefile.am.orig 2015-11-26 15:34:14 UTC
++++ Makefile.am
+@@ -24,9 +24,13 @@ ACLOCAL_AMFLAGS = -I m4
install-data-local:
if MACOS
sed -i '' -e "s|(DESTDIR)|${DESTDIR}|g" $(pcfiles)
@@ -13,6 +13,4 @@
+endif
dist-hook:
-- git log --format='%H' -1 > $(distdir)/latest_commit
-\ No newline at end of file
-+ git log --format='%H' -1 > $(distdir)/latest_commit
+ git log --format='%H' -1 > $(distdir)/latest_commit
diff --git a/net-mgmt/ccnet/files/patch-configure.ac b/net-mgmt/ccnet/files/patch-configure.ac
index 11e43e50cb6a..90cc9a5c384b 100644
--- a/net-mgmt/ccnet/files/patch-configure.ac
+++ b/net-mgmt/ccnet/files/patch-configure.ac
@@ -1,6 +1,6 @@
---- configure.ac.orig 2014-12-03 21:47:39.000000000 -0500
-+++ configure.ac 2015-01-27 23:56:25.000000000 -0500
-@@ -51,8 +51,16 @@
+--- configure.ac.orig 2015-11-11 09:50:52 UTC
++++ configure.ac
+@@ -51,8 +51,16 @@ else
AC_MSG_RESULT(no)
fi
@@ -18,7 +18,7 @@
blinux=true
AC_MSG_RESULT(compile in linux)
else
-@@ -154,6 +162,7 @@
+@@ -154,6 +162,7 @@ AM_CONDITIONAL([COMPILE_DEMO], [test "${
AM_CONDITIONAL([WIN32], [test "$bwin32" = "true"])
AM_CONDITIONAL([MACOS], [test "$bmac" = "true"])
AM_CONDITIONAL([LINUX], [test "$blinux" = "true"])
@@ -26,7 +26,7 @@
# check libraries
-@@ -192,6 +201,7 @@
+@@ -213,6 +222,7 @@ if test "$bwin32" = true; then
LIBS=
LIB_RESOLV=
LIB_UUID=-lrpcrt4
@@ -34,7 +34,7 @@
LIB_IPHLPAPI=-liphlpapi
LIB_SHELL32=-lshell32
LIB_PSAPI=-lpsapi
-@@ -204,11 +214,25 @@
+@@ -225,11 +235,25 @@ elif test "$bmac" = true ; then
LIB_INTL=
LIB_RESOLV=-lresolv
LIB_UUID=
@@ -60,7 +60,7 @@
else
LIB_WS32=
LIB_GDI32=
-@@ -216,6 +240,7 @@
+@@ -237,6 +261,7 @@ else
LIB_INTL=
LIB_RESOLV=-lresolv
LIB_UUID=-luuid
@@ -68,7 +68,7 @@
LIB_IPHLPAPI=
LIB_SHELL32=
LIB_PSAPI=
-@@ -229,6 +254,7 @@
+@@ -250,6 +275,7 @@ AC_SUBST(LIB_RT)
AC_SUBST(LIB_INTL)
AC_SUBST(LIB_RESOLV)
AC_SUBST(LIB_UUID)
diff --git a/net-mgmt/ccnet/files/patch-lib_Makefile.am b/net-mgmt/ccnet/files/patch-lib_Makefile.am
index da47ac89654f..9a55f8271d21 100644
--- a/net-mgmt/ccnet/files/patch-lib_Makefile.am
+++ b/net-mgmt/ccnet/files/patch-lib_Makefile.am
@@ -1,6 +1,6 @@
---- lib/Makefile.am.orig 2015-01-27 22:48:22.000000000 -0500
-+++ lib/Makefile.am 2015-01-27 22:49:06.000000000 -0500
-@@ -61,6 +61,7 @@
+--- lib/Makefile.am.orig 2015-11-26 15:34:14 UTC
++++ lib/Makefile.am
+@@ -61,6 +61,7 @@ libccnetd_la_SOURCES = utils.c db.c job-
libccnetd_la_LDFLAGS = -no-undefined
libccnetd_la_LIBADD = @GLIB2_LIBS@ @GOBJECT_LIBS@ @SSL_LIBS@ @LIB_GDI32@ \
-lsqlite3 @LIBEVENT_LIBS@ @LIB_WS32@ @LIB_UUID@ \
diff --git a/net-mgmt/ccnet/files/patch-lib_net.c b/net-mgmt/ccnet/files/patch-lib_net.c
index f6c693c144a6..d3e73a732d53 100644
--- a/net-mgmt/ccnet/files/patch-lib_net.c
+++ b/net-mgmt/ccnet/files/patch-lib_net.c
@@ -1,6 +1,6 @@
---- lib/net.c.orig 2015-01-27 23:18:59.000000000 -0500
-+++ lib/net.c 2015-01-27 23:23:04.000000000 -0500
-@@ -152,7 +152,11 @@
+--- lib/net.c.orig 2015-11-11 09:50:52 UTC
++++ lib/net.c
+@@ -152,7 +152,11 @@ ccnet_net_bind_tcp (int port, int nonblo
snprintf (buf, sizeof(buf), "%d", port);
diff --git a/net-mgmt/ccnet/files/patch-lib_utils.c b/net-mgmt/ccnet/files/patch-lib_utils.c
index ca4b00bf071e..2a40a2a94ebf 100644
--- a/net-mgmt/ccnet/files/patch-lib_utils.c
+++ b/net-mgmt/ccnet/files/patch-lib_utils.c
@@ -1,5 +1,5 @@
---- lib/utils.c.orig 2015-01-27 23:13:50.000000000 -0500
-+++ lib/utils.c 2015-01-27 23:18:04.000000000 -0500
+--- lib/utils.c.orig 2016-01-08 11:43:49 UTC
++++ lib/utils.c
@@ -43,6 +43,16 @@
#include <event2/util.h>
@@ -17,7 +17,7 @@
extern int inet_pton(int af, const char *src, void *dst);
-@@ -1465,14 +1475,20 @@
+@@ -1469,14 +1479,20 @@ get_argv_utf8 (int *argc)
}
#endif /* ifdef WIN32 */
@@ -40,7 +40,7 @@
return -1;
}
-@@ -1496,7 +1512,8 @@
+@@ -1500,7 +1516,8 @@ find_process_in_dirent(struct dirent *di
}
/* read the /proc fs to determine whether some process is running */
@@ -50,7 +50,7 @@
{
DIR *proc_dir = opendir("/proc");
if (!proc_dir) {
-@@ -1510,7 +1527,7 @@
+@@ -1514,7 +1531,7 @@ gboolean process_is_running (const char
/* /proc/[1-9][0-9]* */
if (first > '9' || first < '1')
continue;
@@ -59,7 +59,7 @@
if (pid > 0) {
closedir(proc_dir);
return TRUE;
-@@ -1520,6 +1537,18 @@
+@@ -1524,6 +1541,18 @@ gboolean process_is_running (const char
closedir(proc_dir);
return FALSE;
}
@@ -78,14 +78,19 @@
#endif
#ifdef __APPLE__
-@@ -1530,6 +1559,108 @@
+@@ -1534,6 +1563,113 @@ gboolean process_is_running (const char
}
#endif
+#if defined(__FreeBSD__) || defined(__DragonFly__) || defined(__NetBSD__) || defined(__OpenBSD__)
+#if defined(__FreeBSD__)
++#if __FreeBSD_version < 1100097
+#define PSKIP(kp) ((kp)->ki_pid == mypid || \
+ (!kthreads && ((kp)->ki_flag & P_KTHREAD) != 0))
++#else
++#define PSKIP(kp) ((kp)->ki_pid == mypid || \
++ (!kthreads && ((kp)->ki_flag & P_KPROC) != 0))
++#endif
+#define KVM_OPENFILES(exec, coref, buf) \
+ kvm_openfiles(exec, coref, NULL, O_RDONLY, buf)
+#define KVM_GETPROCS(kd, plist, nproc) \
diff --git a/net-mgmt/ccnet/files/patch-net_common_getgateway.c b/net-mgmt/ccnet/files/patch-net_common_getgateway.c
index a00c0c4acfcd..bffdf7d7b684 100644
--- a/net-mgmt/ccnet/files/patch-net_common_getgateway.c
+++ b/net-mgmt/ccnet/files/patch-net_common_getgateway.c
@@ -1,5 +1,5 @@
---- net/common/getgateway.c.orig 2015-01-27 23:26:41.000000000 -0500
-+++ net/common/getgateway.c 2015-01-27 23:27:58.000000000 -0500
+--- net/common/getgateway.c.orig 2015-11-11 09:50:52 UTC
++++ net/common/getgateway.c
@@ -34,7 +34,7 @@
#undef USE_SYSCTL_NET_ROUTE
#endif
diff --git a/net-mgmt/ccnet/pkg-plist b/net-mgmt/ccnet/pkg-plist
index 6201852cdc0f..0c31839c407b 100644
--- a/net-mgmt/ccnet/pkg-plist
+++ b/net-mgmt/ccnet/pkg-plist
@@ -2,6 +2,7 @@ bin/ccnet
bin/ccnet-demo-client
bin/ccnet-demo-server
bin/ccnet-tool
+bin/ccnet-server
include/ccnet.h
include/ccnet/async-rpc-proc.h
include/ccnet/ccnet-client.h