aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2011-12-18 17:44:38 +0000
committerChris Rees <crees@FreeBSD.org>2011-12-18 17:44:38 +0000
commitfce0cd9cfc45398809ceb0d5113369bdaa1192cd (patch)
tree9b8d9d454cb8bff027e8100541cd8a3a31f9bc88 /net-mgmt
parentc3765886cf28a333a11d2eead76788b88663fb89 (diff)
downloadports-fce0cd9cfc45398809ceb0d5113369bdaa1192cd.tar.gz
ports-fce0cd9cfc45398809ceb0d5113369bdaa1192cd.zip
Notes
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/zenpack-ntpmonitor/Makefile26
-rw-r--r--net-mgmt/zenpack-ntpmonitor/distinfo2
-rw-r--r--net-mgmt/zenpack-ntpmonitor/files/pkg-deinstall.in10
-rw-r--r--net-mgmt/zenpack-ntpmonitor/files/pkg-message.in5
-rw-r--r--net-mgmt/zenpack-ntpmonitor/pkg-descr6
6 files changed, 50 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index b22edcd159b6..914e2d8c20ff 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -307,5 +307,6 @@
SUBDIR += zenpack-interfacegraphs
SUBDIR += zenpack-libvirt
SUBDIR += zenpack-macreport
+ SUBDIR += zenpack-ntpmonitor
.include <bsd.port.subdir.mk>
diff --git a/net-mgmt/zenpack-ntpmonitor/Makefile b/net-mgmt/zenpack-ntpmonitor/Makefile
new file mode 100644
index 000000000000..91cde5157c09
--- /dev/null
+++ b/net-mgmt/zenpack-ntpmonitor/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: NtpMonitor
+# Date created: 13 May 2011
+# Whom: Zenoss <zenoss@experts-exchange.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= NtpMonitor
+PORTVERSION= 2.0.3
+CATEGORIES= net-mgmt
+MASTER_SITES= http://dev.zenoss.org/trac/changeset/26205/tags/zenoss-3.1.0/zenpacks/
+DISTFILES= ${ZPACKPREFIX}${PORTNAME}?old_path=%2F\&format=zip
+
+MAINTAINER= zenoss@experts-exchange.com
+COMMENT= Monitors the offset between system time and a target NTP servers time
+
+PLIST_FILES= zenoss/ZenPack/${ZPACK}
+PLIST_DIRS= zenoss/ZenPack
+
+USE_ZIP= yes
+ZPACKGROUP= core
+WRKSRC= ${WRKDIR}/tags/zenoss-3.1.0/zenpacks/${ZPACKPREFIX}${PORTNAME}/
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.zenoss.mk"
+.include <bsd.port.post.mk>
diff --git a/net-mgmt/zenpack-ntpmonitor/distinfo b/net-mgmt/zenpack-ntpmonitor/distinfo
new file mode 100644
index 000000000000..2ea48116a28a
--- /dev/null
+++ b/net-mgmt/zenpack-ntpmonitor/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ZenPacks.zenoss.NtpMonitor?old_path=%2F&format=zip) = 4e761243ac6b1b6652465532a36bd4c193a9b9256cf9c7056804cf09675a88ea
+SIZE (ZenPacks.zenoss.NtpMonitor?old_path=%2F&format=zip) = 10697
diff --git a/net-mgmt/zenpack-ntpmonitor/files/pkg-deinstall.in b/net-mgmt/zenpack-ntpmonitor/files/pkg-deinstall.in
new file mode 100644
index 000000000000..a1f84ae8e2cf
--- /dev/null
+++ b/net-mgmt/zenpack-ntpmonitor/files/pkg-deinstall.in
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+if [ "$2" = "DEINSTALL" ]; then
+ echo "To de-activate this Zenpack, run the following command as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --remove %%ZPACKPREFIX%%%%PORTNAME%%
+
+IMPORTANT: De-activating a Zenpack will also remove all its associated data"
+
+fi
diff --git a/net-mgmt/zenpack-ntpmonitor/files/pkg-message.in b/net-mgmt/zenpack-ntpmonitor/files/pkg-message.in
new file mode 100644
index 000000000000..869bea811264
--- /dev/null
+++ b/net-mgmt/zenpack-ntpmonitor/files/pkg-message.in
@@ -0,0 +1,5 @@
+
+To activate this Zenpack, run the following commands as the zenoss user:
+
+%%ZENHOME%%/bin/zenpack --install %%ZPACKHOME%%/%%ZPACK%%
+%%ZENHOME%%/bin/zopectl restart
diff --git a/net-mgmt/zenpack-ntpmonitor/pkg-descr b/net-mgmt/zenpack-ntpmonitor/pkg-descr
new file mode 100644
index 000000000000..2239dbe65377
--- /dev/null
+++ b/net-mgmt/zenpack-ntpmonitor/pkg-descr
@@ -0,0 +1,6 @@
+NTPMonitor monitors the offset between system time and a target NTP (Network
+Time Server) server's time.
+
+More details can be found at provided url.
+
+WWW: http://community.zenoss.org/docs/DOC-3469