aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/amule-devel/Makefile
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /net-p2p/amule-devel/Makefile
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
downloadports-0f583d87000061087521fb77c44c9055d122d787.tar.gz
ports-0f583d87000061087521fb77c44c9055d122d787.zip
Notes
Diffstat (limited to 'net-p2p/amule-devel/Makefile')
-rw-r--r--net-p2p/amule-devel/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index 122eb9c14e10..2ba28926440b 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -90,10 +90,11 @@ MMAP_CONFIGURE_ON= --enable-mmap
MONOLITHIC_CONFIGURE_OFF= --disable-monolithic
PLASMAMULE_CONFIGURE_ON= --enable-plasmamule
-PLASMAMULE_USE= KDE4=kdelibs QT4=dbus,gui,moc_build
+PLASMAMULE_USES= kde:4
+PLASMAMULE_USE= KDE=kdelibs QT4=dbus,gui,moc_build
PLASMAMULE_CONFIGURE_ENV= \
- ac_cv_path_KDE4_CONFIG=${KDE4_PREFIX}/bin/kde4-config \
- KBUILDSYCOCA=${KDE4_PREFIX}/bin/kbuildsycoca4 \
+ ac_cv_path_KDE4_CONFIG=${KDE_PREFIX}/bin/kde4-config \
+ KBUILDSYCOCA=${KDE_PREFIX}/bin/kbuildsycoca4 \
UPDATE_MIME_DATABASE=/usr/bin/true
UPNP_LIB_DEPENDS= libupnp.so:devel/upnp
@@ -129,8 +130,8 @@ post-patch: .SILENT
${WRKSRC}/docs/Makefile.in
.endif
.if ${PORT_OPTIONS:MPLASMAMULE}
- ${REINPLACE_CMD} -e 's|@prefix@|${KDE4_PREFIX}|' \
- -e 's|LDFLAGS =|& -L${KDE4_PREFIX}/lib |' \
+ ${REINPLACE_CMD} -e 's|@prefix@|${KDE_PREFIX}|' \
+ -e 's|LDFLAGS =|& -L${KDE_PREFIX}/lib |' \
${WRKSRC}/src/utils/plasmamule/Makefile.in
.endif