aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/amule-devel
diff options
context:
space:
mode:
authorBarbara Guida <bar@FreeBSD.org>2017-11-22 00:07:30 +0000
committerBarbara Guida <bar@FreeBSD.org>2017-11-22 00:07:30 +0000
commit7a4c9778f17441d0e7ba633a93609b996aa74d6d (patch)
tree972aacf88619ce4ca58baaf4e194b79e67c15457 /net-p2p/amule-devel
parent18af141cc0293b65eb729e742de1c63d7ffeb2c1 (diff)
downloadports-7a4c9778f17441d0e7ba633a93609b996aa74d6d.tar.gz
ports-7a4c9778f17441d0e7ba633a93609b996aa74d6d.zip
Add two patches to fix switching tab on search.
Notes
Notes: svn path=/head/; revision=454659
Diffstat (limited to 'net-p2p/amule-devel')
-rw-r--r--net-p2p/amule-devel/Makefile2
-rw-r--r--net-p2p/amule-devel/files/patch-src_MuleNotebook.cpp43
-rw-r--r--net-p2p/amule-devel/files/patch-src_MuleNotebook.h14
3 files changed, 58 insertions, 1 deletions
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index de06bdee669b..018681076ad9 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= amule
PORTVERSION= 10990
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net-p2p
MASTER_SITES= http://amule.sourceforge.net/tarballs/
PKGNAMESUFFIX= -devel
diff --git a/net-p2p/amule-devel/files/patch-src_MuleNotebook.cpp b/net-p2p/amule-devel/files/patch-src_MuleNotebook.cpp
new file mode 100644
index 000000000000..881d129b5d98
--- /dev/null
+++ b/net-p2p/amule-devel/files/patch-src_MuleNotebook.cpp
@@ -0,0 +1,43 @@
+--- src/MuleNotebook.cpp.orig 2017-06-03 23:55:41.000000000 +0200
++++ src/MuleNotebook.cpp 2017-11-20 14:51:19.834947000 +0100
+@@ -45,10 +45,10 @@
+ EVT_MENU(MP_CLOSE_OTHER_TABS, CMuleNotebook::OnPopupCloseOthers)
+
+ // Madcat - tab closing engine
+- EVT_LEFT_DOWN(CMuleNotebook::OnMouseButtonRelease)
+- EVT_LEFT_UP(CMuleNotebook::OnMouseButtonRelease)
+- EVT_MIDDLE_DOWN(CMuleNotebook::OnMouseButtonRelease)
+- EVT_MIDDLE_UP(CMuleNotebook::OnMouseButtonRelease)
++ EVT_LEFT_DOWN(CMuleNotebook::OnMouseButton)
++ EVT_LEFT_UP(CMuleNotebook::OnMouseButton)
++ EVT_MIDDLE_DOWN(CMuleNotebook::OnMouseButton)
++ EVT_MIDDLE_UP(CMuleNotebook::OnMouseButton)
+ EVT_MOTION(CMuleNotebook::OnMouseMotion)
+ #if MULE_NEEDS_DELETEPAGE_WORKAROUND
+ EVT_MULENOTEBOOK_DELETE_PAGE(wxID_ANY, CMuleNotebook::OnDeletePage)
+@@ -217,7 +217,7 @@
+ }
+
+
+-void CMuleNotebook::OnMouseButtonRelease(wxMouseEvent &event)
++void CMuleNotebook::OnMouseButton(wxMouseEvent &event)
+ {
+ if (GetImageList() == NULL) {
+ // This Mulenotebook has no images on tabs, so nothing to do.
+@@ -235,16 +235,13 @@
+
+ if (event.LeftDown() && (flags == wxNB_HITTEST_ONICON)) {
+ tab_down_icon = tab;
+- return;
+ }
+ else if (event.MiddleDown() && (flags == wxNB_HITTEST_ONLABEL)) {
+ tab_down_label = tab;
+- return;
+ }
+ else if (event.LeftDown() || event.MiddleDown()) {
+ tab_down_icon = -1;
+ tab_down_label = -1;
+- return;
+ }
+
+ if (((tab != -1) && (((flags == wxNB_HITTEST_ONICON) && event.LeftUp() && (tab == tab_down_icon)) ||
diff --git a/net-p2p/amule-devel/files/patch-src_MuleNotebook.h b/net-p2p/amule-devel/files/patch-src_MuleNotebook.h
new file mode 100644
index 000000000000..ef0987f27d0c
--- /dev/null
+++ b/net-p2p/amule-devel/files/patch-src_MuleNotebook.h
@@ -0,0 +1,14 @@
+--- src/MuleNotebook.h.orig 2017-06-03 23:55:41.000000000 +0200
++++ src/MuleNotebook.h 2017-11-20 14:52:35.287092000 +0100
+@@ -130,9 +130,9 @@
+
+ protected:
+ /**
+- * Event handler for left or middle mouse button release (for closing pages)
++ * Event handler for left or middle mouse button to press or release (for closing pages)
+ */
+- void OnMouseButtonRelease(wxMouseEvent &event);
++ void OnMouseButton(wxMouseEvent &event);
+
+ /**
+ * Event handler for mouse motion (for highlighting the 'x')