aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/amule-devel
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-08-24 17:22:01 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-08-24 17:22:01 +0000
commitedf512ca2e5e5a59e84993103663d499dc54600d (patch)
tree755180fd4810fbf33aa78186166afc94eafc7a8e /net-p2p/amule-devel
parentd0dff0b145c82c7f6acffe2125012004f4d4d6cb (diff)
downloadports-edf512ca2e5e5a59e84993103663d499dc54600d.tar.gz
ports-edf512ca2e5e5a59e84993103663d499dc54600d.zip
Update security/cryptopp to 7.0.0
We now install a pkgconfig file which will allow ports to check whether cryptopp was built with assembly instructions enabled or not. There are a few functions that will be undefined if built without assembly and -DCRYPTOPP_DISABLE_ASM needs to be passed to the compiler in that case to avoid build failures. This is not new, but the pkgconf file should make it easier to determine if the flag is needed or not. Fix several ports due to API changes and to use the new pkgconf file to determine cryptopp location and build flags. Special cases below. deskutils/cdcat - Use cryptopp shared library instead of static, detect with pkgconf devel/xeus - Fix dependencies and remove header-only libraries from RUN_DEPENDS - Rework to use the cryptopp pkgconf file - net/cppzmq CMake files were fixed in r477649, remove hacks for that as they were seemingly causing devel/xeus-cling to link to cryptopp unnecessarily - Remove C++17 code from cryptopp checks for compatibility devel/xeus-cling - Fix dependencies - Remove hacks for previously broken cppzmq CMake files and no longer needed cryptopp dependency Changes: https://www.cryptopp.com/#news PR: 230579 (original patch, not used) Submitted by: yuri
Notes
Notes: svn path=/head/; revision=477967
Diffstat (limited to 'net-p2p/amule-devel')
-rw-r--r--net-p2p/amule-devel/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net-p2p/amule-devel/Makefile b/net-p2p/amule-devel/Makefile
index fa01722a840e..ee1756b0fc22 100644
--- a/net-p2p/amule-devel/Makefile
+++ b/net-p2p/amule-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= amule
PORTVERSION= 10998
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= http://amule.sourceforge.net/tarballs/
PKGNAMESUFFIX= -devel
@@ -31,6 +32,7 @@ CONFIGURE_ENV= LEX="${FLEX}" PKG_CONFIG="${PKG_CONFIG}" \
docdir='$${prefix}/${DOCSDIR_REL}'
CPPFLAGS+= -I${LOCALBASE}/include
+CXXFLAGS+= `pkgconf --cflags-only-other libcryptopp`
LDFLAGS+= -lpthread -L${LOCALBASE}/lib
OPTIONS_DEFINE= ALC ALCC AMULECMD AMULEDAEMON AMULEGUI CAS DEBUG DOCS ED2K \
@@ -109,10 +111,6 @@ XAS_USE= PERL5+=run
.include <bsd.port.options.mk>
-.if ${ARCH} == "i386" && ( ${OSVERSION} >= 1000024 || ${CXX:T} == "clang++" )
-CPPFLAGS+= -DCRYPTOPP_DISABLE_ASM
-.endif
-
.if ${PORT_OPTIONS:MED2K}
CONFLICTS+= ed2k-hash*
.endif