aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/amule/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-04-17 14:21:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-04-17 14:21:58 +0000
commit8f7f9d56ebee8f2ba0350653cd3882f7ff4312f9 (patch)
tree8ffc710fba463fb7c7c66c2f2232a5e13fdd71d0 /net-p2p/amule/Makefile
parent4521b0a32213d299ead3203bb2fe3aedc2bfbdab (diff)
downloadports-8f7f9d56ebee8f2ba0350653cd3882f7ff4312f9.tar.gz
ports-8f7f9d56ebee8f2ba0350653cd3882f7ff4312f9.zip
Notes
Diffstat (limited to 'net-p2p/amule/Makefile')
-rw-r--r--net-p2p/amule/Makefile25
1 files changed, 11 insertions, 14 deletions
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index a6fec1275aa5..af2e50c167ce 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -11,8 +11,7 @@ DISTNAME= aMule-${PORTVERSION}
MAINTAINER= bar@FreeBSD.org
COMMENT= All-platform eMule p2p client
-LICENSE= GPLv2 GPLv3
-LICENSE_COMB= dual
+LICENSE= GPLv2+
LIB_DEPENDS= libcryptopp.so:security/cryptopp
@@ -107,7 +106,7 @@ XAS_USE= PERL5+=run
.include <bsd.port.options.mk>
-.if ${ARCH} == "i386" && ( ${OSVERSION} >= 1000024 || ${CXX:T} == "clang++" )
+.if ${ARCH} == "i386"
CPPFLAGS+= -DCRYPTOPP_DISABLE_ASM
.endif
@@ -115,23 +114,21 @@ CPPFLAGS+= -DCRYPTOPP_DISABLE_ASM
CONFLICTS+= ed2k-hash*
.endif
-post-patch: .SILENT
- ${REINPLACE_CMD} -e 's/test.*-print-file-name.*`/true/' \
+post-patch:
+ @${REINPLACE_CMD} -e 's/test.*-print-file-name.*`/true/' \
-e '/if.*test/s/==/=/' \
${WRKSRC}/configure
-.if ! ${PORT_OPTIONS:MDOCS}
- ${REINPLACE_CMD} 's/install-data-am:.*/install-data-am:/' \
+
+post-patch-DOCS-off:
+ @${REINPLACE_CMD} 's/install-data-am:.*/install-data-am:/' \
${WRKSRC}/docs/Makefile.in
-.endif
-.if ${PORT_OPTIONS:MPLASMAMULE}
- ${REINPLACE_CMD} -e 's|@prefix@|${KDE_PREFIX}|' \
+
+post-patch-PLASMAMULE-on:
+ @${REINPLACE_CMD} -e 's|@prefix@|${KDE_PREFIX}|' \
-e 's|LDFLAGS =|& -L${KDE_PREFIX}/lib |' \
${WRKSRC}/src/utils/plasmamule/Makefile.in
-.endif
-post-install:
-.if ${PORT_OPTIONS:MFILEVIEW}
+post-install-FILEVIEW-on:
${INSTALL_PROGRAM} ${WRKSRC}/src/utils/fileview/mulefileview ${STAGEDIR}${PREFIX}/bin
-.endif
.include <bsd.port.mk>