aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/amule
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2016-08-24 08:20:31 +0000
commit0f583d87000061087521fb77c44c9055d122d787 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /net-p2p/amule
parent558a51279c03199a7a20966174a8f0a1f33dc9b2 (diff)
downloadports-0f583d87000061087521fb77c44c9055d122d787.tar.gz
ports-0f583d87000061087521fb77c44c9055d122d787.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Notes
Notes: svn path=/head/; revision=420774
Diffstat (limited to 'net-p2p/amule')
-rw-r--r--net-p2p/amule/Makefile11
-rw-r--r--net-p2p/amule/pkg-plist24
2 files changed, 18 insertions, 17 deletions
diff --git a/net-p2p/amule/Makefile b/net-p2p/amule/Makefile
index e29fdb303d2c..a43c2f81241d 100644
--- a/net-p2p/amule/Makefile
+++ b/net-p2p/amule/Makefile
@@ -88,10 +88,11 @@ MMAP_CONFIGURE_ON= --enable-mmap
MONOLITHIC_CONFIGURE_OFF= --disable-monolithic
PLASMAMULE_CONFIGURE_ON= --enable-plasmamule
-PLASMAMULE_USE= KDE4=kdelibs QT4=dbus,gui,moc_build
+PLASMAMULE_USES= kde:4
+PLASMAMULE_USE= KDE=kdelibs QT4=dbus,gui,moc_build
PLASMAMULE_CONFIGURE_ENV= \
- ac_cv_path_KDE4_CONFIG=${KDE4_PREFIX}/bin/kde4-config \
- KBUILDSYCOCA=${KDE4_PREFIX}/bin/kbuildsycoca4 \
+ ac_cv_path_KDE4_CONFIG=${KDE_PREFIX}/bin/kde4-config \
+ KBUILDSYCOCA=${KDE_PREFIX}/bin/kbuildsycoca4 \
UPDATE_MIME_DATABASE=/usr/bin/true
UPNP_LIB_DEPENDS= libupnp.so:devel/upnp
@@ -123,8 +124,8 @@ post-patch: .SILENT
${WRKSRC}/docs/Makefile.in
.endif
.if ${PORT_OPTIONS:MPLASMAMULE}
- ${REINPLACE_CMD} -e 's|@prefix@|${KDE4_PREFIX}|' \
- -e 's|LDFLAGS =|& -L${KDE4_PREFIX}/lib |' \
+ ${REINPLACE_CMD} -e 's|@prefix@|${KDE_PREFIX}|' \
+ -e 's|LDFLAGS =|& -L${KDE_PREFIX}/lib |' \
${WRKSRC}/src/utils/plasmamule/Makefile.in
.endif
diff --git a/net-p2p/amule/pkg-plist b/net-p2p/amule/pkg-plist
index ea8ef0d9524d..23b2d4822ffe 100644
--- a/net-p2p/amule/pkg-plist
+++ b/net-p2p/amule/pkg-plist
@@ -1,15 +1,15 @@
-%%PLASMAMULE%%%%KDE4_PREFIX%%/bin/plasmamule-engine-feeder
-%%PLASMAMULE%%%%KDE4_PREFIX%%/lib/kde4/plasma-applet-plasmamule.so
-%%PLASMAMULE%%%%KDE4_PREFIX%%/lib/kde4/plasma-engine-plasmamule.so
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/applications/plasmamule-engine-feeder.desktop
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/icons/hicolor/scalable/mimetypes/application-x-emulecollection.svg
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/kde4/services/ed2k.protocol
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/kde4/services/magnet.protocol
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/kde4/services/plasma-applet-plasmamule.desktop
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/kde4/services/plasma-engine-plasmamule.desktop
-%%PLASMAMULE%%%%KDE4_PREFIX%%/share/mime/amule.xml
-%%PLASMAMULE%%@postexec [ -f %%LOCALBASE%%/bin/update-mime-database ] && %%LOCALBASE%%/bin/update-mime-database %%KDE4_PREFIX%%/share/mime >/dev/null 2>&1 || true
-%%PLASMAMULE%%@postunexec [ -f %%LOCALBASE%%/bin/update-mime-database ] && %%LOCALBASE%%/bin/update-mime-database %%KDE4_PREFIX%%/share/mime >/dev/null 2>&1 || true
+%%PLASMAMULE%%%%KDE_PREFIX%%/bin/plasmamule-engine-feeder
+%%PLASMAMULE%%%%KDE_PREFIX%%/lib/kde4/plasma-applet-plasmamule.so
+%%PLASMAMULE%%%%KDE_PREFIX%%/lib/kde4/plasma-engine-plasmamule.so
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/applications/plasmamule-engine-feeder.desktop
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/icons/hicolor/scalable/mimetypes/application-x-emulecollection.svg
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/kde4/services/ed2k.protocol
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/kde4/services/magnet.protocol
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/kde4/services/plasma-applet-plasmamule.desktop
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/kde4/services/plasma-engine-plasmamule.desktop
+%%PLASMAMULE%%%%KDE_PREFIX%%/share/mime/amule.xml
+%%PLASMAMULE%%@postexec [ -f %%LOCALBASE%%/bin/update-mime-database ] && %%LOCALBASE%%/bin/update-mime-database %%KDE_PREFIX%%/share/mime >/dev/null 2>&1 || true
+%%PLASMAMULE%%@postunexec [ -f %%LOCALBASE%%/bin/update-mime-database ] && %%LOCALBASE%%/bin/update-mime-database %%KDE_PREFIX%%/share/mime >/dev/null 2>&1 || true
%%ALC%%bin/alc
%%ALCC%%bin/alcc
%%MONOLITHIC%%bin/amule