aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/bitcoin-daemon
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2017-08-01 16:45:32 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2017-08-01 16:45:32 +0000
commit67ff3911521ef6338aa79a7b07e263baadd6fcf2 (patch)
treecd42b5654657230c51bab1c5481568068575f3fe /net-p2p/bitcoin-daemon
parent3449a6fb9215d844376d38563f0edd4ac7ead907 (diff)
downloadports-67ff3911521ef6338aa79a7b07e263baadd6fcf2.tar.gz
ports-67ff3911521ef6338aa79a7b07e263baadd6fcf2.zip
- net-p2p/bitcoin: fix path error in startup script files/bitcoin.in also
removes reliance on unnecessary cli script. - net-p2p/bitcoin-daemon: create the user/group for the daemon to use also install a sample configuration file. With these two patches a "pkg install bitcoin-daemon" followed by "service start bitcoind" will be sufficient to run as a non-privileged user and automatically connect to bitcoin live network; using /var/db/bitcoin to store blockchain data. PR: 215059 Submitted by: Christopher Hall <hsw@bitmark.com> Approved by: <robbak@robbak.com> (maintainer)
Notes
Notes: svn path=/head/; revision=447030
Diffstat (limited to 'net-p2p/bitcoin-daemon')
-rw-r--r--net-p2p/bitcoin-daemon/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net-p2p/bitcoin-daemon/Makefile b/net-p2p/bitcoin-daemon/Makefile
index 95e32bf0a629..bc08adba22f2 100644
--- a/net-p2p/bitcoin-daemon/Makefile
+++ b/net-p2p/bitcoin-daemon/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
MASTERDIR= ${.CURDIR}/../bitcoin
-PORTREVISION= 6
+PORTREVISION= 7
PKGNAMESUFFIX= -daemon
COMMENT= Virtual Peer-to-Peer Currency (Daemon)
@@ -14,6 +14,9 @@ ONLY_FOR_ARCHS_REASON= does not support big-endian architectures
OPTIONS_DEFINE= DEBUG HARDENING TESTS UPNP WALLET ZMQ
OPTIONS_DEFAULT= HARDENING UPNP WALLET
+USERS= bitcoin
+GROUPS= bitcoin
+
CONFIGURE_ARGS= --with-daemon \
--without-gui \
--without-libs \
@@ -24,4 +27,7 @@ PLIST_FILES= bin/bitcoind
USE_RC_SUBR= bitcoind
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/contrib/debian/examples/bitcoin.conf ${STAGEDIR}${PREFIX}/etc/bitcoin.conf.sample
+
.include "${MASTERDIR}/Makefile"