aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/ctcs
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-05-25 12:28:44 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-05-25 12:28:44 +0000
commit70a7bcebb4e6ceae322b8ec85b3259565d85827e (patch)
tree9f28526b1f5e60944560f0985904a43b13a48574 /net-p2p/ctcs
parenta54d3673cc13d731c2dda48d28a088e5f7255b8f (diff)
downloadports-70a7bcebb4e6ceae322b8ec85b3259565d85827e.tar.gz
ports-70a7bcebb4e6ceae322b8ec85b3259565d85827e.zip
net-p2p/ctcs: Install with executable permissions and correct shebang
PR: 238116 Submitted by: debdrup@gmail.com
Notes
Notes: svn path=/head/; revision=502572
Diffstat (limited to 'net-p2p/ctcs')
-rw-r--r--net-p2p/ctcs/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/net-p2p/ctcs/Makefile b/net-p2p/ctcs/Makefile
index 150dea104f20..e9fe8f42b6dd 100644
--- a/net-p2p/ctcs/Makefile
+++ b/net-p2p/ctcs/Makefile
@@ -3,15 +3,20 @@
PORTNAME= ctcs
PORTVERSION= 1.4.1
+PORTREVISION= 1
CATEGORIES= net-p2p
MASTER_SITES= SF/dtorrent/${PORTNAME}/${PORTVERSION}
MAINTAINER= dereckson@gmail.com
COMMENT= CTorrent monitoring and managing interface
-USES= perl5
+USES= perl5 shebangfix
USE_PERL5= run
-NO_BUILD= #
+
+SHEBANG_FILES= ctcs
+
+NO_ARCH= yes
+NO_BUILD= yes
PORTDOCS= readme.txt
PLIST_FILES= bin/ctcs
@@ -19,7 +24,7 @@ PLIST_FILES= bin/ctcs
OPTIONS_DEFINE= DOCS
do-install:
- ${INSTALL_DATA} ${WRKSRC}/ctcs ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/ctcs ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}