aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/ctorrent
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-06-11 04:44:18 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-06-11 04:44:18 +0000
commitc1ad24bc7b9aaecbfbc042447ec4c2002aef1f28 (patch)
tree13f6c71628b6beefb6e75b27d7ae1afb5bcf313b /net-p2p/ctorrent
parente8db1107615d5a0082d1bf7736337c4d0eb1adac (diff)
downloadports-c1ad24bc7b9aaecbfbc042447ec4c2002aef1f28.tar.gz
ports-c1ad24bc7b9aaecbfbc042447ec4c2002aef1f28.zip
- fix negative int bug
- take maintainership PR: 169283 Submitted by: dinoex Approved by: flz Obtained from: http://sourceforge.net/tracker/?func=detail&aid=3159066&group_id=202532&atid=981959
Notes
Notes: svn path=/head/; revision=320530
Diffstat (limited to 'net-p2p/ctorrent')
-rw-r--r--net-p2p/ctorrent/Makefile2
-rw-r--r--net-p2p/ctorrent/files/patch-negative-ints15
2 files changed, 16 insertions, 1 deletions
diff --git a/net-p2p/ctorrent/Makefile b/net-p2p/ctorrent/Makefile
index 82c22f23026b..6c400ff55d6a 100644
--- a/net-p2p/ctorrent/Makefile
+++ b/net-p2p/ctorrent/Makefile
@@ -12,7 +12,7 @@ CATEGORIES= net-p2p
MASTER_SITES= http://www.rahul.net/dholmes/ctorrent/
DISTNAME= ${PORTNAME}-dnh${PORTVERSION}
-MAINTAINER= flz@FreeBSD.org
+MAINTAINER= dinoex@FreeBSD.org
COMMENT= BitTorrent Client written in C for FreeBSD and Linux
GNU_CONFIGURE= yes
diff --git a/net-p2p/ctorrent/files/patch-negative-ints b/net-p2p/ctorrent/files/patch-negative-ints
new file mode 100644
index 000000000000..29e1c5fb629a
--- /dev/null
+++ b/net-p2p/ctorrent/files/patch-negative-ints
@@ -0,0 +1,15 @@
+allow negative integers ... should fix random "error, initial meta info failed"
+
+--- bencode.cpp.orig
++++ bencode.cpp
+@@ -44,6 +44,10 @@
+ p++; len--;
+ }
+
++ if( *p == '-'){
++ p++; len--;
++ }
++
+ for(psave = p; len && isdigit(*p); p++,len--) ;
+
+ if(!len || MAX_INT_SIZ < (p - psave) || *p != endchar) return 0;