aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/dclib
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-12-01 22:33:51 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-12-01 22:33:51 +0000
commit4545505b269024142b59601575e982e27102f0c6 (patch)
tree1ce201803e09b9cb30f79e46a9dae236682a1da4 /net-p2p/dclib
parentf13ef5853486a1440035b16e3d95967bc88b9afd (diff)
downloadports-4545505b269024142b59601575e982e27102f0c6.tar.gz
ports-4545505b269024142b59601575e982e27102f0c6.zip
- Add patch to chase latest API-change in libxml2
- Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=122943
Diffstat (limited to 'net-p2p/dclib')
-rw-r--r--net-p2p/dclib/Makefile1
-rw-r--r--net-p2p/dclib/files/patch-dclib-core-cxml.cpp23
2 files changed, 24 insertions, 0 deletions
diff --git a/net-p2p/dclib/Makefile b/net-p2p/dclib/Makefile
index 53c5fb4aefc3..7fc49e34d397 100644
--- a/net-p2p/dclib/Makefile
+++ b/net-p2p/dclib/Makefile
@@ -8,6 +8,7 @@
PORTNAME= dclib
PORTVERSION= 0.3.3
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://download.berlios.de/dcgui/
diff --git a/net-p2p/dclib/files/patch-dclib-core-cxml.cpp b/net-p2p/dclib/files/patch-dclib-core-cxml.cpp
new file mode 100644
index 000000000000..d185d95f5b20
--- /dev/null
+++ b/net-p2p/dclib/files/patch-dclib-core-cxml.cpp
@@ -0,0 +1,23 @@
+--- dclib/core/cxml.cpp.orig Thu Aug 12 10:32:06 2004
++++ dclib/core/cxml.cpp Wed Dec 1 23:14:00 2004
+@@ -149,10 +149,8 @@
+ printf("UTF8Toisolat1 transcoding fail: '%s'\n",s);
+ else if ( res == -1 )
+ printf("UTF8Toisolat1 fail: '%s'\n",s);
+- else if ( res == 0 )
+- r = (char*)b;
+ else
+- printf("CXml::xml_UTF8Toisolat1 error %d\n",res);
++ r = (char*)b;
+
+ free(b);
+
+@@ -180,7 +178,7 @@
+
+ if ( res == -1 )
+ printf("isolat1ToUTF8 fail: '%s'\n",s);
+- else if ( res == 0 )
++ else
+ r = (char*)b;
+
+ free(b);