aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/edonkey-tool-hash
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-08-13 02:23:24 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2004-08-13 02:23:24 +0000
commit0c8479d99613ed8d405307f4e082e5b2d14382f8 (patch)
treebc0a507fee5f2109f6a4fafe5c9ec92e7706ee9d /net-p2p/edonkey-tool-hash
parent3f0e7e442e0c8dc5fdfd8da7c8a81096626fd4ed (diff)
downloadports-0c8479d99613ed8d405307f4e082e5b2d14382f8.tar.gz
ports-0c8479d99613ed8d405307f4e082e5b2d14382f8.zip
Update to 0.4.0
Submitted by: dinoex
Notes
Notes: svn path=/head/; revision=116082
Diffstat (limited to 'net-p2p/edonkey-tool-hash')
-rw-r--r--net-p2p/edonkey-tool-hash/Makefile6
-rw-r--r--net-p2p/edonkey-tool-hash/distinfo4
-rw-r--r--net-p2p/edonkey-tool-hash/files/patch-processfile.c12
3 files changed, 17 insertions, 5 deletions
diff --git a/net-p2p/edonkey-tool-hash/Makefile b/net-p2p/edonkey-tool-hash/Makefile
index d662b449a198..42734de85a04 100644
--- a/net-p2p/edonkey-tool-hash/Makefile
+++ b/net-p2p/edonkey-tool-hash/Makefile
@@ -6,19 +6,19 @@
#
PORTNAME= edonkey
-PORTVERSION= 0.3.3
+PORTVERSION= 0.4.0
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ed2k-tools
PKGNAMESUFFIX= -tool-hash
-DISTNAME= ed2k-hash_${PORTVERSION}
+DISTNAME= ed2k_hash-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
COMMENT= Both calculates 'eDonkey/Overnet hashes' producing ed2k:// file links
PLIST_FILES= bin/edonkey-tool-hash
USE_REINPLACE= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER=15
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}/ed2k_hash-${PORTVERSION}
diff --git a/net-p2p/edonkey-tool-hash/distinfo b/net-p2p/edonkey-tool-hash/distinfo
index 37f9a2891ff8..4b207c9d025f 100644
--- a/net-p2p/edonkey-tool-hash/distinfo
+++ b/net-p2p/edonkey-tool-hash/distinfo
@@ -1,2 +1,2 @@
-MD5 (ed2k-hash_0.3.3.tar.gz) = 989a530afaefa3d797471d0ce5ef1d0a
-SIZE (ed2k-hash_0.3.3.tar.gz) = 347541
+MD5 (ed2k_hash-0.4.0.tar.gz) = 545d44d5e00078011f41a18e235f4af8
+SIZE (ed2k_hash-0.4.0.tar.gz) = 113158
diff --git a/net-p2p/edonkey-tool-hash/files/patch-processfile.c b/net-p2p/edonkey-tool-hash/files/patch-processfile.c
new file mode 100644
index 000000000000..b1553b8edf39
--- /dev/null
+++ b/net-p2p/edonkey-tool-hash/files/patch-processfile.c
@@ -0,0 +1,12 @@
+--- ed2k_hash/processfile.c.orig Wed Jun 25 00:51:21 2003
++++ ed2k_hash/processfile.c Mon Aug 9 20:39:37 2004
+@@ -123,6 +123,9 @@
+ return 0;
+ }
+
++#ifndef _SC_PAGE_SIZE
++#define _SC_PAGE_SIZE _SC_PAGESIZE
++#endif
+ pagesize = sysconf(_SC_PAGE_SIZE);
+
+ for (b=0; b < fi.blocks; b++)