aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/edonkey-tool-hash
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-02-20 22:36:43 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-02-20 22:36:43 +0000
commit0f311a05e57e61dc88e57327f36c0d9fc001d958 (patch)
tree59787593d32d0ecc6aba1249d791e17ffc54f0b3 /net-p2p/edonkey-tool-hash
parent9934f8fb7935398b0c50b495ec131dce3ea6ad69 (diff)
downloadports-0f311a05e57e61dc88e57327f36c0d9fc001d958.tar.gz
ports-0f311a05e57e61dc88e57327f36c0d9fc001d958.zip
- edonkey-tool-hash version 0.0.1: Both calculates 'eDonkey hashes'
and produces ed2k:// links for files
Notes
Notes: svn path=/head/; revision=55003
Diffstat (limited to 'net-p2p/edonkey-tool-hash')
-rw-r--r--net-p2p/edonkey-tool-hash/Makefile27
-rw-r--r--net-p2p/edonkey-tool-hash/distinfo1
-rw-r--r--net-p2p/edonkey-tool-hash/pkg-comment1
-rw-r--r--net-p2p/edonkey-tool-hash/pkg-descr6
-rw-r--r--net-p2p/edonkey-tool-hash/pkg-plist1
5 files changed, 36 insertions, 0 deletions
diff --git a/net-p2p/edonkey-tool-hash/Makefile b/net-p2p/edonkey-tool-hash/Makefile
new file mode 100644
index 000000000000..4ecca6ab2dc0
--- /dev/null
+++ b/net-p2p/edonkey-tool-hash/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: edonkey hash tool
+# Date created: Wed Feb 20 18:03:49 BRT 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= edonkey
+PORTVERSION= 0.0.1
+CATEGORIES= misc
+MASTER_SITES= http://users.aber.ac.uk/tpm01/ed2k_tools/
+PKGNAMESUFFIX= -tool-hash
+DISTNAME= ed2k_hash
+
+MAINTAINER= lioux@FreeBSD.org
+
+# I could have written a Makefile but I would rather
+# not waste inodes
+do-build:
+ @cd ${WRKSRC} && ${CC} -D__linux ${CFLAGS} ${LDFLAGS} -lmd \
+ ed2k_hash.c -o ${PORTNAME}${PKGNAMESUFFIX}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME}${PKGNAMESUFFIX} \
+ ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net-p2p/edonkey-tool-hash/distinfo b/net-p2p/edonkey-tool-hash/distinfo
new file mode 100644
index 000000000000..fcc84b1a7415
--- /dev/null
+++ b/net-p2p/edonkey-tool-hash/distinfo
@@ -0,0 +1 @@
+MD5 (ed2k_hash.tar.gz) = f4645f0f44b9332a6e5672d8b8a0f0ab
diff --git a/net-p2p/edonkey-tool-hash/pkg-comment b/net-p2p/edonkey-tool-hash/pkg-comment
new file mode 100644
index 000000000000..8ba672f57cb8
--- /dev/null
+++ b/net-p2p/edonkey-tool-hash/pkg-comment
@@ -0,0 +1 @@
+Both calculates 'eDonkey hashes' and produces ed2k:// links for files
diff --git a/net-p2p/edonkey-tool-hash/pkg-descr b/net-p2p/edonkey-tool-hash/pkg-descr
new file mode 100644
index 000000000000..f6fbcc985df5
--- /dev/null
+++ b/net-p2p/edonkey-tool-hash/pkg-descr
@@ -0,0 +1,6 @@
+This tool takes a file and calculates the final 'eDonkey hash' for
+it that you need if you want to create ed2k:// links to that file.
+It also spits out the complete ed2k:// link in the end and appends
+it to the file 'ed2k_links.txt' for easier copy-and-paste later on.
+
+WWW: http://users.aber.ac.uk/tpm01/ed2k_tools/ed2k_hash.html
diff --git a/net-p2p/edonkey-tool-hash/pkg-plist b/net-p2p/edonkey-tool-hash/pkg-plist
new file mode 100644
index 000000000000..5a5e8ae8d189
--- /dev/null
+++ b/net-p2p/edonkey-tool-hash/pkg-plist
@@ -0,0 +1 @@
+bin/edonkey-tool-hash