aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/eiskaltdcpp-gtk
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2013-05-10 17:34:56 +0000
committerMax Khon <fjoe@FreeBSD.org>2013-05-10 17:34:56 +0000
commit4b1c04bfbc9d17807b34f7cabf2034a7a48188a3 (patch)
tree33d1093b3315f2c20eb20efefb35f765710930f9 /net-p2p/eiskaltdcpp-gtk
parent05c536c40b3007a1cefbbde68e9b44dab219c28b (diff)
downloadports-4b1c04bfbc9d17807b34f7cabf2034a7a48188a3.tar.gz
ports-4b1c04bfbc9d17807b34f7cabf2034a7a48188a3.zip
- Unbreak the build (link with -lboost_system)
- Fix COMMENT for eiskaltdcpp-cli - Take maintainership Approved by: MAINTAINER
Notes
Notes: svn path=/head/; revision=317832
Diffstat (limited to 'net-p2p/eiskaltdcpp-gtk')
-rw-r--r--net-p2p/eiskaltdcpp-gtk/Makefile4
-rw-r--r--net-p2p/eiskaltdcpp-gtk/files/patch-CMakeLists.txt13
2 files changed, 12 insertions, 5 deletions
diff --git a/net-p2p/eiskaltdcpp-gtk/Makefile b/net-p2p/eiskaltdcpp-gtk/Makefile
index 8dda4d169366..7b16d72da0b8 100644
--- a/net-p2p/eiskaltdcpp-gtk/Makefile
+++ b/net-p2p/eiskaltdcpp-gtk/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= net-p2p
MASTER_SITES= GOOGLE_CODE
DISTNAME= eiskaltdcpp-${DISTVERSION}
-MAINTAINER= gelraen.ua@gmail.com
+MAINTAINER= fjoe@FreeBSD.org
COMMENT= EiskaltDC++ Direct Connect client GTK GUI
LICENSE= GPLv3
@@ -17,8 +17,6 @@ RUN_DEPENDS= ${LOCALBASE}/share/eiskaltdcpp/keep_me:${PORTSDIR}/net-p2p/eiskaltd
LIB_DEPENDS= eiskaltdcpp:${PORTSDIR}/net-p2p/eiskaltdcpp-lib
BUILD_DEPENDS+= chrpath:${PORTSDIR}/devel/chrpath
-BROKEN= does not build
-
CMAKE_ARGS+= -DBUILD_LIB:BOOL=OFF
PROJECTHOST= eiskaltdc
diff --git a/net-p2p/eiskaltdcpp-gtk/files/patch-CMakeLists.txt b/net-p2p/eiskaltdcpp-gtk/files/patch-CMakeLists.txt
index 526a0d24a262..f1f6e7321d3b 100644
--- a/net-p2p/eiskaltdcpp-gtk/files/patch-CMakeLists.txt
+++ b/net-p2p/eiskaltdcpp-gtk/files/patch-CMakeLists.txt
@@ -1,5 +1,5 @@
---- ./CMakeLists.txt.orig 2011-10-02 18:12:43.000000000 +0300
-+++ ./CMakeLists.txt 2011-10-10 11:16:46.000000000 +0300
+--- CMakeLists.txt.orig 2011-10-02 22:12:43.000000000 +0700
++++ CMakeLists.txt 2013-05-09 17:58:03.000000000 +0700
@@ -212,14 +212,14 @@
if (USE_LIBGNOME2)
@@ -17,6 +17,15 @@
else (USE_LIBNOTIFY)
message (STATUS "Building without libnotify support")
endif (USE_LIBNOTIFY)
+@@ -256,7 +256,7 @@
+ endif()
+ message (STATUS "USED LOCAL BOOST HEADERS")
+ else (LOCAL_BOOST)
+- find_package (Boost REQUIRED)
++ find_package (Boost COMPONENTS system REQUIRED)
+ if (Boost_VERSION VERSION_LESS 103900)
+ add_definitions(-DFIX_FOR_OLD_BOOST)
+ endif()
@@ -370,16 +370,14 @@
else (MINGW)
set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++0x")