aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/eiskaltdcpp-gtk
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2012-12-21 04:05:15 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2012-12-21 04:05:15 +0000
commit748d75ba78eb89a6fe36363fc566232fafcdfc19 (patch)
tree1b2348cce1d747f00a050132edbbba3e549f7de8 /net-p2p/eiskaltdcpp-gtk
parent6434abfc09aef64dcfaec3f0822b1bb0c0edfc3e (diff)
downloadports-748d75ba78eb89a6fe36363fc566232fafcdfc19.tar.gz
ports-748d75ba78eb89a6fe36363fc566232fafcdfc19.zip
Replace the use of _GCC_BUILD_DEPENDS (which was never meant to be
used outside of Mk/bsd.gcc.mk) by _GCC_RUNTIME. This is still not ideal, but at least a documented stopgap, and it avoids the manual construction of the directory to be added to rpath. As a side effect, the Makefiles become a tad simpler. On the way, update to USE_GCC=4.6+ per pending work of linimon and myself. Approved by: maintainer
Notes
Notes: svn path=/head/; revision=309337
Diffstat (limited to 'net-p2p/eiskaltdcpp-gtk')
-rw-r--r--net-p2p/eiskaltdcpp-gtk/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/net-p2p/eiskaltdcpp-gtk/Makefile b/net-p2p/eiskaltdcpp-gtk/Makefile
index 0086a49b8bc6..b641bc6bb50b 100644
--- a/net-p2p/eiskaltdcpp-gtk/Makefile
+++ b/net-p2p/eiskaltdcpp-gtk/Makefile
@@ -25,7 +25,7 @@ CMAKE_ARGS+= -DBUILD_LIB:BOOL=OFF
PROJECTHOST= eiskaltdc
USE_XZ= yes
-USE_GCC= 4.4+
+USE_GCC= 4.6+
USE_CMAKE= yes
USE_GETTEXT= yes
USE_OPENSSL= yes
@@ -75,9 +75,7 @@ CMAKE_ARGS+= -DUSE_LIBNOTIFY:BOOL=OFF
USE_OPENSSL_PORT=yes
.endif
-GCC_LIBS= "${LOCALBASE}/lib/${_GCC_BUILD_DEPENDS}"
-
post-build:
- ${LOCALBASE}/bin/chrpath -r "${GCC_LIBS}" "${WRKSRC}/${PORTNAME}/${PORTNAME}"
+ ${LOCALBASE}/bin/chrpath -r "${_GCC_RUNTIME}" "${WRKSRC}/${PORTNAME}/${PORTNAME}"
.include <bsd.port.mk>