aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/frost
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-05 21:54:47 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-05 21:54:47 +0000
commit7c52eeb81af7d915c4c91fc3dc585ff3d0f86154 (patch)
treec0e86564d9ca558e5bb751529e342bf746fb208f /net-p2p/frost
parent2f7656898a2f06c51bb67e2d0a36130838852df2 (diff)
downloadports-7c52eeb81af7d915c4c91fc3dc585ff3d0f86154.tar.gz
ports-7c52eeb81af7d915c4c91fc3dc585ff3d0f86154.zip
Notes
Diffstat (limited to 'net-p2p/frost')
-rw-r--r--net-p2p/frost/Makefile36
-rw-r--r--net-p2p/frost/distinfo9
-rw-r--r--net-p2p/frost/files/wrapper.sh11
-rw-r--r--net-p2p/frost/pkg-descr16
4 files changed, 38 insertions, 34 deletions
diff --git a/net-p2p/frost/Makefile b/net-p2p/frost/Makefile
index d5b0e3c7dd08..0548a165f418 100644
--- a/net-p2p/frost/Makefile
+++ b/net-p2p/frost/Makefile
@@ -6,51 +6,46 @@
#
PORTNAME= frost
-PORTVERSION= 1.2.0.20051020
-PORTREVISION= 2
+PORTVERSION= 1.2.0.20070719
PORTEPOCH= 2
CATEGORIES= net-p2p java
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= jtcfrost
-DISTNAME= ${PORTNAME}-20-Oct-2005-java${JAVA_VERSION:S/.//}
+DISTNAME= ${PORTNAME}-19-Jul-2007
-MAINTAINER= ports@FreeBSD.org
-COMMENT= File-sharing tool for FreeNet with Usenet like forum support
+MAINTAINER= peter.thoenen@yahoo.com
+COMMENT= Frost is a Freenet client that provides messenger and file services
USE_JAVA= yes
+JAVA_VERSION= 1.5+
JAVA_RUN= yes
USE_ZIP= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
PLIST_SUB= JAR_DIR=${JAR_DIR}
-.ifdef(WITH_JDK15)
-JAVA_VERSION= 1.5
-.else
-JAVA_VERSION= 1.4
-.endif
-
DATADIR= ${JAVASHAREDIR}/${PORTNAME}
JAVAVM= ${LOCALBASE}/bin/java
JAR_DIR= ${JAVAJARDIR:S,^${PREFIX}/,,}/${PORTNAME}
JAR_FILE= frost.jar
JAR_FILES= frost.jar lib/fecImpl.jar \
- lib/BCastle.jar \
+ lib/BCastle.jar lib/datechooser.jar \
lib/fec-native.jar \
- lib/genChkImpl.jar lib/xercesImpl.jar \
- lib/mailapi.jar lib/smtp.jar \
- lib/skinlf.jar lib/skinlfFix.jar \
- lib/xml-apis.jar
+ lib/genChkImpl.jar lib/gnu-regexp-1.1.4.jar \
+ lib/xercesImpl.jar \
+ lib/joda-time.jar lib/mckoidb.jar \
+ lib/perst15.jar lib/skinlf.jar \
+ lib/skinlfFix.jar lib/xml-apis.jar
DOC_FILES= doc/Frost.tex doc/authors.txt doc/gpl.txt \
doc/SkinLFLicense.txt \
- doc/hypersonic_lic.txt doc/HISTORY.txt \
- help/faq.txt help/history.txt
+ doc/hypersonic_lic.txt doc/HISTORY.txt
PORTDOCS= ${DOC_FILES:C,^.*/,,}
DATA_FILES= config/boards.xml.default \
jtc.ico \
+ store/applayerdb.conf \
themes/themepack.zip
PLIST_FILES= bin/${PORTNAME}
@@ -73,9 +68,6 @@ DESKTOP_ENTRIES= "Frost" "A Freenet Client" \
false
pre-everything::
-.ifndef(WITH_JDK15)
- @${ECHO_MSG} '===> Define WITH_JDK15 to use jdk 1.5 instead of jdk 1.4'
-.endif
post-patch:
@${SED} -e "s|%%PREFIX%%|${PREFIX}|; \
diff --git a/net-p2p/frost/distinfo b/net-p2p/frost/distinfo
index 6f7f8c201083..f145fadee0e3 100644
--- a/net-p2p/frost/distinfo
+++ b/net-p2p/frost/distinfo
@@ -1,6 +1,3 @@
-MD5 (frost-20-Oct-2005-java14.zip) = d1f81569f5489fd0a07bbf9d0db4b693
-SHA256 (frost-20-Oct-2005-java14.zip) = baffc8e07f7f3c4496dd9f5484004a35f38b5578f321291b026af0a40a2f4548
-SIZE (frost-20-Oct-2005-java14.zip) = 3897153
-MD5 (frost-20-Oct-2005-java15.zip) = 2686d4a3445b04692d62b24568d15fef
-SHA256 (frost-20-Oct-2005-java15.zip) = 5123adc21b65e082e3bc003bcb17a62b00867b852ee01da7d829b40963cdd406
-SIZE (frost-20-Oct-2005-java15.zip) = 3871113
+MD5 (frost-19-Jul-2007.zip) = 14e4e740b4487f23a584ccc359c62f98
+SHA256 (frost-19-Jul-2007.zip) = 17095700a4b24870a426e6598cfc150407a0e032fa4434d8c83128624f0d71dc
+SIZE (frost-19-Jul-2007.zip) = 7092779
diff --git a/net-p2p/frost/files/wrapper.sh b/net-p2p/frost/files/wrapper.sh
index 6f7474911c08..78dc182f71fa 100644
--- a/net-p2p/frost/files/wrapper.sh
+++ b/net-p2p/frost/files/wrapper.sh
@@ -9,7 +9,7 @@ JAR_DIR="%%JAR_DIR%%"
JAR_FILE="%%JAR_FILE%%"
DATADIR="%%DATADIR%%"
HOME_DIR=${HOME}/.frost
-CLASSPATH="${PREFIX}/${JAR_DIR}/BCastle.jar:${PREFIX}/${JAR_DIR}/fec-native.jar:${PREFIX}/${JAR_DIR}/fecImpl.jar:${PREFIX}/${JAR_DIR}/frost.jar:${PREFIX}/${JAR_DIR}/genChkImpl.jar:${PREFIX}/${JAR_DIR}/jocache.jar:${PREFIX}/${JAR_DIR}/mailapi.jar:${PREFIX}/${JAR_DIR}/skinlf.jar:${PREFIX}/${JAR_DIR}/skinlfFix.jar:${PREFIX}/${JAR_DIR}/smtp.jar:${PREFIX}/${JAR_DIR}/xercesImpl.jar:${PREFIX}/${JAR_DIR}/xml-apis.jar"
+CLASSPATH="${PREFIX}/${JAR_DIR}/BCastle.jar:${PREFIX}/${JAR_DIR}/datechooser.jar:${PREFIX}/${JAR_DIR}/fec-native.jar:${PREFIX}/${JAR_DIR}/fecImpl.jar:${PREFIX}/${JAR_DIR}/frost.jar:${PREFIX}/${JAR_DIR}/genChkImpl.jar:${PREFIX}/${JAR_DIR}/gnu-regexp-1.1.4.jar:${PREFIX}/${JAR_DIR}/joda-time.jar:${PREFIX}/${JAR_DIR}/perst15.jar:${PREFIX}/${JAR_DIR}/skinlf.jar:${PREFIX}/${JAR_DIR}/skinlfFix.jar:${PREFIX}/${JAR_DIR}/mckoidb.jar:${PREFIX}/${JAR_DIR}/xercesImpl.jar:${PREFIX}/${JAR_DIR}/xml-apis.jar"
if [ ! -d ${HOME_DIR}/config ]
then
@@ -22,9 +22,16 @@ ln -sf ${PREFIX}/${DATADIR}/boards.xml.default \
if [ ! -d ${HOME_DIR}/themes ]
then
mkdir -p ${HOME_DIR}/themes
+ ln -sf ${PREFIX}/${DATADIR}/themepack.zip ${HOME_DIR}/themes/themepack.zip
+fi
+
+if [ ! -d ${HOME_DIR}/store ]
+then
+ mkdir -p ${HOME_DIR}/store
+ ln -sf ${PREFIX}/${DATADIR}/applayerdb.conf \
+ ${HOME_DIR}/store/applayerdb.conf
fi
-ln -sf ${PREFIX}/${DATADIR}/themepack.zip ${HOME_DIR}/themes/themepack.zip
ln -sf ${PREFIX}/${DATADIR}/aquathemepack.zip \
${HOME_DIR}/themes/aquathemepack.zip
diff --git a/net-p2p/frost/pkg-descr b/net-p2p/frost/pkg-descr
index 9d9054b9ef6d..56e833b52bbf 100644
--- a/net-p2p/frost/pkg-descr
+++ b/net-p2p/frost/pkg-descr
@@ -1,7 +1,15 @@
-[ excerpt from FreeNet website ]
+Frost is a Freenet client that provides newsgroup-like messaging, private
+encrypted messages, file upload and download functionality and a file sharing
+system.
-Frost is a file-sharing tool for FreeNet. It also has chat forums
-which allow people to chat anonymously over FreeNet. It now supports
-FEC (which makes downloads more reliable)
+If this is your first time trying Frost, you'll see its quite different from
+other filesharing programs. Its anonymous, and yet has a very personal
+atmosphere.
+
+If you know how to use newsgroups, you'll find Frost very easy to use and will
+feel right at home. If you're used to other filesharing apps, you should know
+that the best way to find what you're looking for is to ask for it. If you
+can't find it in the search results, post a message to the relevant board and
+someone will respond to you. Common questions are answered in the Support area.
WWW: http://jtcfrost.sourceforge.net/