aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/go-ethereum
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-04-30 18:37:51 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-04-30 18:37:51 +0000
commit70412f689b96752976760ba74e72c9272205f8d5 (patch)
tree5f71cdcb749c86cee3b06d3982193e86c00efaf4 /net-p2p/go-ethereum
parente728786ee1801a64a39c13882448f90fcd0906a1 (diff)
downloadports-70412f689b96752976760ba74e72c9272205f8d5.tar.gz
ports-70412f689b96752976760ba74e72c9272205f8d5.zip
New port: net-p2p/go-ethereum
Ethereum is a community-driven project aiming to decentralize the internet and return it to its democratic roots. It is a platform for building and running applications which do not need to rely on trust and cannot be controlled by any central authority. This is the Go implementation of Ethereum y/w paper WWW: https://github.com/ethereum/go-ethereum PR: 201954 Submitted by: enriquefynn@gmail.com
Notes
Notes: svn path=/head/; revision=414354
Diffstat (limited to 'net-p2p/go-ethereum')
-rw-r--r--net-p2p/go-ethereum/Makefile49
-rw-r--r--net-p2p/go-ethereum/distinfo2
-rw-r--r--net-p2p/go-ethereum/pkg-descr8
-rw-r--r--net-p2p/go-ethereum/pkg-plist6
4 files changed, 65 insertions, 0 deletions
diff --git a/net-p2p/go-ethereum/Makefile b/net-p2p/go-ethereum/Makefile
new file mode 100644
index 000000000000..cd89604b5cfe
--- /dev/null
+++ b/net-p2p/go-ethereum/Makefile
@@ -0,0 +1,49 @@
+# $FreeBSD$
+
+PORTNAME= go-ethereum
+PORTVERSION= 1.3.6
+DISTVERSIONPREFIX= v
+CATEGORIES= net-p2p
+
+MAINTAINER= enriquefynn@gmail.com
+COMMENT= Go implementation of the Ethereum y/w paper
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= libgmp.so:math/gmp
+BUILD_DEPENDS= go:lang/go
+RUN_DEPENDS= go:lang/go
+
+OPTIONS_DEFINE= BOOTNODE ETHTEST EVM DISASM RLPDUMP
+OPTIONS_SUB= yes
+
+BOOTNODE_DESC= Runs a bootstrap node for the Discovery Protocol
+ETHTEST_DESC= Test tool which runs with the tests suite
+EVM_DESC= A generic Ethereum Virtual Machine
+DISASM_DESC= Disassembles EVM code
+RLPDUMP_DESC= Prints RLP structures
+
+USE_GITHUB= yes
+GH_ACCOUNT= ethereum
+
+USE_GCC= 4.8+
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/geth ${STAGEDIR}${PREFIX}/bin
+ @if [ ${PORT_OPTIONS:MBOOTNODE} ]; then \
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/bootnode ${STAGEDIR}${PREFIX}/bin; \
+ fi;
+ @if [ ${PORT_OPTIONS:METHTEST} ]; then \
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/ethtest ${STAGEDIR}${PREFIX}/bin; \
+ fi;
+ @if [ ${PORT_OPTIONS:MEVM} ]; then \
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/evm ${STAGEDIR}${PREFIX}/bin; \
+ fi;
+ @if [ ${PORT_OPTIONS:MDISASM} ]; then \
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/disasm ${STAGEDIR}${PREFIX}/bin; \
+ fi;
+ @if [ ${PORT_OPTIONS:MRLPDUMP} ]; then \
+ ${INSTALL_PROGRAM} ${WRKSRC}/build/bin/rlpdump ${STAGEDIR}${PREFIX}/bin; \
+ fi;
+
+.include <bsd.port.mk>
diff --git a/net-p2p/go-ethereum/distinfo b/net-p2p/go-ethereum/distinfo
new file mode 100644
index 000000000000..dab86876b786
--- /dev/null
+++ b/net-p2p/go-ethereum/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ethereum-go-ethereum-v1.3.6_GH0.tar.gz) = 83e90eeca939a0e721bd58dbb76b832bbd0b944f790a34d55eb22684570a5023
+SIZE (ethereum-go-ethereum-v1.3.6_GH0.tar.gz) = 10778610
diff --git a/net-p2p/go-ethereum/pkg-descr b/net-p2p/go-ethereum/pkg-descr
new file mode 100644
index 000000000000..432c50cd252c
--- /dev/null
+++ b/net-p2p/go-ethereum/pkg-descr
@@ -0,0 +1,8 @@
+Ethereum is a community-driven project aiming to decentralize the internet and
+return it to its democratic roots. It is a platform for building and running
+applications which do not need to rely on trust and cannot be controlled by
+any central authority.
+
+This is the Go implementation of Ethereum y/w paper
+
+WWW: https://github.com/ethereum/go-ethereum
diff --git a/net-p2p/go-ethereum/pkg-plist b/net-p2p/go-ethereum/pkg-plist
new file mode 100644
index 000000000000..d55416ba6aad
--- /dev/null
+++ b/net-p2p/go-ethereum/pkg-plist
@@ -0,0 +1,6 @@
+bin/geth
+%%BOOTNODE%%bin/bootnode
+%%ETHTEST%%bin/ethtest
+%%EVM%%bin/evm
+%%DISASM%%bin/disasm
+%%RLPDUMP%%bin/rlpdump