aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/jigdo
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2011-09-23 22:26:39 +0000
commit6f6fbe4bdf9851de1eb6ebef5287e3007846045e (patch)
tree3b556699991305af672fba96e0e8b6bb88bcc7da /net-p2p/jigdo
parent86f8cde1da39aadc3efbc11e60998d886c86c36e (diff)
downloadports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.tar.gz
ports-6f6fbe4bdf9851de1eb6ebef5287e3007846045e.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Notes
Notes: svn path=/head/; revision=282282
Diffstat (limited to 'net-p2p/jigdo')
-rw-r--r--net-p2p/jigdo/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-p2p/jigdo/Makefile b/net-p2p/jigdo/Makefile
index c6ca9b328ad4..c9d2b00d943c 100644
--- a/net-p2p/jigdo/Makefile
+++ b/net-p2p/jigdo/Makefile
@@ -24,7 +24,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
WITH_BDB_VER?= 43
-CONFIGURE_ENV+= "CPPFLAGS=-I${LOCALBASE}/include"
+CPPFLAGS+= -I${LOCALBASE}/include
OPTIONS= GUI "Build the gtk2 gui" off \
BDB "Build with Berkeley DB support (for jigdo-file cache)" on \
@@ -44,8 +44,8 @@ PLIST_SUB+= GUI="@comment "
.endif
.if !defined(WITHOUT_BDB)
-CONFIGURE_ENV+= CPPFLAGS=-I${BDB_INCLUDE_DIR} \
- LIBS=-L${BDB_LIB_DIR}
+CONFIGURE_ENV+= LIBS=-L${BDB_LIB_DIR}
+CPPFLAGS+= -I${BDB_INCLUDE_DIR}
CONFIGURE_ARGS+=--with-libdb=-l${BDB_LIB_CXX_NAME}
USE_BDB= ${WITH_BDB_VER}
.else