aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent-rasterbar
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2015-01-19 08:22:38 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2015-01-19 08:22:38 +0000
commit828d3043d68552d8f2c04937fc53e3168f2118f4 (patch)
treeb9bd9b4d4d54bb551ddc7dddefae4a33b84fc252 /net-p2p/libtorrent-rasterbar
parent6709be3950e95a4736e6cefd3a2abfa5cce74e7d (diff)
downloadports-828d3043d68552d8f2c04937fc53e3168f2118f4.tar.gz
ports-828d3043d68552d8f2c04937fc53e3168f2118f4.zip
net-p2p/libtorrent-rasterbar: fix build with LibreSSL
Add upstream-provided patch to fix build with LibreSSL. Default (OpenSSL) setup isn't affected, so no PORTREVISION bump. Remove pkg-message, that have no use. Submitted by: Corey <merlincorey@hushmail.me> (by private email)
Notes
Notes: svn path=/head/; revision=377391
Diffstat (limited to 'net-p2p/libtorrent-rasterbar')
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile2
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-libressl38
-rw-r--r--net-p2p/libtorrent-rasterbar/files/pkg-message.in9
3 files changed, 38 insertions, 11 deletions
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index 19c4208f5d18..db644ccf183a 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -35,8 +35,6 @@ CONFIGURE_ARGS= --disable-static \
SHLIB_VER= 7
PLIST_SUB+= SHLIB_VER="${SHLIB_VER}"
-SUB_FILES= pkg-message
-
PORTDOCS= *
DOCSRCDIR1= ${WRKSRC}
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-libressl b/net-p2p/libtorrent-rasterbar/files/patch-libressl
new file mode 100644
index 000000000000..88072dd79414
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar/files/patch-libressl
@@ -0,0 +1,38 @@
+--- src/torrent.cpp (revision 10629)
++++ src/torrent.cpp (revision 10630)
+@@ -82,6 +82,7 @@
+ #ifdef TORRENT_USE_OPENSSL
+ #include "libtorrent/ssl_stream.hpp"
+ #include <boost/asio/ssl/context.hpp>
++#include <openssl/rand.h>
+ #if BOOST_VERSION >= 104700
+ #include <boost/asio/ssl/verify_context.hpp>
+ #endif // BOOST_VERSION
+Index: src/peer_connection.cpp
+===================================================================
+--- src/peer_connection.cpp (revision 10629)
++++ src/peer_connection.cpp (revision 10630)
+@@ -65,6 +65,10 @@
+ #include <set>
+ #endif
+
++#ifdef TORRENT_USE_OPENSSL
++#include <openssl/rand.h>
++#endif
++
+ //#define TORRENT_CORRUPT_DATA
+
+ using boost::shared_ptr;
+Index: src/session_impl.cpp
+===================================================================
+--- src/session_impl.cpp (revision 10629)
++++ src/session_impl.cpp (revision 10630)
+@@ -149,6 +149,7 @@
+ #ifdef TORRENT_USE_OPENSSL
+
+ #include <openssl/crypto.h>
++#include <openssl/rand.h>
+
+ namespace
+ {
+
diff --git a/net-p2p/libtorrent-rasterbar/files/pkg-message.in b/net-p2p/libtorrent-rasterbar/files/pkg-message.in
deleted file mode 100644
index b2cc1dcff86e..000000000000
--- a/net-p2p/libtorrent-rasterbar/files/pkg-message.in
+++ /dev/null
@@ -1,9 +0,0 @@
-===============================================================================
-
-libtorrent-rasterbar has been installed.
-
-When you have problems to build Source please reinstall
-
-devel/boost-libs
-
-===============================================================================