aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent-rasterbar
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-12-20 03:18:13 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-12-20 03:18:13 +0000
commitc5ead6a7ed337e68125ff904ad63d79db7bb4100 (patch)
treeb4e24c58c4964831423cc468b9c5a0fcfb3fa83f /net-p2p/libtorrent-rasterbar
parentdc4be4c458652f57a7210551adfdd02a1e3bc237 (diff)
downloadports-c5ead6a7ed337e68125ff904ad63d79db7bb4100.tar.gz
ports-c5ead6a7ed337e68125ff904ad63d79db7bb4100.zip
Notes
Diffstat (limited to 'net-p2p/libtorrent-rasterbar')
-rw-r--r--net-p2p/libtorrent-rasterbar/Makefile41
-rw-r--r--net-p2p/libtorrent-rasterbar/distinfo6
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-CMakeLists.txt10
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-bindings_python_compile__flags.in5
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-boost-1.6953
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-boost-1.70193
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-boost-1.7221
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-include_libtorrent_tommath.h11
-rw-r--r--net-p2p/libtorrent-rasterbar/files/patch-test_test_ssl.cpp41
-rw-r--r--net-p2p/libtorrent-rasterbar/pkg-plist93
10 files changed, 158 insertions, 316 deletions
diff --git a/net-p2p/libtorrent-rasterbar/Makefile b/net-p2p/libtorrent-rasterbar/Makefile
index 8fe7ad28a044..94f3209a9fc1 100644
--- a/net-p2p/libtorrent-rasterbar/Makefile
+++ b/net-p2p/libtorrent-rasterbar/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= libtorrent-rasterbar
-DISTVERSION= 1.1.10
-PORTREVISION= 6
+DISTVERSIONPREFIX= libtorrent-
+DISTVERSION= 1_2_2
CATEGORIES= net-p2p
-MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/libtorrent-${PORTVERSION:S/./_/g}/
MAINTAINER= yuri@FreeBSD.org
COMMENT= C++ library implementing a BitTorrent client
@@ -17,31 +16,43 @@ LIB_DEPENDS= libboost_chrono.so:devel/boost-libs \
libboost_random.so:devel/boost-libs \
libboost_system.so:devel/boost-libs
-USES= cmake compiler:c++14-lang iconv:wchar_t libtool pathfix pkgconfig ssl
+USES= cmake compiler:c++14-lang iconv:wchar_t libtool pathfix pkgconfig python:2.7,test shebangfix ssl
+LDFLAGS+= -L${LOCALBASE}/lib ${ICONV_LIB}
+SHEBANG_FILES= test/socks.py test/web_server.py
+USE_GITHUB= yes
+GH_ACCOUNT= arvidn
+GH_PROJECT= libtorrent
USE_LDCONFIG= yes
-SHLIB_VER= 9
+SHLIB_VER= 10
PLIST_SUB+= SHLIB_VER="${SHLIB_VER}"
DOCFILES= AUTHORS ChangeLog
PORTDOCS= ${DOCFILES} docs/*
PORTEXAMPLES= *.cpp
-OPTIONS_DEFINE= DEBUG DOCS EXAMPLES LOGGING
-OPTIONS_DEFAULT=LOGGING
-OPTIONS_SUB= yes
-LOGGING_DESC= Enable disk stat logging and logging to disk
+OPTIONS_DEFINE= DOCS EXAMPLES LOGGING
+OPTIONS_DEFAULT= LOGGING
+OPTIONS_SUB= yes
+LOGGING_DESC= Enable logging to disk
-DEBUG_CONFIGURE_ENABLE= debug
-EXAMPLES_CONFIGURE_ENABLE= examples
-LOGGING_CONFIGURE_ENABLE= logging disk-stats
+EXAMPLES_CMAKE_BOOL= build_examples
+LOGGING_CMAKE_BOOL= logging
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/include|${PREFIX}/include|' \
${WRKSRC}/Jamfile
+ @${REINPLACE_CMD} -e 's|python|${PYTHON_CMD}|' \
+ ${WRKSRC}/test/setup_transfer.cpp
post-install:
- @${RM} ${STAGEDIR}${PREFIX}/include/libtorrent/tommath.h.orig ${STAGEDIR}${PREFIX}/include/libtorrent/Makefile*
+ @${RM} ${STAGEDIR}${PREFIX}/include/libtorrent/Makefile*
+ # Workaround for -DTHREADS_HAVE_PTHREAD_ARG:BOOL=YES being set in
+ # Mk/Uses/cmake.mk
+ # References: https://mariadb.atlassian.net/browse/MDEV-9388
+ # https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=206169
+ @${REINPLACE_CMD} 's/-l-pthread/-lpthread/' \
+ ${STAGEDIR}${PREFIX}/libdata/pkgconfig/libtorrent-rasterbar.pc
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@@ -54,9 +65,9 @@ post-install-EXAMPLES-on:
${INSTALL_DATA} ${WRKSRC}/examples/${PORTEXAMPLES} \
${STAGEDIR}${EXAMPLESDIR}
-do-test: # broken: https://github.com/arvidn/libtorrent/issues/3327
+do-test:
@cd ${BUILD_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -Dbuild_tests=ON ${CMAKE_SOURCE_PATH} && \
+ ${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -Dbuild_tests:BOOL=ON ${CMAKE_SOURCE_PATH} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
diff --git a/net-p2p/libtorrent-rasterbar/distinfo b/net-p2p/libtorrent-rasterbar/distinfo
index f10367fe9917..c5136ec2e679 100644
--- a/net-p2p/libtorrent-rasterbar/distinfo
+++ b/net-p2p/libtorrent-rasterbar/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1538843172
-SHA256 (libtorrent-rasterbar-1.1.10.tar.gz) = 07b2b391e0d16bc693d793e352338488a0e41f3130b70884bb2e0270ea00b8c2
-SIZE (libtorrent-rasterbar-1.1.10.tar.gz) = 3902542
+TIMESTAMP = 1571671656
+SHA256 (arvidn-libtorrent-libtorrent-1_2_2_GH0.tar.gz) = 353793a234858e8dae9ee4a37d59c8c5297b718cc7ae3efe5798f004c0da6856
+SIZE (arvidn-libtorrent-libtorrent-1_2_2_GH0.tar.gz) = 3584187
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-CMakeLists.txt b/net-p2p/libtorrent-rasterbar/files/patch-CMakeLists.txt
deleted file mode 100644
index 42fb9c447cd2..000000000000
--- a/net-p2p/libtorrent-rasterbar/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,10 +0,0 @@
---- CMakeLists.txt.orig 2018-10-06 18:06:13 UTC
-+++ CMakeLists.txt
-@@ -1,6 +1,6 @@
- cmake_minimum_required(VERSION 3.8)
- project(libtorrent)
--set (SOVERSION "8")
-+set (SOVERSION "9") # https://github.com/arvidn/libtorrent/issues/3326
- set (VERSION "1.1.10")
-
- set(sources
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-bindings_python_compile__flags.in b/net-p2p/libtorrent-rasterbar/files/patch-bindings_python_compile__flags.in
deleted file mode 100644
index 9d9fb85cc6da..000000000000
--- a/net-p2p/libtorrent-rasterbar/files/patch-bindings_python_compile__flags.in
+++ /dev/null
@@ -1,5 +0,0 @@
---- bindings/python/compile_flags.in.orig 2017-07-02 16:18:10 UTC
-+++ bindings/python/compile_flags.in
-@@ -1 +1 @@
---I@top_srcdir@/include @COMPILETIME_OPTIONS@ @CPPFLAGS@ @BOOST_CPPFLAGS@ @PYTHON_CXXFLAGS@ @OPENSSL_INCLUDES@
-+-I@top_srcdir@/include @COMPILETIME_OPTIONS@ @CPPFLAGS@ -std=c++11 @BOOST_CPPFLAGS@ @OPENSSL_INCLUDES@
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-boost-1.69 b/net-p2p/libtorrent-rasterbar/files/patch-boost-1.69
deleted file mode 100644
index d5969e03bcdc..000000000000
--- a/net-p2p/libtorrent-rasterbar/files/patch-boost-1.69
+++ /dev/null
@@ -1,53 +0,0 @@
-https://github.com/arvidn/libtorrent/commit/a5da48edd4be
-
---- include/libtorrent/disk_io_job.hpp.orig 2018-10-05 09:19:18 UTC
-+++ include/libtorrent/disk_io_job.hpp
-@@ -43,7 +43,7 @@ POSSIBILITY OF SUCH DAMAGE.
- #include <string>
- #include <boost/function/function1.hpp>
- #include <boost/shared_ptr.hpp>
--#include <boost/shared_ptr.hpp>
-+#include <boost/noncopyable.hpp>
-
- #include "libtorrent/aux_/disable_warnings_pop.hpp"
-
---- include/libtorrent/kademlia/observer.hpp.orig 2018-10-05 09:19:18 UTC
-+++ include/libtorrent/kademlia/observer.hpp
-@@ -42,6 +42,7 @@ POSSIBILITY OF SUCH DAMAGE.
- #include <boost/detail/atomic_count.hpp>
- #include <boost/intrusive_ptr.hpp>
- #include <boost/cstdint.hpp>
-+#include <boost/noncopyable.hpp>
-
- #include "libtorrent/aux_/disable_warnings_pop.hpp"
-
---- include/libtorrent/proxy_base.hpp.orig 2018-10-05 09:19:18 UTC
-+++ include/libtorrent/proxy_base.hpp
-@@ -42,6 +42,7 @@ POSSIBILITY OF SUCH DAMAGE.
- #include "libtorrent/aux_/disable_warnings_push.hpp"
- #include <boost/function/function1.hpp>
- #include <boost/shared_ptr.hpp>
-+#include <boost/noncopyable.hpp>
- #include "libtorrent/aux_/disable_warnings_pop.hpp"
-
- namespace libtorrent {
---- include/libtorrent/tracker_manager.hpp.orig 2018-10-05 09:19:21 UTC
-+++ include/libtorrent/tracker_manager.hpp
-@@ -50,6 +50,7 @@ POSSIBILITY OF SUCH DAMAGE.
- #include <boost/tuple/tuple.hpp>
- #include <boost/unordered_map.hpp>
- #include <boost/optional.hpp>
-+#include <boost/noncopyable.hpp>
-
- #ifdef TORRENT_USE_OPENSSL
- // there is no forward declaration header for asio
---- src/kademlia/dht_storage.cpp.orig 2018-10-05 09:19:18 UTC
-+++ src/kademlia/dht_storage.cpp
-@@ -38,6 +38,7 @@ POSSIBILITY OF SUCH DAMAGE.
- #include <boost/bind.hpp>
- #include <boost/function/function1.hpp>
- #include <boost/tuple/tuple.hpp>
-+#include <boost/noncopyable.hpp>
-
- #include "libtorrent/aux_/disable_warnings_pop.hpp"
-
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-boost-1.70 b/net-p2p/libtorrent-rasterbar/files/patch-boost-1.70
deleted file mode 100644
index 68b5ff07e636..000000000000
--- a/net-p2p/libtorrent-rasterbar/files/patch-boost-1.70
+++ /dev/null
@@ -1,193 +0,0 @@
-https://github.com/arvidn/libtorrent/commit/76c2794923c4
-
---- include/libtorrent/io_service.hpp.orig 2018-10-05 09:19:18 UTC
-+++ include/libtorrent/io_service.hpp
-@@ -53,6 +53,7 @@ POSSIBILITY OF SUCH DAMAGE.
- #endif
-
- #include "libtorrent/aux_/disable_warnings_pop.hpp"
-+#include "libtorrent/io_service_fwd.hpp"
-
- #ifdef __OBJC__
- #undef Protocol
---- include/libtorrent/io_service_fwd.hpp.orig 2018-10-05 09:19:18 UTC
-+++ include/libtorrent/io_service_fwd.hpp
-@@ -65,10 +65,19 @@ namespace boost { namespace asio {
- namespace libtorrent
- {
- #if defined TORRENT_BUILD_SIMULATOR
-- typedef sim::asio::io_service io_service;
-+ using io_service = sim::asio::io_service;
- #else
-- typedef boost::asio::io_service io_service;
-+ using io_service = boost::asio::io_service;
- #endif
-+
-+#if BOOST_VERSION >= 107000
-+template <typename T>
-+io_service& get_io_service(T& o) { return static_cast<io_service&>(o.get_executor().context()); }
-+#else
-+template <typename T>
-+io_service& get_io_service(T& o) { return o.get_io_service(); }
-+#endif
-+
- }
-
- #endif
---- include/libtorrent/proxy_base.hpp.orig 2018-10-05 09:19:18 UTC
-+++ include/libtorrent/proxy_base.hpp
-@@ -249,7 +249,7 @@ class proxy_base : boost::noncopyable (public)
-
- io_service& get_io_service()
- {
-- return m_sock.get_io_service();
-+ return lt::get_io_service(m_sock);
- }
-
- lowest_layer_type& lowest_layer()
---- include/libtorrent/tracker_manager.hpp.orig 2018-10-05 09:19:21 UTC
-+++ include/libtorrent/tracker_manager.hpp
-@@ -283,7 +283,7 @@ namespace libtorrent
- virtual void on_timeout(error_code const& ec) = 0;
- virtual ~timeout_handler() {}
-
-- io_service& get_io_service() { return m_timeout.get_io_service(); }
-+ io_service& get_io_service() { return lt::get_io_service(m_timeout); }
-
- private:
-
---- include/libtorrent/udp_socket.hpp.orig 2018-10-05 09:19:18 UTC
-+++ include/libtorrent/udp_socket.hpp
-@@ -80,7 +80,7 @@ namespace libtorrent
- };
-
- bool is_open() const { return m_abort == false; }
-- io_service& get_io_service() { return m_ipv4_sock.get_io_service(); }
-+ io_service& get_io_service() { return lt::get_io_service(m_ipv4_sock); }
-
- void subscribe(udp_socket_observer* o);
- void unsubscribe(udp_socket_observer* o);
---- src/http_connection.cpp.orig 2018-10-05 09:19:18 UTC
-+++ src/http_connection.cpp
-@@ -150,7 +150,7 @@ void http_connection::get(std::string const& url, time
-
- if (ec)
- {
-- m_timer.get_io_service().post(boost::bind(&http_connection::callback
-+ lt::get_io_service(m_timer).post(boost::bind(&http_connection::callback
- , me, ec, static_cast<char*>(NULL), 0));
- return;
- }
-@@ -162,7 +162,7 @@ void http_connection::get(std::string const& url, time
- )
- {
- error_code err(errors::unsupported_url_protocol);
-- m_timer.get_io_service().post(boost::bind(&http_connection::callback
-+ lt::get_io_service(m_timer).post(boost::bind(&http_connection::callback
- , me, err, static_cast<char*>(NULL), 0));
- return;
- }
-@@ -263,7 +263,7 @@ void http_connection::start(std::string const& hostnam
-
- if (ec)
- {
-- m_timer.get_io_service().post(boost::bind(&http_connection::callback
-+ lt::get_io_service(m_timer).post(boost::bind(&http_connection::callback
- , me, ec, static_cast<char*>(NULL), 0));
- return;
- }
-@@ -303,7 +303,7 @@ void http_connection::start(std::string const& hostnam
-
- if (i2p_conn->proxy().type != settings_pack::i2p_proxy)
- {
-- m_timer.get_io_service().post(boost::bind(&http_connection::callback
-+ lt::get_io_service(m_timer).post(boost::bind(&http_connection::callback
- , me, error_code(errors::no_i2p_router), static_cast<char*>(NULL), 0));
- return;
- }
-@@ -337,7 +337,7 @@ void http_connection::start(std::string const& hostnam
- m_ssl_ctx->set_verify_mode(ssl::context::verify_none, ec);
- if (ec)
- {
-- m_timer.get_io_service().post(boost::bind(&http_connection::callback
-+ lt::get_io_service(m_timer).post(boost::bind(&http_connection::callback
- , me, ec, static_cast<char*>(NULL), 0));
- return;
- }
-@@ -349,7 +349,7 @@ void http_connection::start(std::string const& hostnam
- // assume this is not a tracker connection. Tracker connections that
- // shouldn't be subject to the proxy should pass in NULL as the proxy
- // pointer.
-- instantiate_connection(m_timer.get_io_service()
-+ instantiate_connection(lt::get_io_service(m_timer)
- , proxy ? *proxy : null_proxy, m_sock, userdata, NULL, false, false);
-
- if (m_bind_addr)
-@@ -358,7 +358,7 @@ void http_connection::start(std::string const& hostnam
- m_sock.bind(tcp::endpoint(*m_bind_addr, 0), ec);
- if (ec)
- {
-- m_timer.get_io_service().post(boost::bind(&http_connection::callback
-+ lt::get_io_service(m_timer).post(boost::bind(&http_connection::callback
- , me, ec, static_cast<char*>(NULL), 0));
- return;
- }
-@@ -367,7 +367,7 @@ void http_connection::start(std::string const& hostnam
- setup_ssl_hostname(m_sock, hostname, ec);
- if (ec)
- {
-- m_timer.get_io_service().post(boost::bind(&http_connection::callback
-+ lt::get_io_service(m_timer).post(boost::bind(&http_connection::callback
- , me, ec, static_cast<char*>(NULL), 0));
- return;
- }
---- src/lsd.cpp.orig 2018-10-05 09:19:18 UTC
-+++ src/lsd.cpp
-@@ -112,12 +112,12 @@ void lsd::debug_log(char const* fmt, ...) const
- void lsd::start(error_code& ec)
- {
- m_socket.open(boost::bind(&lsd::on_announce, self(), _1, _2, _3)
-- , m_broadcast_timer.get_io_service(), ec);
-+ , lt::get_io_service(m_broadcast_timer), ec);
- if (ec) return;
-
- #if TORRENT_USE_IPV6
- m_socket6.open(boost::bind(&lsd::on_announce, self(), _1, _2, _3)
-- , m_broadcast_timer.get_io_service(), ec);
-+ , lt::get_io_service(m_broadcast_timer), ec);
- #endif
- }
-
---- src/natpmp.cpp.orig 2018-10-05 09:19:18 UTC
-+++ src/natpmp.cpp
-@@ -89,7 +89,7 @@ void natpmp::start()
- mutex::scoped_lock l(m_mutex);
-
- error_code ec;
-- address gateway = get_default_gateway(m_socket.get_io_service(), ec);
-+ address gateway = get_default_gateway(lt::get_io_service(m_socket), ec);
- if (ec)
- {
- char msg[200];
---- src/upnp.cpp.orig 2018-10-05 09:19:18 UTC
-+++ src/upnp.cpp
-@@ -135,7 +135,7 @@ void upnp::start()
- {
- error_code ec;
- m_socket.open(boost::bind(&upnp::on_reply, self(), _1, _2, _3)
-- , m_refresh_timer.get_io_service(), ec);
-+ , lt::get_io_service(m_refresh_timer), ec);
-
- m_mappings.reserve(10);
- }
---- test/test_fast_extension.cpp.orig 2018-10-05 09:19:21 UTC
-+++ test/test_fast_extension.cpp
-@@ -453,7 +453,7 @@ boost::shared_ptr<torrent_info> setup_peer(tcp::socket
- }
- else
- {
-- tcp::acceptor l(s.get_io_service());
-+ tcp::acceptor l(lt::get_io_service(s));
- l.open(tcp::v4());
- l.bind(tcp::endpoint(address_v4::from_string("127.0.0.1")
- , 3000 + rand() % 60000));
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-boost-1.72 b/net-p2p/libtorrent-rasterbar/files/patch-boost-1.72
index f82053349895..155402c72e36 100644
--- a/net-p2p/libtorrent-rasterbar/files/patch-boost-1.72
+++ b/net-p2p/libtorrent-rasterbar/files/patch-boost-1.72
@@ -1,10 +1,19 @@
-https://github.com/arvidn/libtorrent/commit/e4b812b50b0a
+From 48fa5343b5d99416ba9606f5f52fba58b93dffe6 Mon Sep 17 00:00:00 2001
+From: Arvid Norberg <arvid@cs.umu.se>
+Date: Wed, 13 Nov 2019 15:36:05 +0000
+Subject: [PATCH] add executor_type to socket_type
---- include/libtorrent/socket_type.hpp.orig 2018-10-05 09:19:18 UTC
-+++ include/libtorrent/socket_type.hpp
-@@ -192,6 +192,10 @@ namespace libtorrent
- typedef tcp::socket::receive_buffer_size receive_buffer_size;
- typedef tcp::socket::send_buffer_size send_buffer_size;
+---
+ include/libtorrent/aux_/socket_type.hpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/include/libtorrent/aux_/socket_type.hpp b/include/libtorrent/aux_/socket_type.hpp
+index 1342d39adf..7cbe90fd68 100644
+--- include/libtorrent/aux_/socket_type.hpp
++++ include/libtorrent/aux_/socket_type.hpp
+@@ -184,6 +184,10 @@ namespace aux {
+ using receive_buffer_size = tcp::socket::receive_buffer_size;
+ using send_buffer_size = tcp::socket::send_buffer_size;
+#if BOOST_VERSION >= 106600
+ using executor_type = tcp::socket::executor_type;
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-include_libtorrent_tommath.h b/net-p2p/libtorrent-rasterbar/files/patch-include_libtorrent_tommath.h
deleted file mode 100644
index ba5d60d7d970..000000000000
--- a/net-p2p/libtorrent-rasterbar/files/patch-include_libtorrent_tommath.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/libtorrent/tommath.h.orig 2016-08-29 10:51:22 UTC
-+++ include/libtorrent/tommath.h
-@@ -111,7 +111,7 @@ extern "C" {
-
- /* use arc4random on platforms that support it */
- #ifdef MP_USE_ALT_RAND
-- #define MP_GEN_RANDOM() arc4random()
-+ #define MP_GEN_RANDOM() (int)arc4random()
- #else
- #define MP_GEN_RANDOM() rand()
- #endif
diff --git a/net-p2p/libtorrent-rasterbar/files/patch-test_test_ssl.cpp b/net-p2p/libtorrent-rasterbar/files/patch-test_test_ssl.cpp
new file mode 100644
index 000000000000..717957ef69d2
--- /dev/null
+++ b/net-p2p/libtorrent-rasterbar/files/patch-test_test_ssl.cpp
@@ -0,0 +1,41 @@
+From c8f3063f25ab0c90998b08711a7ecf2eed5677ba Mon Sep 17 00:00:00 2001
+From: arvidn <arvid@libtorrent.org>
+Date: Mon, 14 Oct 2019 12:35:17 +0200
+Subject: [PATCH] fix SSL test
+
+---
+ test/test_ssl.cpp | 14 ++++++++++++--
+ 1 file changed, 12 insertions(+), 2 deletions(-)
+
+diff --git a/test/test_ssl.cpp b/test/test_ssl.cpp
+index 63a1ae75fa..47f713c737 100644
+--- test/test_ssl.cpp
++++ test/test_ssl.cpp
+@@ -101,7 +101,12 @@ bool on_alert(alert const* a)
+ if (peer_disconnected_alert const* e = alert_cast<peer_disconnected_alert>(a))
+ {
+ ++peer_disconnects;
+- if (strcmp(e->error.category().name(), boost::asio::error::get_ssl_category().name()) == 0)
++ string_view const cat = e->error.category().name();
++ if (cat == boost::asio::error::get_ssl_category().name()
++#if BOOST_VERSION >= 106400
++ || cat == boost::asio::ssl::error::get_stream_category().name()
++#endif
++ )
+ ++ssl_peer_disconnects;
+
+ std::printf("--- peer_errors: %d ssl_disconnects: %d\n"
+@@ -113,7 +118,12 @@ bool on_alert(alert const* a)
+ ++peer_disconnects;
+ ++peer_errors;
+
+- if (strcmp(e->error.category().name(), boost::asio::error::get_ssl_category().name()) == 0)
++ string_view const cat = e->error.category().name();
++ if (cat == boost::asio::error::get_ssl_category().name()
++#if BOOST_VERSION >= 106400
++ || cat == boost::asio::ssl::error::get_stream_category().name()
++#endif
++ )
+ ++ssl_peer_disconnects;
+
+ std::printf("--- peer_errors: %d ssl_disconnects: %d\n"
diff --git a/net-p2p/libtorrent-rasterbar/pkg-plist b/net-p2p/libtorrent-rasterbar/pkg-plist
index bf6427544157..6d13ba038f80 100644
--- a/net-p2p/libtorrent-rasterbar/pkg-plist
+++ b/net-p2p/libtorrent-rasterbar/pkg-plist
@@ -4,27 +4,65 @@ include/libtorrent/address.hpp
include/libtorrent/alert.hpp
include/libtorrent/alert_manager.hpp
include/libtorrent/alert_types.hpp
-include/libtorrent/alloca.hpp
-include/libtorrent/allocator.hpp
include/libtorrent/announce_entry.hpp
include/libtorrent/assert.hpp
-include/libtorrent/aux_/alert_manager_variadic_emplace.hpp
+include/libtorrent/aux_/aligned_storage.hpp
+include/libtorrent/aux_/aligned_union.hpp
+include/libtorrent/aux_/alloca.hpp
include/libtorrent/aux_/allocating_handler.hpp
+include/libtorrent/aux_/array.hpp
+include/libtorrent/aux_/bind_to_device.hpp
+include/libtorrent/aux_/block_cache_reference.hpp
include/libtorrent/aux_/byteswap.hpp
+include/libtorrent/aux_/container_wrapper.hpp
+include/libtorrent/aux_/cppint_import_export.hpp
include/libtorrent/aux_/cpuid.hpp
+include/libtorrent/aux_/deferred_handler.hpp
+include/libtorrent/aux_/deque.hpp
+include/libtorrent/aux_/dev_random.hpp
include/libtorrent/aux_/disable_warnings_pop.hpp
include/libtorrent/aux_/disable_warnings_push.hpp
+include/libtorrent/aux_/disk_job_fence.hpp
include/libtorrent/aux_/escape_string.hpp
+include/libtorrent/aux_/export.hpp
include/libtorrent/aux_/file_progress.hpp
+include/libtorrent/aux_/ffs.hpp
+include/libtorrent/aux_/generate_peer_id.hpp
+include/libtorrent/aux_/has_block.hpp
+include/libtorrent/aux_/instantiate_connection.hpp
+include/libtorrent/aux_/io.hpp
+include/libtorrent/aux_/ip_notifier.hpp
+include/libtorrent/aux_/listen_socket_handle.hpp
+include/libtorrent/aux_/lsd.hpp
include/libtorrent/aux_/merkle.hpp
+include/libtorrent/aux_/noexcept_movable.hpp
+include/libtorrent/aux_/numeric_cast.hpp
include/libtorrent/aux_/openssl.hpp
+include/libtorrent/aux_/path.hpp
+include/libtorrent/aux_/portmap.hpp
include/libtorrent/aux_/proxy_settings.hpp
+include/libtorrent/aux_/range.hpp
include/libtorrent/aux_/route.h
+include/libtorrent/aux_/scope_end.hpp
include/libtorrent/aux_/session_call.hpp
include/libtorrent/aux_/session_impl.hpp
include/libtorrent/aux_/session_interface.hpp
include/libtorrent/aux_/session_settings.hpp
+include/libtorrent/aux_/session_udp_sockets.hpp
+include/libtorrent/aux_/set_socket_buffer.hpp
+include/libtorrent/aux_/socket_type.hpp
+include/libtorrent/aux_/storage_piece_set.hpp
+include/libtorrent/aux_/storage_utils.hpp
+include/libtorrent/aux_/string_ptr.hpp
+include/libtorrent/aux_/suggest_piece.hpp
+include/libtorrent/aux_/throw.hpp
include/libtorrent/aux_/time.hpp
+include/libtorrent/aux_/torrent_impl.hpp
+include/libtorrent/aux_/unique_ptr.hpp
+include/libtorrent/aux_/vector.hpp
+include/libtorrent/aux_/win_crypto_provider.hpp
+include/libtorrent/aux_/win_util.hpp
+include/libtorrent/aux_/windows.hpp
include/libtorrent/bandwidth_limit.hpp
include/libtorrent/bandwidth_manager.hpp
include/libtorrent/bandwidth_queue_entry.hpp
@@ -37,7 +75,6 @@ include/libtorrent/bloom_filter.hpp
include/libtorrent/broadcast_socket.hpp
include/libtorrent/bt_peer_connection.hpp
include/libtorrent/buffer.hpp
-include/libtorrent/build_config.hpp
include/libtorrent/chained_buffer.hpp
include/libtorrent/choker.hpp
include/libtorrent/close_reason.hpp
@@ -52,17 +89,16 @@ include/libtorrent/disk_buffer_pool.hpp
include/libtorrent/disk_interface.hpp
include/libtorrent/disk_io_job.hpp
include/libtorrent/disk_io_thread.hpp
+include/libtorrent/disk_io_thread_pool.hpp
include/libtorrent/disk_job_pool.hpp
include/libtorrent/disk_observer.hpp
+include/libtorrent/download_priority.hpp
include/libtorrent/ed25519.hpp
include/libtorrent/entry.hpp
include/libtorrent/enum_net.hpp
include/libtorrent/error.hpp
include/libtorrent/error_code.hpp
-include/libtorrent/export.hpp
include/libtorrent/extensions.hpp
-include/libtorrent/extensions/lt_trackers.hpp
-include/libtorrent/extensions/metadata_transfer.hpp
include/libtorrent/extensions/smart_ban.hpp
include/libtorrent/extensions/ut_metadata.hpp
include/libtorrent/extensions/ut_pex.hpp
@@ -70,9 +106,11 @@ include/libtorrent/file.hpp
include/libtorrent/file_pool.hpp
include/libtorrent/file_storage.hpp
include/libtorrent/fingerprint.hpp
+include/libtorrent/flags.hpp
include/libtorrent/fwd.hpp
include/libtorrent/gzip.hpp
include/libtorrent/hasher.hpp
+include/libtorrent/hasher512.hpp
include/libtorrent/heterogeneous_queue.hpp
include/libtorrent/hex.hpp
include/libtorrent/http_connection.hpp
@@ -82,21 +120,26 @@ include/libtorrent/http_stream.hpp
include/libtorrent/http_tracker_connection.hpp
include/libtorrent/i2p_stream.hpp
include/libtorrent/identify_client.hpp
-include/libtorrent/instantiate_connection.hpp
+include/libtorrent/index_range.hpp
include/libtorrent/invariant_check.hpp
include/libtorrent/io.hpp
include/libtorrent/io_service.hpp
include/libtorrent/io_service_fwd.hpp
include/libtorrent/ip_filter.hpp
include/libtorrent/ip_voter.hpp
+include/libtorrent/kademlia/announce_flags.hpp
include/libtorrent/kademlia/dht_observer.hpp
+include/libtorrent/kademlia/dht_settings.hpp
+include/libtorrent/kademlia/dht_state.hpp
include/libtorrent/kademlia/dht_storage.hpp
include/libtorrent/kademlia/dht_tracker.hpp
include/libtorrent/kademlia/direct_request.hpp
include/libtorrent/kademlia/dos_blocker.hpp
+include/libtorrent/kademlia/ed25519.hpp
include/libtorrent/kademlia/find_data.hpp
include/libtorrent/kademlia/get_item.hpp
include/libtorrent/kademlia/get_peers.hpp
+include/libtorrent/kademlia/io.hpp
include/libtorrent/kademlia/item.hpp
include/libtorrent/kademlia/msg.hpp
include/libtorrent/kademlia/node.hpp
@@ -107,20 +150,24 @@ include/libtorrent/kademlia/put_data.hpp
include/libtorrent/kademlia/refresh.hpp
include/libtorrent/kademlia/routing_table.hpp
include/libtorrent/kademlia/rpc_manager.hpp
+include/libtorrent/kademlia/sample_infohashes.hpp
include/libtorrent/kademlia/traversal_algorithm.hpp
+include/libtorrent/kademlia/types.hpp
include/libtorrent/lazy_entry.hpp
include/libtorrent/link.hpp
include/libtorrent/linked_list.hpp
include/libtorrent/lsd.hpp
include/libtorrent/magnet_uri.hpp
-include/libtorrent/max.hpp
include/libtorrent/natpmp.hpp
-include/libtorrent/network_thread_pool.hpp
+include/libtorrent/netlink.hpp
include/libtorrent/operations.hpp
+include/libtorrent/optional.hpp
include/libtorrent/packet_buffer.hpp
+include/libtorrent/packet_pool.hpp
include/libtorrent/parse_url.hpp
include/libtorrent/part_file.hpp
include/libtorrent/pe_crypto.hpp
+include/libtorrent/pex_flags.hpp
include/libtorrent/peer.hpp
include/libtorrent/peer_class.hpp
include/libtorrent/peer_class_set.hpp
@@ -133,32 +180,35 @@ include/libtorrent/peer_info.hpp
include/libtorrent/peer_list.hpp
include/libtorrent/peer_request.hpp
include/libtorrent/performance_counters.hpp
+include/libtorrent/piece_block.hpp
include/libtorrent/piece_block_progress.hpp
include/libtorrent/piece_picker.hpp
include/libtorrent/platform_util.hpp
+include/libtorrent/portmap.hpp
include/libtorrent/proxy_base.hpp
include/libtorrent/puff.hpp
include/libtorrent/random.hpp
+include/libtorrent/read_resume_data.hpp
include/libtorrent/receive_buffer.hpp
include/libtorrent/request_blocks.hpp
include/libtorrent/resolve_links.hpp
include/libtorrent/resolver.hpp
include/libtorrent/resolver_interface.hpp
-include/libtorrent/rss.hpp
include/libtorrent/session.hpp
include/libtorrent/session_handle.hpp
include/libtorrent/session_settings.hpp
include/libtorrent/session_stats.hpp
include/libtorrent/session_status.hpp
+include/libtorrent/session_types.hpp
include/libtorrent/settings_pack.hpp
include/libtorrent/sha1.hpp
include/libtorrent/sha1_hash.hpp
+include/libtorrent/sha512.hpp
include/libtorrent/sliding_average.hpp
include/libtorrent/socket.hpp
include/libtorrent/socket_io.hpp
-include/libtorrent/socket_type.hpp
-include/libtorrent/socket_type_fwd.hpp
include/libtorrent/socks5_stream.hpp
+include/libtorrent/span.hpp
include/libtorrent/ssl_stream.hpp
include/libtorrent/stack_allocator.hpp
include/libtorrent/stat.hpp
@@ -166,16 +216,12 @@ include/libtorrent/stat_cache.hpp
include/libtorrent/storage.hpp
include/libtorrent/storage_defs.hpp
include/libtorrent/string_util.hpp
+include/libtorrent/string_view.hpp
include/libtorrent/tailqueue.hpp
-include/libtorrent/thread.hpp
-include/libtorrent/thread_pool.hpp
include/libtorrent/time.hpp
include/libtorrent/timestamp_history.hpp
-include/libtorrent/tommath.h
-include/libtorrent/tommath_class.h
-include/libtorrent/tommath_private.h
-include/libtorrent/tommath_superclass.h
include/libtorrent/torrent.hpp
+include/libtorrent/torrent_flags.hpp
include/libtorrent/torrent_handle.hpp
include/libtorrent/torrent_info.hpp
include/libtorrent/torrent_peer.hpp
@@ -184,8 +230,8 @@ include/libtorrent/torrent_status.hpp
include/libtorrent/tracker_manager.hpp
include/libtorrent/udp_socket.hpp
include/libtorrent/udp_tracker_connection.hpp
-include/libtorrent/uncork_interface.hpp
include/libtorrent/union_endpoint.hpp
+include/libtorrent/units.hpp
include/libtorrent/upnp.hpp
include/libtorrent/utf8.hpp
include/libtorrent/utp_socket_manager.hpp
@@ -194,7 +240,14 @@ include/libtorrent/vector_utils.hpp
include/libtorrent/version.hpp
include/libtorrent/web_connection_base.hpp
include/libtorrent/web_peer_connection.hpp
+include/libtorrent/write_resume_data.hpp
include/libtorrent/xml_parse.hpp
+lib/cmake/LibtorrentRasterbar/LibtorrentRasterbarConfig.cmake
+lib/cmake/LibtorrentRasterbar/LibtorrentRasterbarConfigVersion.cmake
+lib/cmake/LibtorrentRasterbar/LibtorrentRasterbarTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/LibtorrentRasterbar/LibtorrentRasterbarTargets.cmake
lib/libtorrent-rasterbar.so
+lib/libtorrent-rasterbar.so.1.2.2
lib/libtorrent-rasterbar.so.%%SHLIB_VER%%
libdata/pkgconfig/libtorrent-rasterbar.pc
+share/cmake/Modules/FindLibtorrentRasterbar.cmake