aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/libtorrent
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-11-02 08:32:28 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-11-02 08:32:28 +0000
commita1a91e218218009bee9fd8a1a7c364438e497f89 (patch)
treec31a15027992c850693132762b2c96cbfcf64cf7 /net-p2p/libtorrent
parentf29bf5fd0eb15d1e46735d84c84224b633d7f6f5 (diff)
downloadports-a1a91e218218009bee9fd8a1a7c364438e497f89.tar.gz
ports-a1a91e218218009bee9fd8a1a7c364438e497f89.zip
Notes
Diffstat (limited to 'net-p2p/libtorrent')
-rw-r--r--net-p2p/libtorrent/Makefile7
-rw-r--r--net-p2p/libtorrent/files/patch-src__torrent__connection_manager.h10
2 files changed, 16 insertions, 1 deletions
diff --git a/net-p2p/libtorrent/Makefile b/net-p2p/libtorrent/Makefile
index 6a964623f3f3..9406705f72bc 100644
--- a/net-p2p/libtorrent/Makefile
+++ b/net-p2p/libtorrent/Makefile
@@ -39,8 +39,13 @@ CONFIGURE_ENV= OPENSSL_LIBS="-L/usr/lib -ssl -crypto" OPENSSL_CFLAGS="-I/usr/inc
CONFIGURE_ARGS+= --disable-debug
+# Workaround to build on > 10.x
+.if ${OSVERSION} >= 1000000
+USE_GCC= yes
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's/-O3/${CFLAGS}/' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
.if ${PORT_OPTIONS:MKQUEUE}
CONFIGURE_ARGS+= --with-kqueue
diff --git a/net-p2p/libtorrent/files/patch-src__torrent__connection_manager.h b/net-p2p/libtorrent/files/patch-src__torrent__connection_manager.h
new file mode 100644
index 000000000000..dc26b729c50e
--- /dev/null
+++ b/net-p2p/libtorrent/files/patch-src__torrent__connection_manager.h
@@ -0,0 +1,10 @@
+--- ./src/torrent/connection_manager.h.orig 2013-10-25 09:26:00.379999391 +0100
++++ ./src/torrent/connection_manager.h 2013-10-25 09:26:18.486351796 +0100
+@@ -40,6 +40,7 @@
+ #define LIBTORRENT_CONNECTION_MANAGER_H
+
+ #include <sys/socket.h>
++#include <sys/types.h>
+ #include <arpa/inet.h>
+ #include <netinet/in.h>
+ #include <netinet/in_systm.h>